Closed Bug 1208003 Opened 6 years ago Closed 6 years ago

[TV 2.5] Implement the functionalities of the TV remote control app

Categories

(Firefox OS Graveyard :: Gaia::TV, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.5+)

RESOLVED FIXED
feature-b2g 2.5+

People

(Reporter: lchang, Assigned: lchang)

References

Details

(Whiteboard: [partner-cherry-picked<2015/11/10>])

Attachments

(1 file)

We have two options related to TV remote control.

- enable/disable remote control server
- enable/disable PIN code verification for pairing
Assignee: nobody → lchang
feature-b2g: --- → 2.5+
No longer blocks: TV_RemoteControl_TVSide
Depends on: 1212726
Comment on attachment 8671179 [details] [review]
[gaia] luke-chang:1208003_tv_remote_control_app > mozilla-b2g:master

Hi Evelyn,

This is the first bug of the TV remote control app. Please take a look.

Note that this bug depends on Bug 1212726 so I cherry-picked that patch in this pull request so you can review it more easily.

Thanks.
Attachment #8671179 - Flags: review?(ehung)
Duplicate of this bug: 1208004
Summary: [TV 2.5] Provide toggles for configuring remote control function → [TV 2.5] Implement the functionalities of the TV remote control app
Comment on attachment 8671179 [details] [review]
[gaia] luke-chang:1208003_tv_remote_control_app > mozilla-b2g:master

This patch achieves following tasks:

- a stand-alone TV remote control app
- showing server's IP on the screen
- showing error messages when server disabled or offline
- configuration page
- ability to revoke paired devices
- l10n

The remaining tasks are as follows:

- show the QRCode (Bug 1203853)
- apply the visual spec (Bug 1212402)
Status: NEW → ASSIGNED
Comment on attachment 8671179 [details] [review]
[gaia] luke-chang:1208003_tv_remote_control_app > mozilla-b2g:master

Please see my github comments. Basically are renaming some variables, and add comments to make the code more readable. I suggest re-architecture a bit and let config section be more isolated from app.js.
Attachment #8671179 - Flags: review?(ehung)
Comment on attachment 8671179 [details] [review]
[gaia] luke-chang:1208003_tv_remote_control_app > mozilla-b2g:master

Hi Evelyn,

I've addressed the comments and redesigned my structure. Since it's a big change, I keep the previous one on PR in case you'd like to refer to it during reviewing. Thanks.
Attachment #8671179 - Flags: review?(ehung)
Comment on attachment 8671179 [details] [review]
[gaia] luke-chang:1208003_tv_remote_control_app > mozilla-b2g:master

r+ with comment addressed. Thanks.
Attachment #8671179 - Flags: review?(ehung) → review+
tests passed: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=f99179bf9443becb77e64453431e9a55f0cc6af8

landed on master: https://github.com/mozilla-b2g/gaia/commit/7b59f91935415bc88685c601f1c6181b986d6036
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [partner-cherry-pick]
Whiteboard: [partner-cherry-pick] → [partner-cherry-picked<2015/11/10>]
You need to log in before you can comment on or make changes to this bug.