Cannot sync phone agenda with car system over bluetooth

RESOLVED DUPLICATE of bug 892179

Status

Firefox OS
Gaia::Bluetooth
RESOLVED DUPLICATE of bug 892179
2 years ago
2 years ago

People

(Reporter: Mihai Barbat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Build ID: 20150820202733

Steps to reproduce:

Pair my Flame phone with the car system of my BMW using the Bluetooth connection


Actual results:

The car system is stuck while trying to sync the contacts from the phone. Still I can very well call or pick up calls over Bluetooth in the car using the Flame. The issue is only when the car needs to get the contacts from the phone.


Expected results:

All contacts should have been shared with the car system
Bluetooth Phone Book Access Profile function landed on m-c last month but gaia part is not done yet. AFAIK the first release that fully supported PBAP would be v2.2R. I'm not sure when Gaia PBAP code will land in m-c, it's not in v2.5 feature planning.
(Reporter)

Updated

2 years ago
Component: Bluetooth → Gaia::Bluetooth
(Reporter)

Updated

2 years ago
Flags: needinfo?(tzimmermann)
Hi, please see Shawn's comment.
Flags: needinfo?(tzimmermann)
Shawn, I wonder if there's a quick fix to avoid this problem.
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #3)
> Shawn, I wonder if there's a quick fix to avoid this problem.

Hi Thomas,
We will check preferences of PBAP by default on m-c soon for v2.5. So at least we won't make people suffer from unexpected timeout or connection drop issue (since gaia application doesn't land their part, OBEX server won't reply any data). At least v2.5 won't support PBAP/MAP by default.

Hi Cindy,
As the product manager, please consider the product roadmap to support PBAP from gaia side. PBAP is out-of scope of v2.5, and it's very basic use case for driving experience.
Flags: needinfo?(chsiang)
There is no quick fix for this feature request until gaia land PBAP related code.
But you can take the reference design:
See Bug 1200091.
(Reporter)

Comment 6

2 years ago
What's the status of this? I see that the bug above is resolved. I retried connecting to my phone agenda from my car but still no luck.
(Reporter)

Updated

2 years ago
Summary: Cannot sync phone agenda with BMW 116d over bluetooth → Cannot sync phone agenda with car system over bluetooth

Comment 7

2 years ago
This might be dupe of 910195 but I am only blocking it atm. 
Maybe someone from the team can confirm?
Blocks: 910195
Flags: needinfo?(shuang)

Comment 8

2 years ago
This bug requires PBAP per comment 1. Mark as duplicate of PBAP meta bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(shuang)
Resolution: --- → DUPLICATE
Duplicate of bug: 892179

Updated

2 years ago
Flags: needinfo?(chsiang)
You need to log in before you can comment on or make changes to this bug.