Closed Bug 12090 Opened 23 years ago Closed 23 years ago

[dogfood][IME]IME does not force commit on Linux

Categories

(Core :: Internationalization, defect, P2)

All
Other
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: teruko, Assigned: ftang)

References

Details

(Keywords: inputmethod, Whiteboard: [PDT+]Finish date: DONE)

When you type Japanese characters in editor, the characters are undetemined untile you commit the character at hitting
enter.  At that time, if you move the cursor to some different object, the undetermine Japanese character should be
committed.  However, the undetermined Japanese characters are shown in the undetermined windows.

Steps of reproduce
1. Open the Editor
2. Change the character set to Japanese (Shift_JIS)
3. Turn on IME and type "あああ" at this time, do not hit enter
4. Move mouse to click on "BOLD"buton

Notice that "あああ" characters are in the undetermine windows.

Tested 8-16 Win32 build.
Priority: P3 → P2
Status: NEW → ASSIGNED
Target Milestone: M12
*** Bug 12249 has been marked as a duplicate of this bug. ***
*** Bug 12249 has been marked as a duplicate of this bug. ***
Blocks: 14356
Blocks: 16127
Assignee: tague → ftang
Status: ASSIGNED → NEW
Summary: IME bug-Undetermined characters remain when you move the cursor to the different object → [IME][IME-IMECommitTxn]IME bug-Unconverted characters remain when you move the cursor to the different object
Status: NEW → ASSIGNED
Summary: [IME][IME-IMECommitTxn]IME bug-Unconverted characters remain when you move the cursor to the different object → dogfood][IME][IME-IMECommitTxn]IME does not force commit
Change the title from ""[IME][IME-IMECommitTxn]IME bug-Unconverted characters
remain when you move the cursor to the different object" to "[dogfood]
[IME][IME-IMECommitTxn]IME does not force commit"
Whiteboard: [PDT+]
putting on PDT+ radar
*** Bug 15784 has been marked as a duplicate of this bug. ***
*** Bug 12251 has been marked as a duplicate of this bug. ***
Hardware: PC → All
Summary: dogfood][IME][IME-IMECommitTxn]IME does not force commit → [dogfood][IME][IME-IMECommitTxn]IME does not force commit
added missing '[' in summary: "dogfood]" -> "[dogfood]"
Whiteboard: [PDT+] → [PDT+]In design phase, should be fix by M12
Whiteboard: [PDT+]In design phase, should be fix by M12 → [PDT+]Finish Win-11/18 Mac- 11/20 X-12/3
Whiteboard: [PDT+]Finish Win-11/18 Mac- 11/20 X-12/3 → [PDT+]Finish Win-[DONE] Mac- 11/20 X-12/3
I think I fix all the cases for Window. Please open seperate bugs for remaining
window problems (and add dep to this) instead of using this bug.
Blocks: 18951
Whiteboard: [PDT+]Finish Win-[DONE] Mac- 11/20 X-12/3 → [PDT+]Finish date: Win-[DONE] Mac- 11/20 X-12/3
Whiteboard: [PDT+]Finish date: Win-[DONE] Mac- 11/20 X-12/3 → [PDT+]Finish date: Win-[DONE] Mac- DONE X-12/3
I think I fix all the cases for Mac also. Please open seperate bugs for
remaining Mac problems (and add dep to this) instead of using this bug
Summary: [dogfood][IME][IME-IMECommitTxn]IME does not force commit → [dogfood][IME]IME does not force commit on Linux
Whiteboard: [PDT+]Finish date: Win-[DONE] Mac- DONE X-12/3 → [PDT+]Finish date: X-12/3
To trace this bug more precisly, I decide to split this bugs into 3 bugs.

Window specific problem are now split into bug 19357
Mac specific problem are now split into bug 19358

Rename this bug from "[dogfood][IME][IME-IMECommitTxn]IME does not force commit"
to "[dogfood][IME]IME does not force commit on Linux"
From now on this bug is only for Linux. Mac and Win problem should go to other
two bugs.
I think I fix half of the Linux cases. It now commit if I click in the same text
field. It have not commit if I click on editor toolbar yet.
Whiteboard: [PDT+]Finish date: X-12/3 → [PDT+]Finish date: X-12/10
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+]Finish date: X-12/10 → [PDT+]Finish date: DONE
Status: RESOLVED → VERIFIED
Inside the Composer, IME force to commit in linux.
I verfied this in 12-10-08 Linux build.
No longer blocks: 18951
You need to log in before you can comment on or make changes to this bug.