[IME]IME bug-Style does not change correctly in editor when FEP is on

VERIFIED DUPLICATE of bug 12090

Status

()

Core
Internationalization
P3
major
VERIFIED DUPLICATE of bug 12090
19 years ago
18 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Frank Tang)

Tracking

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
After you edit some Japanese characters by using IME, you hightlight the characers
and you can change the characters' styles, such as Bold, Underline, Italic, fonts
font's size, and so on.
Then, if you change the character's styles, the styles are same as before.

Step of reproduce
1. Select menu View|Character set->Japanese(Shift_JIS)
2. Open Editor
3. Alt + ~ to on IME
4. Edit some Japanese characters, like 漢字
5. Highlight those characters
6. Select Bold button or Underline button
At this time, the Style is changed in the HTML editor.

Then,
7. Unselect menu Bold button
8. Edit other Japanese characters
Notice that the style for other characters are still Bold and Underline.

If you hightlight the other characters, you can change the style.
This happens when IME is on. 

Tested 8-16 Win32 build and Mac build.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

18 years ago
Blocks: 14356

Updated

18 years ago
Blocks: 16127
(Assignee)

Updated

18 years ago
Assignee: tague → ftang
Status: ASSIGNED → NEW
Summary: IME bug-Style does not change correctly in editor when FEP is on → [IME]IME bug-Style does not change correctly in editor when FEP is on
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

18 years ago
IME hight light got implement. Now the situration is easier to compare. We
should have no problem after we commit the IME. The currently problem is we
didnt force commit IME when we should . So I mark this as dup of 19090 for we
currently not force commit IME when we should.

*** This bug has been marked as a duplicate of 19090 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 2

18 years ago
Frank put the wrong dup bug number here.
(Reporter)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
(Reporter)

Comment 3

18 years ago
*** This bug has been marked as a duplicate of 12090 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

18 years ago
Verified as dup.
You need to log in before you can comment on or make changes to this bug.