Closed Bug 1209404 Opened 7 years ago Closed 7 years ago

Addon names and description displayed in foreign languages

Categories

(addons.mozilla.org Graveyard :: Localization, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 718441

People

(Reporter: underpass_bugzilla, Unassigned)

Details

(Whiteboard: dupeme)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150921151815

Steps to reproduce:

Open the page

https://addons.mozilla.org/firefox/addon/easy-access/

with a browser localized in Italian (Firefox, but even Internet Explorer). The link becomes

https://addons.mozilla.org/it/firefox/addon/easy-access/


Actual results:

The addon name and description are not diplayed in English (it is Chinese, I guess).

The only way to see what this addon actually does and its English name is to write the link with the en-us notation:

https://addons.mozilla.org/en-us/firefox/addon/easy-access/


Expected results:

I expect all the addons names, descriptions, etc. are displayed in English - if a page localized in the browser language doesn't exist.

Thanks for your attention.
That's because Chinese (zh-CN)is set as the default. If I remember correct, a similar requests has been closed in the past as wontfix.
Whiteboard: dupeme
Product: addons.mozilla.org → addons.mozilla.org Graveyard
Excuse me, is there any plan to look at this bug? There are several addons with this problem, like 

https://addons.mozilla.org/en-US/firefox/addon/clever-%D0%BE%D1%82%D1%81%D0%BB%D0%B5%D0%B6%D0%B8%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5-%D0%BF%D0%BE%D1%81%D1%8B%D0%BB%D0%BE%D0%BA/

I simply wish to know what is the purpose of addons listed in the official Mozilla addons website.

Thanks.
Not that I agree with the decision, but this bug is a duplicate of bug 718441 (which was WONTFIXED).
In particular, the add-on in comment #2 only has Russian strings and apparently had to do something with tracking local shipments (I got that from an auto-translator). Forcing developers to translate add-ons beyond their abilities, or in cases where it doesn't even makes sense, would only alienate some of them and bring little benefit to end users.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718441
You need to log in before you can comment on or make changes to this bug.