Quicktext Addon - Technical Problem.

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
2 years ago
9 days ago

People

(Reporter: Prashant, Unassigned)

Tracking

44 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:quicktext][support][leave open], URL)

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8667145 [details]
Thunderbrd Beta - 41.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150921151815

Steps to reproduce:

nothing


Actual results:

Dear Sir,

I am Very Big Fan of Mozilla Products.

I use All Latest Daily Updated
1) Thudrbird Daily - 32 Bit
2) Thuderbird Daily - 64 Bit
3) Mozilla Thunderbird - 32 Bit
4) Firefox Beta - 32 Bit
5) Firefox Nightly - 64 Bit

From Long Time I am finding that One of Extension called Quicktext is having Some Technical Problem with Thuderbird Daily Both Version 86 & 64.

This Extension works Perfectly in Thuderbird Beta 41.0 and not in Daily 

Main Problem is the Core Item of this Addon is addon Templet is Missing from it. Attached is the Images of the Both.



As I and Lot of other Users of this addon requested to Author for the Correction of this same from Long time, but he is not listening same, because of which we have to use the beta version of the Thuderbird.

As in my office i had installed Daily in all my 5 Pcs. from long time they stoped using daily & now using Beta for their work.as here we all missing use of Daily.

I requesting you to please see in this matter as i fill some code improvement in daily will start templet again, here we all users save lot of time & Love Daily Version Again for further Development of Mozilla.

Regards,
Prashant


Expected results:

Dear Sir,

I am Very Big Fan of Mozilla Products.

I use All Latest Daily Updated
1) Thudrbird Daily - 32 Bit
2) Thuderbird Daily - 64 Bit
3) Mozilla Thunderbird - 32 Bit
4) Firefox Beta - 32 Bit
5) Firefox Nightly - 64 Bit

From Long Time I am finding that One of Extension called Quicktext is having Some Technical Problem with Thuderbird Daily Both Version 86 & 64.

This Extension works Perfectly in Thuderbird Beta 41.0 and not in Daily 

Main Problem is the Core Item of this Addon is addon Templet is Missing from it. Attached is the Images of the Both.



As I and Lot of other Users of this addon requested to Author for the Correction of this same from Long time, but he is not listening same, because of which we have to use the beta version of the Thuderbird.

As in my office i had installed Daily in all my 5 Pcs. from long time they stoped using daily & now using Beta for their work.as here we all missing use of Daily.

I requesting you to please see in this matter as i fill some code improvement in daily will start templet again, here we all users save lot of time & Love Daily Version Again for further Development of Mozilla.

Regards,
Prashant

Comment 1

2 years ago
Note to QA folks: please leave this open for now even though it deals with an extension.

The situation with Quicktext is somewhat difficult, as it is an addon with quite a few users, has no license so it cannot legally be forked, but the original author does not have time to update it. I did a very tiny patch for the addon to get it working in Thunderbird 38, and persuaded the author to include that patch in the official AMO version, but was not able to persuade him to take any of the steps needed to allow such problems to be more easily fixed in the future.

Putting that all together, although it is good to know there are issues with it in the current development releases of Thunderbird, it is unlikely those will be fixed officially until the next official release of Thunderbird (which will be version 45 in March 2016), and even then it may be difficult.

What we and you can do is to report issues, propose fixes, and then people are free to add those modifications to their own local version of Quicktext.

So for now, please report any issues that you have here, and if someone proposes a fix we'll also post it here. Or there may be some better place for that in the future, but I prefer using this bug for now.
(In reply to Kent James (:rkent) from comment #1)
> ... was not able to persuade
> him to take any of the steps needed to allow such problems to be more easily
> fixed in the future.

that's very unfortunate.  Is there anything long term that might be built into Thunderbird make quicktext less subject to breakage?

It is indeed popular - just barely in the top 20.  But there is some history of issues when new releases come out.  For example the big one was crash Bug 785370 when version 17 came out.
Whiteboard: [addon:quicktext][support][leave open]
Duplicate of this bug: 1150364

Comment 4

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)

> that's very unfortunate.  Is there anything long term that might be built
> into Thunderbird make quicktext less subject to breakage?
> 

I doubt it. We would have to go the direction that Firefox is trying to go, using a standardized API for extensions that limits what they can do, but also provides a more easily maintained path.

What would help for similar extensions in the future is a policy change in AMO that either requires a standard license for addons, or gives Mozilla the right to modify the addon on AMO to fix critical issues regardless of the license (or lack thereof in this case) of the addon.
I was thinking the same thing regarding license - this is the kind of thing that makes us look bad.

FWIW, Emil was still engaged when we had to blocklist the failing version related to Bug 785370

Comment 6

a year ago
I can confirm that now we went to final release of tb 45.0, win32, a perfectly nicely working quicktext  0.9.11.6 on tb 38.7.2 does not work on the upgraded tb to 45.0

the text templates simply vanish from inside quicktext and one can not create new templates or at least thats what i experienced in a brief testing for a friend

also the export to xml function (downgrade/reinstall of 38.7.2 and xml export there the quicktext text templates) and trying to import them in the upgraded tb 45.0 results only in an empty seemingly filled with template objects but all having no visible names but still clickable white areas and their contents actually present, but this renders the addon unusable as all the templates have no real representation in the gui, or all are white and indistinguishable or similar.

this is very frustrating and this extension needs to be marked incompatible and needs to be blocked from being delivered and executed in its current broken for for tb 45.0 and higher.

please block/remove. thanks.
Created attachment 8741889 [details] [diff] [review]
QuickText patch from previous version

These are the changes that I have applied to Quicktext Basic to get it to work in Thunderbird 45.

Comment 8

a year ago
@Kent: thanks for your patch, I can confirm it works perfectly.

PS: Hope that someone could shed some light over licensing issues so we could share the patched .xpi somewhere...

Updated

a year ago
Duplicate of this bug: 1265103

Comment 10

a year ago
So now we spend development time to fix faulty add-ons when their authors are negligent?
(In reply to Jorg K (GMT+2) from comment #10)
> So now we spend development time to fix faulty add-ons when their authors
> are negligent?

"We" don't but "I" do, at least in the case of QuickText because 1) I use it myself, so I do the small fixes for my own needs, and 2) It is one of our most-used addons yet unmaintained by the author. I have offered many times to take it over from the author, but he has not agreed. But I will set this as "Invalid" since that is correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Comment 12

a year ago
What type of license has it? Just publish it as QuickText-RKJ ;-)
It is unlicensed, which means it defaults to All Rights Reserved :(

Comment 14

a year ago
(In reply to Kent James (:rkent) from comment #13)
> It is unlicensed, which means it defaults to All Rights Reserved :(

Each author is free to choose the preferred license BUT Mozilla should only host/promote the open ones (or at least the ones that allows code takeover in case of "abandonware").
Hosting closed source extensions - without clearly marking them as such - is counter-productive.

This is another example of abandoned extension (Firefox):
https://addons.mozilla.org/en-US/firefox/addon/aardvark/
but since it's BSD-licensed, so I've legally offered a fix for years (just a change on its manifest), then it was replaced by HackTheWeb.

I'm a Drupal developer; the Drupal website only hosts open-source extensions.
If you want to create a closed source extensions then you must host it elsewhere.

IMHO Mozilla foundation should quickly set a default licensing for all the external code they host, asking all the authors to choose one within a timeframe.

About original author decision: pal, there's nothing to protect: your code is already available and is going to die because of a "legal issue".
Release it to the wild and let it fly again!
(Reporter)

Comment 15

a year ago
Dear Sir,

As i Wanted to Say Lot of Thanks to Kent James (:rkent) as he saves by making Quick text problem Solved.

I have Small office with 5 PC & all installed with Thunderbird Because of Only One Reason - Opensource.

As I use Thunderbird Daily on My Machine & other 4 uses beta Version to help the Community.



As the Author / Writer of Quick Text is not responding emails from long time, Finally I Requested to kent & He Solved my Problem.

I have one Suggestion, Make Quick Text as default in Thunderbird, Because of which lot of People save, lot of time & Thunderbird Get Advance Feature also, as what we have in Our Mobile Templets, this help lot.

Once Again Thanks to Kent James (:rkent)
Flags: needinfo?(info)

Comment 16

a year ago
Also from me many thanks to Kent James for the patch!  
Let's hope for an “official” solution for this useful addon.  -- Hans
Here's a link to what I am currently running with the patches:

http://mesquilla.net/betas/quicktext-20160419.xpi

Comment 18

a year ago
Kent James, HUGE thanks for your efforts here. We were stunned/dismayed/upset when we upgraded this morning and then discovered QT was broken - again - and there was no upgraded version - again.

We depend on QuickText Pro to run our business, (licensed/paid and regularly upgraded since 2010) it saves us easily an hour a day each, and is why we're running Thunderbird and not Outlook. Without QT, we'd have to switch. We've been considering switching because of the poor calendar - Lightning just isn't there, and shows no signs of improving, but we've stuck with TB because of QT.

I agree that it should be in core, not an add-on, and I also agree that Mozilla needs to sort out the license nonsense for all extension, including Firefox.

On Hesslow's site, it seems he is still taking people's money for QT Pro, and it's not working, and no response re fixing. Seems to me there's a serious legal issue there that needs sorting before someone gets lawsuit happy. Is Hesslow an a$$hole and a thief? Strong words, but what else are we supposed to think?

Comment 19

a year ago
calm down maybe?
if the shopping is fully automated then you can still buy stuff although the creator is absent, gone, deceased or held up with different things in life

Comment 20

a year ago
(In reply to Kent James (:rkent) from comment #17)
> Here's a link to what I am currently running with the patches:
> 
> http://mesquilla.net/betas/quicktext-20160419.xpi

Very nice, but still had the unwanted blanks problem. Solved for me with follwoing changes to quicktext.js:

Original:
      if (found)
      {
        e.preventBubble();
        e.preventDefault();
      }


New:
      if (found)
      {
        //e.preventBubble();
        e.stopPropagation();
        e.preventDefault();
      }

I can not understand Emil Hesslow especcially when the adjustings are obviously not so hard to make and many people likes to help.

By the way I am not a programmer but need quicktext so urgently, so I made my own amateur reseaches!

Comment 21

a year ago
Did anyone actually ever manage to really contact the author? We all dont know what is happening over there so stop jumping to conclusions or why the author is apparently reluctant to fix stuff. Maybe he is incapable of doing so at the moment for whatever reasons.
My last email to Emil was 2016-02-17 and got no response. For TB 38 he finally responded when I presented him with a fixed version. It's time to do it again.

Doing some quick research, .preventBubble was deprecated then removed, replaced by stopPropagation

(http://mxr.mozilla.org/comm-1.9.1/source/mozilla/dom/public/idl/events/nsIDOMNSEvent.idl#108)

So I'll do the changes from comment 20.

Any more?

Comment 23

a year ago
what is the current not beta version of TB? and why when i update, i receive version 45 beta  which does not recognize quicktext? i uninstalled it and went back to 38.7.2

Comment 24

a year ago
Hi - for windows 8, which folder is quicktext.js in? Hoping all I need do is comment 20 changes but windows search says it can't find quicktext.js. Thanks!

Comment 25

a year ago
(In reply to Val from comment #24)
> Hi - for windows 8, which folder is quicktext.js in? Hoping all I need do is
> comment 20 changes but windows search says it can't find quicktext.js.
> Thanks!

Hi Val,
The file is part of the quicktext installation package. No need to modify it. You can simply try this:

1. uninstall TB addon Quicktext
2. download http://www.gramatec.de/quicktext-09.11.7_patch.zip
3. unzip download to a folder
4. install the patched version within Thunderbird by "Install Add-on From File…!"

No warranties or promises!

Comment 26

a year ago
Hi,
*your* template backup for Quicktext on Win x.y could be found here:
C:\Users\myuser\AppData\Roaming\Thunderbird\Profiles\myprofile_xy.default\quicktext\templates.xml

Comment 27

a year ago
Thank you WizKid! 

http://www.gramatec.de/quicktext-09.11.7_patch.zip

this quicktext 0.9.11.7 patch works for me in TB 45.0. Clean on virustotal.com today ..

https://addons.mozilla.org/en-US/thunderbird/user/wizkid/
https://addons.mozilla.org/en-US/thunderbird/addon/quicktext/?src=userprofile

Comment 28

a year ago
Thank you michael_usr - works great! Although couldn't figure out how to get the groups with their dropdown templates back on the menu bar so I just moved the quicktext icon to the top where Tbird has "Send" icon. Very grateful :)

Comment 29

a year ago
Stupid question.  How would you install the patch?

Comment 30

a year ago
Not a stupid questions. You need developer tools to do that.

However, the patched add-on is available, see:
comment #17: http://mesquilla.net/betas/quicktext-20160419.xpi
comment #25: http://www.gramatec.de/quicktext-09.11.7_patch.zip
Perhaps you should have read those comments ;-)

Comment 31

a year ago
(In reply to Jorg K (GMT+2) from comment #30)
> Not a stupid questions. You need developer tools to do that.
> 
> However, the patched add-on is available, see:
> comment #17: http://mesquilla.net/betas/quicktext-20160419.xpi
> comment #25: http://www.gramatec.de/quicktext-09.11.7_patch.zip
> Perhaps you should have read those comments ;-)

Thank you so much for the clarification Jorg K! :)

Comment 32

a year ago
Hi - this morning I lost all my unopened emails in my inbox. First time it's happened with TBird. Although a few other times Tbird has scrambled the text of both the opened & unopened so I'm unable to read anything and have to delete them all.

This wouldn't have anything to do with http://www.gramatec.de/quicktext-09.11.7_patch, would it?

This is off-topic but does anyone know what to do when all emails have vaporized? Or their text is scrambled? I tried google but can't find an answer. Is the inbox in a file on the hard drive somewhere, that I could open them in a text editor to at least read? I found an "inbox.msf" and "inbox" under appdata/roaming but they're not readable in text editor. I'm using Windows 8. This is a real drag. I used to use Calypso mail program, and never once lost all my inbox, but the programmers stopped supporting it a few years back. I repeatedly lose my inbox with Tbird.

Comment 33

a year ago
I opened a new #Bug 1268435 at https://bugzilla.mozilla.org/show_bug.cgi?id=1268435 for this problem of all emails vaporizing.

Comment 34

a year ago
Thanks for the patch! Seems to work fine.

Only thing weird is that I had my settings was reset to default (other then templates). This is probably not a problem with the patch, rather previously settings where miss-read and miss-saved.

Anyway I had to tick "Collapse group when it contains one template" again. It works fine.

Comment 35

a year ago
Thank you very much for the patch ! It seems to works fine.
Hovewer somebody needs to contact the author and disable the original extension in the repository, because it has a bug inside.

Updated

a year ago
Duplicate of this bug: 1269309

Comment 37

a year ago
How do I install the quicktext-09.11.7_patch.xpi?
From: jim@durabelt.com

Comment 38

a year ago
How do I install the quicktext-09.11.7_patch.xpi?

Better yet, how do I uninstall TB quicktext? 

I have Windows 7 and have turned off "hidden files"

Quicktext is not listen in the Control Panel uninstall section.

I have searched the program folders for quicktext and addon and cannot find it.

TB does not give me the option of uninstalling quicktext.

If I uninstall TB, wiil that also uninstall quicktext?

From: jim@durabelt.com

Comment 39

a year ago
Please note: Bugzilla is NOT a support forum. It is a tracking system for bugs in Mozilla products. You should go to https://support.mozilla.org/en-US/products/thunderbird to get support.

The questions you're asking here are clearly support questions and don't belong here. Additionally, they are related to a TB add-on.

That said and just to help you out:
You uninstall an add-on via Tools > Add-ons from the menu or "Hamburger menu, Add-ons".
You install the new version by downloading it first, then on the add-ons tab there is a tool menu (sprocket/cogwheel/gear-wheel) above that allows you to install an add-on from a file.
You can also simply drag the downloaded .xpi onto the tab and it will install.
Flags: needinfo?(info)

Comment 40

a year ago
Addons are installed and uninstalled inside the Thunderbird application itself. It is not in your windows control panel. Go Thunderbird tools menu, and there Addons, and you should see your quicktext there and be able to remove it.

Comment 41

a year ago
Isn't that what I said in comment #39?

Comment 42

a year ago
Created attachment 8750160 [details]
quicktext-0.9.11.6-tb.xpi

Comment 43

a year ago
I am eager to install the patch. However I have "Quicktext" and "Quicktext Pro" installed. Am I to uninstall both of them, then run the patch, then reinstall both of them? Thank you, David

Comment 44

a year ago
(In reply to michael_usr from comment #25)
> (In reply to Val from comment #24)
> > Hi - for windows 8, which folder is quicktext.js in? Hoping all I need do is
> > comment 20 changes but windows search says it can't find quicktext.js.
> > Thanks!
> 
> Hi Val,
> The file is part of the quicktext installation package. No need to modify
> it. You can simply try this:
> 
> 1. uninstall TB addon Quicktext
> 2. download http://www.gramatec.de/quicktext-09.11.7_patch.zip
> 3. unzip download to a folder
> 4. install the patched version within Thunderbird by "Install Add-on From
> File…!"
> 
> No warranties or promises!

THANKS IT WORKS!!! I use Thunderbird on about 12 workstations and use QuickText on all of them. It's hard to work without it (almost impossible). A company should pick this up. I would be willing to pay for this little extension. Like $2 per seat per month or something.
Thanks for all the support and info!

Does anyone know if there is also a patch for the MAC version of Quicktext. I use it everyday and saves so much time.

Other question: is there an altertive add-on for Quicktext for MAC users with Thunderbird?

Thanks for the support!!!
(In reply to info@dutchmasterpaints.com from comment #45)
> Thanks for all the support and info!
> 
> Does anyone know if there is also a patch for the MAC version of Quicktext.
> I use it everyday and saves so much time.

Did you even try  attachment 8750160 [details] ?

Comment 47

a year ago
Unless it's a binary add-on, which Quicktext isn't, there is no special Mac version. Try Wayne's suggestion or the ones from comment #30.

Comment 48

a year ago
Please Begu Ferer, 
update your site with the patched version;
your extension is very useful.
Have a nice day.
webgaldom

(In reply to Begu Ferer from comment #27)
> Thank you WizKid! 
> 
> http://www.gramatec.de/quicktext-09.11.7_patch.zip
> 
> this quicktext 0.9.11.7 patch works for me in TB 45.0. Clean on
> virustotal.com today ..
> 
> https://addons.mozilla.org/en-US/thunderbird/user/wizkid/
> https://addons.mozilla.org/en-US/thunderbird/addon/quicktext/?src=userprofile
Comment on attachment 8750160 [details]
quicktext-0.9.11.6-tb.xpi

Thank you for all your help, it's been appreciated!! 

Quicktext on my Mac is working again. For all others.

Download the xpi file, delete Quicktext via Tools, Add-ons. (all your settings are saved on your computer, otherwise export files to be 100% sure).
Install the updated version and start using Quicktext again!!

Again many thanks to all you guys which make the world much nicer :-)
Again many thanks to all you guys "who" make the world much nicer :-)

Comment 51

a year ago
   I have been using Thunderbird for the past 6 years with very few problems and a couple of weeks ago, I decided to clean a lot of the email trash that has accumulated over the years. As soon as I finished the clean-up job, I decided to also update Thunderbird to Version 45.1.0 while I was at it.  Soon after the clean-up job, I noticed the Thunderbird was behaving strangely in certain ways, for example,
   * My Quicktext signatures would not work occasionally.
   * My Quicktext stationery was unavailable on occasion.
   * Sometimes Quicktext would not function at all and in fact all my stationery files would not even show in the Quicktext window.
   I instinctively assumed that I inadvertently deleted some vital Thunderbird file during the clean-up job and spent a whole day searching through my archives to find out what was lost.
   My search did not reveal anything, so I Googled the issue and after many trials and tribulations I hit on this thread and found James Kent's patch, see Comment 17 above.  James, thank you, thank you, thank you.  It worked perfectly on the very first attempt. You saved me a lot of time and also money I might add since time equals money.
   As for the author of Quicktext, the VERY LEAST he could do would be to post at his website shown below 
http://extensions.hesslow.se/extension/4/Quicktext/
that the current version of Quecktex does not work with Thunderbird Version 45.1.0. Would you do that Hesslow?

Comment 52

a year ago
http://extensions.hesslow.se/forum/thread/722/Did+Emil+die%3F/ - Quote:
Ah, LinkedIn resolved this: He has gone for the big money and works for Facebook in Menlo Park now. No time for schmucks...
https://www.linkedin.com/in/hesslow

Comment 53

a year ago
he been there for quite a while though

Comment 54

a year ago
I should add that along with the Quicktext issues I mentioned earlier, see Comment 51, my spam filter began to malfunction after using add-on Qucktext Version 0.9.11.1 with Thunderbird Version 45.1.0.  Button "Run Now" of the spam-filter window was permanently grayed while running Thunderbird Version 45.1.0 with the Quicktext Version 0.9.11.1.  The health of my "spam filter" was miraculously restored after installing James Kent's patch in Comment 17. 

But it could be an unusual coincidence.

Comment 55

a year ago
Thank you to the community for getting QuickText rolling again. I am eager to install the patch. However I have both "Quicktext" and "Quicktext Pro" installed. Am I to uninstall both of them, then run the patch, then reinstall both of them?

Comment 56

a year ago
I believe that you should remove both of them but James Kent, see Comment 17, will have the correct answer for you.

Comment 57

a year ago
(In reply to Kent James (:rkent) from comment #17)
> Here's a link to what I am currently running with the patches:
> 
> http://mesquilla.net/betas/quicktext-20160419.xpi

Hi Kent, Thank you. However I remain confused where Quicktext Pro fits into this discussion. Am I correct that the current state of affairs is that your 0.9.11.7 works with Thunderbird 45.1, while there is no patch yet for Quicktext Pro?
Emil has now taken the steps that we requested to free Quicktext. As a result, the changes discussed in the bug have been incorporated into the version of Quicktext Basic available on addons.mozilla.org, so that should now be working.

For Quicktext Pro, I've never used that personally, but presumably it needs the same changes that Quicktext Basic did. It also has some additional features, and I have seen hints that some of those extra features are also not working.

At this point trying to resolve the issues with Quicktext Pro is being actively discussed by the Thunderbird Council (which includes myself as well as Jorg K and Wayne who have also posted in this bug). One issue, should you choose to comment, is should it be kept paid so that someone would have incentive to maintain it? Obviously that has not worked for the last two years, but in theory the addon is more likely to be maintained if it has an income stream. But I suspect we will probably decide to MPL it, release it on AMO with minimal fixes, and hope that someone will submit patches for whatever issues remain.

Comment 59

a year ago
Regarding QuickText Pro:

[1] All the current patches for the std version work with the Pro version (tested up to 38.8.0).  These also include the [[CURSOR]] and "Superfluous Tab character" fixes.

[2] The only thing that is outstanding is the ability to add attachments.  There is a fix out there but it's not been widely disseminated: I haven't found it yet.

On this basis issuing a fix for the Pro version should be relatively straightforward.  The scripting included in the Pro version is really excellent and worth preserving IMO.
"These also include the [[CURSOR]] and "Superfluous Tab character" fixes."

What are these fixes? Or is there a base version you could point me to that already includes these fixes?

Comment 61

a year ago
(In reply to Kent James (:rkent) from comment #60)
> "These also include the [[CURSOR]] and "Superfluous Tab character" fixes."
> 
> What are these fixes? Or is there a base version you could point me to that
> already includes these fixes?

The [[CURSOR]] error fix is provided in the second part of the following post:

Hesslow Extensions > Forum > Quicktext > Bug Reporting > Error with variable [[TO=firstname]] in Thunderbir

http://extensions.hesslow.se/forum/thread/620/Error+with+variable+[[TO%3Dfirstname]]+in+Thunderbir/?start=3

As far as I recall, the [[TO=firstname]] error mentioned before that was already fixed in the versions with which we are dealing.

The "Superfluous Tab character" error fix is provided in:

Hesslow Extensions > Forum > Quicktext > Bug Reporting > Superfluous Tab character inserted since TB 24.0

http://extensions.hesslow.se/forum/thread/674/Superfluous+Tab+character+inserted+since+TB+24.0/?start=15

That, like the [[CURSOR]] fix, also includes a (different) change to lines containing "aEditor.deleteSelection(0)". I already had the first fix but I imagine that either would work and that the complete "Superfluous Tab character" fix might well therefore also fix the [[CURSOR]] problem.

In all fixes, I tried to find and replace all/any other occurrences of the target expressions in the xpi.

So far, with your fix, and those also, applied to Quicktext Basic 0.9.11.5 since you first published, all seems well.

Comment 62

a year ago
Created attachment 8757550 [details]
My current (patched) Quicktext Basic

This is the patched Quicktext Basic I am using. I'm sorry that, in the xpi, I have not annotated the changes made at the positions where they were made.

Comment 63

a year ago
Hi Kent, RDL

Just like many other users on this forum, we also use QuickText within our business and rely on it heavily. We have huge concerns that a future update of Thunderbird will break the extension permanently.

I would also be happy to pay for the QuickText extension to be further developed, updated (so it continues to work with future Thunderbird updates) and generally maintained on an ongoing basis. 

Could you let me know what you intend to do with the future of QuickText, and whether or not this extension will be maintained? I would be happy to discuss options with you and how we could potentially make this work?

I am sure that there are other users here that would be happy to pay for the ongoing maintenance, updating and development of this plugin as an ongoing concern also.

Thanks Kent, RDL

Rob

Comment 64

a year ago
(In reply to Rob Fisher from comment #63)
> Hi Kent, RDL ..
> ..Could you let me know what you intend to do with the future of QuickText,
> and whether or not this extension will be maintained? ..

Dear Rob Fisher

Much as I would like to help you, please do not include me for any hoped for software solutions. I simply sometimes read, pass on what I see might be useful to people elsewhere, and, like you, ask people to help me and/or others. IE, I'm a gopher, not a builder. Sorry about that misunderstanding.

Judging by the fact that rkent now appears as a co-author on the AMO Quicktext page, I would guess he now has authority to maintain that free ("Basic") version and, in view of the proper importance he and others attach to it, hopefully he will there be providing/coordinating at least any essential maintenance for it.

I see no news about any existing new version of "Quicktext Pro".

Doubtless, as the actual sole creator of the much appreciated latest fix and the proper addressee of your enquiry, rkent will be better able to possibly respond to it, although he quite surely is a very busy person.

Regards

RDL

Comment 65

a year ago
(In reply to RDL from comment #64)
> (In reply to Rob Fisher from comment #63)
> > Hi Kent, RDL ..
> > ..Could you let me know what you intend to do with the future of QuickText,
> > and whether or not this extension will be maintained? ..
> 
> Dear Rob Fisher
> 
> Much as I would like to help you, please do not include me for any hoped for
> software solutions. I simply sometimes read, pass on what I see might be
> useful to people elsewhere, and, like you, ask people to help me and/or
> others. IE, I'm a gopher, not a builder. Sorry about that misunderstanding.
> 
> Judging by the fact that rkent now appears as a co-author on the AMO
> Quicktext page, I would guess he now has authority to maintain that free
> ("Basic") version and, in view of the proper importance he and others attach
> to it, hopefully he will there be providing/coordinating at least any
> essential maintenance for it.
> 
> I see no news about any existing new version of "Quicktext Pro".
> 
> Doubtless, as the actual sole creator of the much appreciated latest fix and
> the proper addressee of your enquiry, rkent will be better able to possibly
> respond to it, although he quite surely is a very busy person.
> 
> Regards
> 
> RDL

Hi RDL,

No problem - I only identified you as a possible key person in this based on your previous comments.

If rkent is the co-author I will await his reply. I am only using the free version of the extension.

rkent - let me know your thoughts when you can.

Thanks,

Rob
It's a difficult problem. I have maintained QuickText (free version) primarily because I use it as part of my own workflow (as do some of you), and so when it breaks I have some incentive to fix it, and of course I have the skill as both an addon author as well as core Thunderbird team member. So far the fixes (for TB 38 and TB 45) have been trivial, just a few hours of work. Most of the effort has been dealing with the administrative issues of trying to fix something that I had no legal right to fix.

But those problems are now past, as Emil has freed the addon as I requested. There are also now funds available to fix the addon. So freedom and money are not really the issue - but the administrative burden of figuring out how to do it is. This issue goes beyond just QuickText but strikes at the heart of the definition of "open source software" and how it is funded. (See my post http://mesquilla.com/2013/10/17/the-proxy-debate-over-paid-addons/)

But at this point, with all the attention that QuickText free version has received, it is one of the most likely to be supported Thunderbird addons, so I think you can use it confidently in your business.

As for Quicktext Pro, the ball is in my court, I need to apply the known fixes from Quicktext Free, and get a version available that will work with TB 45.

But I don't want to be in the position of supporting bug reports for that beyond what it takes to fix regressions from previously working versions. I've brought this issue to the Thunderbird Council, and we have had some discussions about how to deal with it, but no resolution.

But those are future issues. If Quicktext (free version) works for you now, please keep using it.

Comment 67

a year ago
(In reply to Kent James (:rkent) from comment #66)
> It's a difficult problem. I have maintained QuickText (free version)
> primarily because I use it as part of my own workflow (as do some of you),
> and so when it breaks I have some incentive to fix it, and of course I have
> the skill as both an addon author as well as core Thunderbird team member.
> So far the fixes (for TB 38 and TB 45) have been trivial, just a few hours
> of work. Most of the effort has been dealing with the administrative issues
> of trying to fix something that I had no legal right to fix.
> 
> But those problems are now past, as Emil has freed the addon as I requested.
> There are also now funds available to fix the addon. So freedom and money
> are not really the issue - but the administrative burden of figuring out how
> to do it is. This issue goes beyond just QuickText but strikes at the heart
> of the definition of "open source software" and how it is funded. (See my
> post http://mesquilla.com/2013/10/17/the-proxy-debate-over-paid-addons/)
> 
> But at this point, with all the attention that QuickText free version has
> received, it is one of the most likely to be supported Thunderbird addons,
> so I think you can use it confidently in your business.
> 
> As for Quicktext Pro, the ball is in my court, I need to apply the known
> fixes from Quicktext Free, and get a version available that will work with
> TB 45.
> 
> But I don't want to be in the position of supporting bug reports for that
> beyond what it takes to fix regressions from previously working versions.
> I've brought this issue to the Thunderbird Council, and we have had some
> discussions about how to deal with it, but no resolution.
> 
> But those are future issues. If Quicktext (free version) works for you now,
> please keep using it.

Hi Kent,

Thanks for your reply.

Okay that all makes sense now. We have only ever used the Free version (tried to buy the pro version, but had issues similar to what others have described on here).

As you also use QuickText, will you be continuing to update the Free version and posting fixes/patches on here, if and when any bugs occur when TB release updates to their client?

I guess I just need a little reassurance that there will be some sort of bug fixing to maintain the extension as much as possible without inconveniencing you.

Regards
Rob

Comment 68

a year ago
James,

It takes a certain amount of empathy for fellow man or woman to fix some software for yourself and then pass on the fixed software on to anyone who needs it.

I for one would like to thank you for doing that and also for your contribution to the mother software, Thunderbird, which I have been using for free for five or six years now.

And some advice from an old professor: Always keep the last working version of any software, including Adobe software. 

Andreas Antoniou
University of Victoria
I've merged the changes from Quicktext basic into Quicktext Pro, and here is a link:

http://mesquilla.net/betas/quicktext-pro-0_9_11_7.xpi

If you have been using pro, please try that and report here if anything that used to work under TB 38 does not work under TB 45.

I thought about the issues more today, here is what I would propose:

1) Merge pro into basic, and update the version on AMO to include the same features as pro. Then there is only one version.

2) The ownership of the addon on AMO will add the thunderbird-accounts group, which is what the Thunderbird core team uses for addons that they control (like Extra Folder Columns). Not that doing that represents any commitment, it just allows the team to take control if the proverbial bus hits the current maintainer.

3) Not sure what to do about future support. One possibility is to merge it into core as a shipped addon, like we are currently doing with Lightning, and use normal Thunderbird core methods for support. Again that does not represent any commitment since we are volunteers anyway, but at least there is a clear path if someone wants to fix something. I could also add it to my support site, but I have not been exactly reliable in supporting my own old addons either, so that also does not really solve the problem.

Concerning "will you be continuing to update the Free version and posting fixes/patches on here, if and when any bugs occur when TB release updates to their client?" the answer is that in the future, the AMO version will be maintained and that is where official releases will be. As for bug reports, that is in flux, use this bug for now but we still need a long-term solution.

Comment 70

a year ago
(In reply to Kent James (:rkent) from comment #69)
> I've merged the changes from Quicktext basic into Quicktext Pro, and here is
> a link:
> 
> http://mesquilla.net/betas/quicktext-pro-0_9_11_7.xpi
> 
> If you have been using pro, please try that and report here if anything that
> used to work under TB 38 does not work under TB 45.
> 
> I thought about the issues more today, here is what I would propose:
> 
> 1) Merge pro into basic, and update the version on AMO to include the same
> features as pro. Then there is only one version.
> 
> 2) The ownership of the addon on AMO will add the thunderbird-accounts
> group, which is what the Thunderbird core team uses for addons that they
> control (like Extra Folder Columns). Not that doing that represents any
> commitment, it just allows the team to take control if the proverbial bus
> hits the current maintainer.
> 
> 3) Not sure what to do about future support. One possibility is to merge it
> into core as a shipped addon, like we are currently doing with Lightning,
> and use normal Thunderbird core methods for support. Again that does not
> represent any commitment since we are volunteers anyway, but at least there
> is a clear path if someone wants to fix something. I could also add it to my
> support site, but I have not been exactly reliable in supporting my own old
> addons either, so that also does not really solve the problem.
> 
> Concerning "will you be continuing to update the Free version and posting
> fixes/patches on here, if and when any bugs occur when TB release updates to
> their client?" the answer is that in the future, the AMO version will be
> maintained and that is where official releases will be. As for bug reports,
> that is in flux, use this bug for now but we still need a long-term solution.

Kent, I think this is awesome. I will report any issues.

I also agree, in balance, with your entire plan. Although having a paid product where someone gets compensated for supporting it, perhaps even better is to have one version that is donationware... so all users will potentially choose to donate towards the support of the one version.

Comment 71

a year ago
(In reply to Kent James (:rkent) from comment #69)
> I've merged the changes from Quicktext basic into Quicktext Pro, and here is
> a link:
> 
> http://mesquilla.net/betas/quicktext-pro-0_9_11_7.xpi
> 
> ..

Dear rkent

Heartfelt thanks to you for all your efforts in this. Certainly the existing users of Quicktext Pro now finally have relief from their troubles.

Your whole plan proposes a most generous and helpful solution to this Quicktext saga.

Very best regards

RDL

Comment 72

a year ago
Hi rkent,

I also am extremely grateful for this and appreciate the time you have provided so far. This extension is clearly a vital tool for many of us on here.

One question - what is AMO?

Also it would be good to perhaps merge QuickText into the core as a shipped addon - like you suggest it would give more of a direct line of support as such.

It would be good to see a future for this product, and merging the pro version into the free one is also another great idea rkent - working on one rather than two is a much better approach.

Again truly appreciative of all the help and assistance so far

Regards

Rob

Comment 73

a year ago
Hi rkent

Thanks for your support to quicktext pro. There is also a problem with adding files to quicktext templates (if you add one or more file to a quicktext template, the attachment (and in this case the body text) will not added neither with button click, shortcut nor with keyword). I have fixed that. Here the link to the patch file (I don't know how I can add this to Bugzilla)

http://share.emailto.ch/19371-quicktexta

And here the patches QuickText Pro Plugin, based on #69 on this thread
http://share.emailto.ch/05934-quicktextp.xpi

Maybe you want to include this in further versions. I don't habe much experience with thunderbird-plugins so I have copied some code part from another plugin, maybe it's not perfect, but it works...

Regards
Juerg

Comment 74

a year ago
(In reply to Juerg Sommer from comment #73)
> There is also a problem with
> adding files to quicktext templates (if you add one or more file to a
> quicktext template, the attachment (and in this case the body text) will not
> added neither with button click, shortcut nor with keyword). I have fixed
> that. Here the link to the patch file (I don't know how I can add this to
> Bugzilla)
> 
> http://share.emailto.ch/19371-quicktexta

Excellent.  I've just applied this patch to the Pro version and can confirm it works.  Thanks very much.

For others I'd previously applied all the other patches one by one (CURSOR, Extra Tab, and patch for TB45) this was the missing piece.  

I had kept a copy of TB24.6 just to auto add attachments.  Now I can upgrade.

Thanks once again.
(In reply to vexillia from comment #74)
> (In reply to Juerg Sommer from comment #73)
> > There is also a problem with
> > adding files to quicktext templates (if you add one or more file to a
> > quicktext template, the attachment (and in this case the body text) will not
> > added neither with button click, shortcut nor with keyword). I have fixed
> > that. Here the link to the patch file (I don't know how I can add this to
> > Bugzilla)
> > 
> > http://share.emailto.ch/19371-quicktexta
> 
> Excellent.  I've just applied this patch to the Pro version and can confirm
> it works.  Thanks very much.
> 
> For others I'd previously applied all the other patches one by one (CURSOR,
> Extra Tab, and patch for TB45) this was the missing piece.  
> 
> I had kept a copy of TB24.6 just to auto add attachments.  Now I can upgrade.
> 
> Thanks once again.

Can you please post here the xpi that you are using, so that I can check that I will include all known issues in what gets released? Or just email it to me at rkent@caspis.com
Correction: rkent@caspia.com

Comment 77

a year ago
(In reply to Kent James (:rkent) from comment #76)

> Correction: rkent@caspia.com

Email sent.

Comment 78

a year ago
(In reply to Kent James (:rkent) from comment #69)
> I've merged the changes from Quicktext basic into Quicktext Pro, and here is
> a link:
> 
> http://mesquilla.net/betas/quicktext-pro-0_9_11_7.xpi
> 
> If you have been using pro, please try that and report here if anything that
> used to work under TB 38 does not work under TB 45.
> 
> I thought about the issues more today, here is what I would propose:
> 
> 1) Merge pro into basic, and update the version on AMO to include the same
> features as pro. Then there is only one version.
> 
> 2) The ownership of the addon on AMO will add the thunderbird-accounts
> group, which is what the Thunderbird core team uses for addons that they
> control (like Extra Folder Columns). Not that doing that represents any
> commitment, it just allows the team to take control if the proverbial bus
> hits the current maintainer.
> 
> 3) Not sure what to do about future support. One possibility is to merge it
> into core as a shipped addon, like we are currently doing with Lightning,
> and use normal Thunderbird core methods for support. Again that does not
> represent any commitment since we are volunteers anyway, but at least there
> is a clear path if someone wants to fix something. I could also add it to my
> support site, but I have not been exactly reliable in supporting my own old
> addons either, so that also does not really solve the problem.
> 
> Concerning "will you be continuing to update the Free version and posting
> fixes/patches on here, if and when any bugs occur when TB release updates to
> their client?" the answer is that in the future, the AMO version will be
> maintained and that is where official releases will be. As for bug reports,
> that is in flux, use this bug for now but we still need a long-term solution.

So grateful!  I just applied it - http://mesquilla.net/betas/quicktext-pro-0_9_11_7.xpi, (I was a Pro version user, too) and w/ one little hiccup, it is now working great!  Thank you, Thank you...  
Initially after installing, it deleted almost everything in my .xml, and nothing came up for the QT templates when I created a new email.  So, I opened QT, imported from a backup .xml I'd made, and now everything is working fine.  I've exited and re-started TB several times, and it is no longer duplicating templates, and no longer losing them every time I exit.  Perhaps that initial startup was a fluke, but most people who are messing around with this are going to have a backup, aren't you?  :-)

At any rate, moving forward, I'm willing to pay to keep this going moving forward.

What I'm not clear about is why Mr. Hesslow seems to have disappeared in this matter?  It's no big deal that I just paid again (hoping to prompt a fix, honestly).  Hope he's OK, of course.  Just not sure who to pay moving forward(or how I'll know?  Or, how I will know if there are patches/updates?)  Don't get me wrong - I love the idea of free!  But, I'm in business myself.  People should be paid for what they do... anyway, thanks to ALL that helped get this pro version going!
"Hope he's OK, of course.  Just not sure who to pay moving forward(or how I'll know?  Or, how I will know if there are patches/updates?)  Don't get me wrong - I love the idea of free!  But, I'm in business myself.  People should be paid for what they do... anyway, thanks to ALL that helped get this pro version going!"

Emil is just extremely busy, but he was take the appropriate steps to make sure we can do what we need to do. I've also lost interest in some of my old addons, so I am guilty as well in other similar cases.

"Initially after installing, it deleted almost everything in my .xml, and nothing came up for the QT templates when I created a new email."

I would appreciate if you could try to reproduce this, perhaps on a new profile, and report back it it can be reproduced.

Comment 80

11 months ago
I tried the Pro version that Kent James proposed.
It would not work when an attachment is added to the template.

I then tried the patched version by Juerg Sommer.
This one works perfectly.

Huge thanks to you!

Comment 81

11 months ago
Hi James,

I just installed your official version of Quicktext because "my one" (modifications thanks to you and others) had a bug where if the recipients name was missing and I tried to use a template with it, the undo history would stop working until Thunderbird was restarted. Anyway, your official version fixed this :-) but I noticed that it did not have the extra tab fix implemented (extra tab after using a template keyword). This is where all "e.preventBubble();" instances in chrome/content/quicktext.js need to be replaced with "e.stopPropagation();". I am sorry I do not know who provided this fix - it may have been you - but it is missing from the official version and I thought I would let you know.

Thank you for all you have done to keep this indispensable add-on alive.

LM

Comment 82

10 months ago
the link to the patched version by Juerg Sommer is no longer working.

can anyone provide it again?

Thanks

Comment 83

10 months ago
After installing the .xpi file from http://mesquilla.net/betas/quicktext-pro-0_9_11_7.xpi my Thunderbird no longer could retrieve emails.

Only by installing a previous version of the .xpi file was functionality restored.

Comment 84

10 months ago
@Hank Friedman

I have uploaded the file there:
http://ul.to/yc8zvl73

I just hope I chose the right one, because I have several variations of it on my PC.
If not, please tell me, I will look further.

Comment 85

10 months ago
Dear Francois,

Thank you very very much.

This one is working both with the latest version of Thunderbird AND allows QuickText Pro to function.

I am very grateful to you all.

Comment 86

10 months ago
Thank you! Will it also work on the 64-bit version of Thunderbird for Windows?

Comment 87

9 months ago
Hello all, been a user for about 10 years and suffering a lot since we have not had proper support.

Tried to get everything going the other day and had a big push and downloaded the latest version of the Thunderbird support website which is referenced in this correspondence chain.

Everything works perfectly again but it introduces another bug into Thunderbird and that is when you click an unread message to read the content it actually leaves the message as unread about 80% of the time,.

Sometimes you click the message and it goes from bold to normal which is the normal behaviour, other times it doesn't. 

It is completely reproducible every time and if you disable quick text pro there are no issues and Thunderbird behaviour is normal. 

This confirms that the latest modified version of quick text does have an unwonted side effect in the main Thunderbird program. 

Anyone else having this problem ??
(Reporter)

Comment 88

9 months ago
Dear All

How can We Add 3 Update in Quick Text ?

1)   Fonts - Type, Color, Size , Bold ,Italic , underline
2)   Links
3)   Numbers & Bullets

Comment 89

9 months ago
I am working a plan to get someone to take over support of this addon, made progress last week actually. Sorry for the slowness of this, but I occasionally need input from people that are also slow to respond.

At some point I might ask anyone unhappy with the current state of affairs to email the Powers That Be, but too early for that. For now, bugging me is probably the best path forward.

Comment 90

9 months ago
You are a good man Kent - thank you again for your time and efforts on this - it really really is appreciated.

Comment 91

14 days ago
(In reply to Francois G. from comment #84)
> @Hank Friedman
> 
> I have uploaded the file there:
> http://ul.to/yc8zvl73
> 
> I just hope I chose the right one, because I have several variations of it
> on my PC.
> If not, please tell me, I will look further.

I very much appreciate all the work you've done to get Quicktext Pro to work again, I guess, because I haven't been able to download it yet.

So frustrating that you used upload.net to host the file. I could live with the 30 seconds wait to start the download, but once the 30 seconds were up, and I entered the captcha text (just a harassment to encourage you to purchase time for 2 seconds of downloading, and the captcha doesn't even work correctly!), so when I finally got the download started, it only downloaded a text saying that my ticket had expired!! So I'm supposed to wait another 180 minutes to try again. I'm certainly not interested in registering on that cut-throat site, which isn't even secure (no https), nor paying $5 for a fix to something I already paid $10 for.

Couldn't you have uploaded to Dropbox, or Google Drive; someplace that doesn't try to screw downloaders out of money? *sigh*

Comment 92

14 days ago
It's officially hosted at AMO again, isn't it?
https://addons.mozilla.org/en-US/thunderbird/addon/quicktext/
Or is that version not working and you had to revert to the one from comment #84?
Then we should fix the official version.

Comment 93

14 days ago
(In reply to Jorg K (GMT+2) from comment #92)
> It's officially hosted at AMO again, isn't it?
> https://addons.mozilla.org/en-US/thunderbird/addon/quicktext/
> Or is that version not working and you had to revert to the one from comment
> #84?
> Then we should fix the official version.

Not the Pro version, which is what I've been using for years.

Comment 94

11 days ago
@Der_Orso

I have just sent you the file by email.

Comment 95

9 days ago
(In reply to Francois G. from comment #94)
> @Der_Orso
> 
> I have just sent you the file by email.

Hi Francois,

many thanks!

Comment 96

9 days ago
You are welcome!
;)
You need to log in before you can comment on or make changes to this bug.