Closed Bug 1209518 Opened 4 years ago Closed 2 years ago

The pasted bookmark keeps the styling of a cut one

Categories

(Firefox :: Bookmarks & History, defect, P5)

defect

Tracking

()

VERIFIED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- verified

People

(Reporter: vasilica.mihasca, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image bookmarks.gif
Reproducible on: Firefox 44.0a1, Firefox 43.0a2, Firefox 41.0.1 across all platforms

Preconditions: use a dirty profile with reasonable amount of browsing history and bookmarks.


STR
1.Launch Firefox.
2.Enable the Bookmarks Toolbar.
3.Right-click on one of the bookmarks displayed in the toolbar and select "Cut".
4.Right-click on bookmarks toolbar area and select “Paste”.
5.In some cases it might be necessary to repeat steps 3 and 4 in order to reproduce this issue.

ER
The pasted bookmark returns to the default styling.

AR
The pasted bookmark has a blurry styling as it would still be cut.


Additional notes:
- This issue is reproducible on Firefox 44.0a1 (2015-09-28), Firefox 43.0a2 (2015-09-29), Firefox 41.0.1 (20150928151607) on Windows 7 64-bit, Ubuntu 13.03 32-bit and Mac OS X 10.10.5
- This issue is also reproducible on Firefox 41 (20150917150946) and on Firefox 37.0a1 (2015-01-01)
- It is always reproducible at a second attempt.
- I am attaching a video recorded on Windows 7 64-bit where I captured this issue.
Priority: -- → P4
Priority: P4 → P5
This works for me on the latest nightly (61), although bug 1253624 is still an issue.

Can someone verify that please?
Flags: needinfo?(addonsqa)
I am still able to reproduce the issue in Latest Firefox Nightly(61.0a1). I will attach a new video recorded on Windows 10x64.
Flags: needinfo?(addonsqa)
Duplicate of this bug: 1253624
Assignee: nobody → standard8
Status: NEW → ASSIGNED
I think this was probably caused by bug 674486 based on blame.
Blocks: 674486
Comment on attachment 8979287 [details]
Bug 1209518 - Fix highlighting of cut bookmarks.

https://reviewboard.mozilla.org/r/245470/#review251588

The real reason, I think, is that populateClipboard() checks this.cutNodes.length, but cut() sets this.cutNodes just after invoking it.
Anyway, I like your fix more!
Attachment #8979287 - Flags: review?(mak77) → review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cc2b79a70a8c
Fix highlighting of cut bookmarks. r=mak
https://hg.mozilla.org/mozilla-central/rev/cc2b79a70a8c
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Verified as fixed in Firefox 62 using Windows 10x64. I will attach a postfix video.
Status: RESOLVED → VERIFIED
Attached image Postfix video
Duplicate of this bug: 1398135
You need to log in before you can comment on or make changes to this bug.