Local files should not be downloaded before passing them to helpers

VERIFIED DUPLICATE of bug 73757

Status

Core Graveyard
File Handling
P4
enhancement
VERIFIED DUPLICATE of bug 73757
17 years ago
2 years ago

People

(Reporter: Jason Bassford, Assigned: Bill Law)

Tracking

({arch, perf})

Trunk
mozilla1.0.1
arch, perf

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7+)
Gecko/20020117
BuildID:    2002011703

When browsing the local filesystem via Mozilla, "file:///", and clicking on a
link, Mozilla should not download the file to its cache prior to piping it to
its helper application, but should send it to the helper application directly
via the OS's internal mechanisms.  There's no reason for the redundant download
when Mozilla already knows exactly where to find it on the local hard drive.

Reproducible: Always
Steps to Reproduce:
1. Use file:/// to browse your local hard drive to a very large file that a
helper application would view.  (Such as a large movie file.)
2. Double-click on the file.
3. Observe that it "Saves" the file to cache rather than simply opening it up
directly.

Actual Results:  Downloads the file to cache.  With large files this can take a
very long time.

Expected Results:  Should not "download" the file at all since it's *already* on
the local hard drive and Mozilla ought to know exactly where to find it (since
you've already browsed to it.)  Mozilla should not be downloading to cache any
file from the local filesystem.
I could have sworn this was already filed, but I can't find it...

The problem is that the code doing the downloading has no concept of the
original url.  All it has at that point is a data stream...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: arch

Comment 2

17 years ago
IMHO this bug also affecting performance -> +perf
Keywords: perf
How is this affecting performance exactly?

Resummarizing to reflect the real issue.
Blocks: 59932
Summary: Localhost filesystem should not "download" to cache. → Local files should not be downloaded before passing them to helpers

Comment 4

17 years ago
Copying file from HDD to another (place on) HDD takes some (not small) time. 
BTW huge file this bug could also fill up whole HDD.
QA Contact: sairuh → benc
(Assignee)

Comment 5

17 years ago
Mozilla is not a file manager, I don't think.  We have other things that have 
priority over this.
Severity: normal → enhancement
Priority: -- → P4
Target Milestone: --- → mozilla1.0.1

Comment 6

16 years ago
*** Bug 136867 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 73757 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
vrfy dupe
No longer blocks: 59932
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.