Closed Bug 1210527 Opened 4 years ago Closed Last year

Get rid of update verify configs

Categories

(Release Engineering :: Release Automation: Updates, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rail, Unassigned)

References

Details

We can generate them in the fly from the patcher configs. ATM we generate (not bump) them when we bump the patcher configs. This is optional, but a nice to have, because we want to get rid of any hg pushes during a release.
Summary: Get rid of update verify conigs → Get rid of update verify configs
So we currently use those config files for the Firefox UI update tests as run via mozharness in Releng infra. Armen was working on that the last months. So if those configs would not exist anymore, how could we determine which locales and versions we would have to test?
They can be generated by 

python tools/scripts/updates/create-update-verify-configs.py -c tools/release/patcher-configs/mozBeta-branch-patcher2.cfg --platform macosx64 --output tools/release/updates/mozBeta-firefox-mac64.cfg --release-config-file mozilla/release-firefox-mozilla-beta.py -b https://hg.mozilla.org/build/buildbot-configs --channel beta-localtest -t FIREFOX_42_0b2_RELEASE

Where tools == http://hg.mozilla.org/build/tools/
Armen, would that work for you?
Flags: needinfo?(armenzg)
It seems that we need to pass --output /path/to/file.cfg for this work.

Yes, this should work for me.

It seems that the generated file is the same [1]

diff here.cfg tools/release/updates/mozBeta-firefox-mac64.cfg
Flags: needinfo?(armenzg)
Duplicate of this bug: 785068
Priority: -- → P3
Do we still want this given your current work Ben?
Flags: needinfo?(bhearsum)
TBD. I think we need to figure out what the glorious future of release update tests looks like before we can answer this.
Flags: needinfo?(bhearsum)
Component: Release Automation: Other → Release Automation: Updates
As part of tcmigration, we killed patcher configs. We now generate update verify configs at the start of each release, based on information sourced from product details, archive, and other places.

Does this satisfy this bug, rail?
Flags: needinfo?(rail)
Sounds like we can delete everything except ers52-based configs. \o/
Flags: needinfo?(rail)
(In reply to Rail Aliiev [:rail] ⌚️ET from comment #9)
> Sounds like we can delete everything except ers52-based configs. \o/

... and Thunderbird I suppose. Although seems like Tom is getting closer to the finish line with those too.
We finally killed these! (We generated them on the fly now, rather than checking them into a repo)
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.