Closed Bug 1211358 Opened 4 years ago Closed 3 years ago

Unresponsive interface - lightning chrome.manifest not updated in 38.3.0

Categories

(Thunderbird :: General, defect, critical)

38 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: eric.peyremorte, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: hang, regression)

Attachments

(7 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

We use a centralized configuration (mozilla.cfg loading reading its configuration from a central location). The problem appeared with 38.3.0 update (OS = Windows 7 x64)


Actual results:

The UI has become unresponsive : cannot display message inbox content, or open menus.
Upon investigation, we found that the chrome.manifest file from lightning extention hasn't been updated in the user profile.

C:\Users\<USERNAME>\AppData\Roaming\Thunderbird\Profiles\admin\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}


Expected results:

C:\Users\<USERNAME>\AppData\Roaming\Thunderbird\Profiles\admin\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103} should have been updated with C:\Program Files (x86)\Mozilla Thunderbird\distribution\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}\chrome.manifest.

We did the update with a logon script.

We checked out our centralized configuration file, but nothing seems to be the problem...
OS: Unspecified → Windows 7
Priority: -- → P1
Hardware: Unspecified → x86_64
Severity: normal → critical
Component: Mail Window Front End → Build Config
Keywords: hang, regression
Priority: P1 → --
Summary: Unresponsive interface - lightning chrome.manifest not updated → Unresponsive interface - lightning chrome.manifest not updated in 38.3.0
I can confirm this issue too.
Cannot find a common cause on our heterogeneous systems. Occurs on Windows 7 & XP, with and without CalDAV calendars, with manually installed addon or bundled one.
All is frozen on thunderbird startup after 38.3.0 update, only way is to fix chrome.manifest file (or remove/readd extension, calendars won't be lost). Thunderbird won't even close cleanly.
(In reply to eric peyremorte from comment #0)
> We use a centralized configuration (mozilla.cfg loading reading its
> configuration from a central location). The problem appeared with 38.3.0
> update (OS = Windows 7 x64)

Could you provide more details on your configuration setup? There are no obvious packaging changes from 38.2 to 38.3 that would explain this.
In every client we have a mozilla.cfg. At the beginning we thought we had accented characters in mozilla.cfg comments, because we had accents in firefox mozilla.cfg comments and apparently it causes problem with the new version.


mozilla.cfg

PARAM_USERNAME=getenv("USERNAME");
pref("autoadmin.global_config_url","http://prefstbird.hidden.fr/tbird.php/" + PARAM_USERNAME);
pref("autoadmin.failover_to_cached",true);

On the server we always had the following configuration :

<?php

// choisir  lockPref()   		pour fixer la valeur d'une variable en interdisant a l'utilisateur de la changer
// choisir  defaultPref() 		pour definir une valeur par defaut d'une variable
// choisir  pref()        		pour ecraser une valeur d'une variable que l'utilisateur a defini


$ldapServer="crozes.hidden.fr";
$baseDN="ou=Users,ou=Adminprofs,dc=hidden,dc=fr";

$user=$_GET["username"];
$ldapConn=ldap_connect($ldapServer) or die("//Erreur ldap");
ldap_set_option($ldapConn,LDAP_OPT_PROTOCOL_VERSION,3);
ldap_bind($ldapConn) or die("//Erreur ldap");
$rs=ldap_list($ldapConn,$baseDN,"(&(uid=$user))",array("cn","mail"));
$result=ldap_get_entries($ldapConn,$rs);
$mail=$result[0]["mail"][0];
$cn=$result[0]["cn"][0];

header("Content-type: application/javascript-config");

$IMAP="imap";
$SMTP="smtp";

//echo "mail=".$result[0]["mail"][0];
//echo "cn=".$result[0]["cn"][0];


echo <<<EOT
//conf auto

pref("ldap_2.servers.crozes.auth.dn", "");
pref("ldap_2.servers.crozes.auth.saslmech", "");
pref("ldap_2.servers.crozes.description", "crozes");
pref("ldap_2.servers.crozes.filename", "ldap.mab");
pref("ldap_2.servers.crozes.maxHits", 100);
pref("ldap_2.servers.crozes.uri", "ldap://crozes.hidden.fr/dc=hidden,dc=fr??sub?(objectclass=*)");
defaultPref("mail.account.account1.identities", "id1");
pref("mail.account.account1.server", "server1");
pref("mail.account.account2.server", "server2");
defaultPref("mail.accountmanager.accounts", "account1,account2");
pref("mail.accountmanager.defaultaccount", "account1");
pref("mail.accountmanager.localfoldersserver", "server2");
pref("mail.append_preconfig_smtpservers.version", 2);
pref("mail.identity.id1.archive_enabled", false);
pref("mail.identity.id1.archive_folder", "imap://$user@$IMAP.hidden.fr/Archives");
;pref("mail.identity.id1.archive_folder", "imap://$user@$IMAP.hidden.fr/Archives");
pref("mail.identity.id1.directoryServer", "ldap_2.servers.crozes");
pref("mail.identity.id1.doBcc", false);
pref("mail.identity.id1.draft_folder", "imap://$user@$IMAP.hidden.fr/Drafts");
pref("mail.identity.id1.drafts_folder_picker_mode", "0");
pref("mail.identity.id1.encryptionpolicy", 0);
pref("mail.identity.id1.fcc_folder", "imap://$user@$IMAP.hidden.fr/Sent");
pref("mail.identity.id1.fcc_folder_picker_mode", "0");
pref("mail.identity.id1.fullName", "$cn");
pref("mail.identity.id1.overrideGlobal_Pref", true);
pref("mail.identity.id1.reply_on_top", 1);
pref("mail.identity.id1.sign_mail", false);
pref("mail.identity.id1.smtpServer", "smtp1");
pref("mail.identity.id1.stationery_folder", "imap://$user@$IMAP.hidden.fr/Templates");
pref("mail.identity.id1.tmpl_folder_picker_mode", "0");
pref("mail.identity.id1.useremail", "$mail");
pref("mail.identity.id1.valid", true);
pref("mail.openMessageBehavior.version", 1);
pref("mail.preferences.advanced.selectedTabIndex", 4);
pref("mail.preferences.compose.selectedTabIndex", 0);
pref("mail.preferences.display.selectedTabIndex", 0);
pref("mail.preferences.security.selectedTabIndex", 4);
pref("mail.quota.mainwindow_threshold.show", 0);
pref("mail.rights.version", 1);
pref("mail.server.server1.ageLimit", 30);
pref("mail.server.server1.applyToFlaggedMessages", false);
pref("mail.server.server1.check_new_mail", true);
pref("mail.server.server1.cleanupBodies", false);
pref("mail.server.server1.daysToKeepBodies", 30);
pref("mail.server.server1.daysToKeepHdrs", 30);
pref("mail.server.server1.directory", "G:\\\\Mail\\\\Imap");
pref("mail.server.server1.downloadByDate", false);
pref("mail.server.server1.downloadUnreadOnly", false);
pref("mail.server.server1.hostname", "$IMAP.hidden.fr");
pref("mail.server.server1.keepUnreadOnly", false);
pref("mail.server.server1.login_at_startup", true);
pref("mail.server.server1.max_cached_connections", 3);
pref("mail.server.server1.name", "$mail");
pref("mail.server.server1.namespace.personal", "\"\"");
pref("mail.server.server1.namespace.public", "\"shared.\",\"#shared.\"");
pref("mail.server.server1.numHdrsToKeep", 2000);
pref("mail.server.server1.offline_download", false);
pref("mail.server.server1.server_sub_directory", "");
pref("mail.server.server1.socketType", 2);
pref("mail.server.server1.spamActionTargetAccount", "imap://$user@$IMAP.hidden.fr");
pref("mail.server.server1.spamActionTargetFolder", "mailbox://nobody@Local%20Folders/Junk");
pref("mail.server.server1.timeout", 29);
pref("mail.server.server1.type", "imap");
pref("mail.server.server1.userName", "$user");
pref("mail.server.server1.using_subscription", false);
pref("mail.server.server1.whiteListAbURI", "moz-abmdbdirectory://history.mab moz-abmdbdirectory://abook.mab");
pref("mail.server.server2.ageLimit", 30);
pref("mail.server.server2.applyToFlaggedMessages", false);
pref("mail.server.server2.cleanupBodies", false);
pref("mail.server.server2.daysToKeepBodies", 30);
pref("mail.server.server2.daysToKeepHdrs", 30);
pref("mail.server.server2.directory", "G:\\\\Mail\\\\Dossiers Locaux");
pref("mail.server.server2.downloadByDate", false);
pref("mail.server.server2.downloadUnreadOnly", false);
pref("mail.server.server2.hostname", "Local Folders");
pref("mail.server.server2.keepUnreadOnly", false);
pref("mail.server.server2.name", "Dossiers locaux");
pref("mail.server.server2.numHdrsToKeep", 2000);
pref("mail.server.server2.spamActionTargetAccount", "mailbox://nobody@Local%20Folders");
pref("mail.server.server2.spamActionTargetFolder", "mailbox://nobody@Local%20Folders/Junk");
pref("mail.server.server2.type", "none");
pref("mail.server.server2.userName", "nobody");
pref("mail.server.server2.whiteListAbURI", "moz-abmdbdirectory://history.mab moz-abmdbdirectory://abook.mab");
pref("mail.smtpserver.smtp1.authMethod", 3);
pref("mail.smtpserver.smtp1.hostname", "$SMTP.hidden.fr");
pref("mail.smtpserver.smtp1.port", 25);
pref("mail.smtpserver.smtp1.try_ssl", 2);
pref("mail.smtpserver.smtp1.username", "$user");
defaultPref("mail.smtpservers", "smtp1");
pref("mail.spam.manualMark", true);
pref("mail.spam.version", 1);
pref("mail.startup.enabledMailCheckOnce", true);
pref("mail.winsearch.firstRunDone", true);
pref("mailnews.database.global.indexer.enabled", false);
pref("mailnews.start_page.enabled", false);
pref("mailnews.start_page.url", "");
pref("mailnews.start_page_override.mstone", "ignore");
pref("network.cookie.lifetimePolicy", 2);
pref("offline.download.download_messages", 2);
pref("app.update.enabled", true);

EOT;

?>
Hi Eric, Sébastien,

can both of you send me a zip with the following directories, ideally zipped with timestamps preserved:

* thunderbird-dir/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
* profile-dir/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}

This would be immensely helpful in determining the cause for it. You can also attach them as one zip to this bug if bugzilla allows.


If you have some extra cycles, can you try to reproduce the issue manually? I imagine these steps:

1) Install Thunderbird 38.2.0, open it with a new profile. Make certain Lightning is enabled and at version 4.0.2.
2) Check for extension updates, which should update Lightning to 4.0.2.1. Restart and have that update apply.
3) Now, check for application updates in the About box, which will download and install 38.3.0. Restart for that to apply.
4) Check the add-on manager, verify that Lightning 4.0.3 is installed.

At this point, you should have the broken Lightning as described in this bug. You may have to prevent automatic application updates so Thunderbird doesn't update between step 1 and 2.
Flags: needinfo?(sebastien-mozilla)
Flags: needinfo?(eric.peyremorte)
Sorry, I forgot to mention, please send me the two above directories for both a working upgrade and a buggy system where the upgrade failed. Thanks!
Flags: needinfo?(sebastien-mozilla)
The only difference is chrome.manifest. Otherwise the working and the broken package attached in previous comments is identical. The broken package contains Lightning with only fr localization and files are packed into chrome.jar. But chrome.manifest states that files are unpacked.

I downloaded the full German Thunderbird 38.3 setup package and its content looks fine and Lightning is working. Maybe problem is specific to partial updates only?
What would be triggering partial updates (we encountered the case in dozen of installations)? Could this be related to l10n (I guess Éric use a French package too)?

Btw shouldn't we report the bug to Thunderbird core? IMHO a buggy extension shouldn't break the whole app.
Attached requested directories from a Windows 7 x64 installation exhibiting the problem as of this morning.
Working dirs for comparison, though this is with Lighning 4.0.2.1 on the same system. (The problem happens with Lightning 4.0.3.)
Partial updates trigger when updating from 38.1.0, 38.2.0 and maybe one other version I don't remember. Full updates happen for all other versions. I don't think it is the AUS updates, as the distribution/extensions/ folder is the same. I fear this might be something in the platform code that installs files from distribution/extensions to the profile folder.

The Thunderbird team is informed, there is at least one more bug on this topic, see for example bug 1211291. We discussed on the Meeting yesterday that we will be releasing the AMO version of Lightning as 4.0.3.1, which will hopefully cause extension updates to trigger, which will fix it for affected folks. If we happen to release Thunderbird 38.3.1 then we'll have to push a change to adapt the Lightning version. Stefan, if you see any downsides to the whole approach let me know.
And now directories from a working system that was manually upgraded from v24.x using a 38.3.0 download from the site.
Attached directories from a working setup auto-updated but on Windows 10 x64.
Attachment #8670937 - Attachment mime type: application/octet-stream → application/x-7z-compressed
Attachment #8670929 - Attachment mime type: application/octet-stream → application/x-7z-compressed
FYI, issue of UI not loading completely and stuck at the home page (impossibility to access any folders content, right panel do not update, menu button do not open, etc...) occur with Thunderbird 38.3.0 and Lightening 4.0.3 (<-- that version is the one embedded with Thunderbird, not available on Ligtning Add-on website) most probably after update but I could not tell from which version. It does not seems to happen to all users for some reason.

Here is how we sort the problem on the spot:
- Fully close Thunderbird
- Start Thunderbird in safe mode from command line (thunderbird.exe -safe-mode)
- Select Disable Add-Ons in prompt window
- Press Continue in Safe Mode button
- Go to Menu > Add-ons > Extension
- Remove Lightning
- Restart Thunderbird in normal mode (as you would usually do)
- Go to Menu > Add-ons > Get Extension
- At the top select Lightening icon
- Press install Add-on
- Press Install button when prompted
- Restart Thunderbird when prompted

This way Lightening version 4.0.2.1 is installed instead. Most probably in user profile.

That is not a long term solution but may help others until a better solution is found.

Cheers,
Note I have just released Lightning 4.0.3.1 on AMO, users that have a broken Lightning should get this update soon via extension updates.
Flags: needinfo?(eric.peyremorte)
See Also: → 1211291
So, I'm confused... in bug 1211291 (In reply to Philipp Kewisch [:Fallen] from comment #16)
> Note I have just released Lightning 4.0.3.1 on AMO, users that have a broken
> Lightning should get this update soon via extension updates.

So, I'm confused... in bug 1211291 you said the problem was not in the package, but in the upgrade code, but here you seem to be saying it is in the package...

Anyway, since 4.0.3.1 was released, we have not had a single case of this happening again.

Very strange...
The problem is still the update code. The package 4.0.3.1 itself did not fix it, it is the exact same code as the 4.0.3 delivered with Thunderbird 38.3.0, but repackaged for multiple locales as we've been doing for all previous versions. Previously we would have also called the version on addons.mozilla.org 4.0.3.

What "fixed" it is the fact that I renamed the version on AMO from 4.0.3 to 4.0.3.1 before uploading. When the add-ons manager checks for add-on updates, it will see that 4.0.3 is installed but the latest version is 4.0.3.1. This triggers the standard update code, which has usually been working. Installing it will cause the broken files to be overwritten with a good copy again.

Of course there was a chance that the same bug might have occurred, but since updates had been working before we had our hopes up that releasing a new version on addons.mozilla.org works around the issue for now. Seems this is the case.
Ok, thanks for the explanation, the weird thing is, I have checked on the last few that I could, and when the auto-update happens, Lightning is at 4.0.3 - but the problem is not evident. Then it gets updated, and so the problem is never seen...

Not sure how to explain this...
OS/Environment:
Mac OS 10.7.5
Lightning 4.0.3.1
Thunderbird 38.3.0

Running with System Admin privileges: YES, I THINK SO, AS I'M THE OWNER OF THIS MAC AND HAVE ALL SYSTEM ADMIN RIGHTS TO IT. I PERSONALLY HAVE SysAdmin PRIVILEGES, BUT DON'T KNOW IF YOU'RE ASKING THAT OR IF YOU'RE ASKING IF COMPUTER WAS IN SOME "SYSTEM ADMIN PRIVILEGES" MODE AT SOME CERTAIN TIME.

I DON'T REMEMBER FROM WHICH VERSION OF TB I UPDATED.

Antivirus programs running: NONE

Neither the calendar toolbar buttons in top right of TB window, nor the corresponding entry in Events/Tasks menu, bring up my calendar (though they do open a new tab for it), and my View > Calendar remains greyed out.

Calendar also doesn't open upon launching TB. Everything was working fine until today. I Quit TB yesterday, started back up today, and Calendar no longer appears. I've tried restarting computer a couple times, restarting TB couple times in addition to that.

SOMEtimes (as I keep restarting computer and/or TB), I can get a Calendar TAB (but not any actual calendar display) to open in TB. When that happens, I see ONE of my several calendars presented in the left-hand sidebar. I then CTRL-click that Calendar, then click "Properties" in the pop-up menu, and nothing happens

Can anyone help?

Thanks,
Ted
Hi,

Just fixed an issue for an end-user where Thunderbird 38.4.0 would not show any emails (but would still pop up notifications). Turned out to be a Lightning issue. 

End-user did not proceed with any manual update (nor is aware of any automatic update having occurred) but ends up with Lightning version 4.0.4 installed somehow (how is that possible?) but 4.0.3.1 seems to be the latest available, so maybe something went wrong at Mozilla's end with an update slipping out by mistake and then cleared.

Current work around it to start in safe mode, uninstall lightening, and then reinstall the correct 
version.

Just thought to report it here, in the hope such issue could be prevented in the future.

Regards,
I would appreciate if somebody affected can do the test requested in [1]. Please report back in either of the bugs.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1211160#c49
(In reply to MakeMyDay from comment #22)
> I would appreciate if somebody affected can do the test requested in [1].
> Please report back in either of the bugs.
> 
> [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1211160#c49

FYI, it seems issue raised again when upgrading to TB 38.5.0 for one of our client (I can confirm that end-user use a Windows domain account and a Windows roaming profile).
The manifest file not properly updated during upgrade may still be the source of issue though but I cannot confirm at this stage.

My feeling is that it is occurring when Lightening was installed as an external extension and not provided via TB distribution in the previous version. During the upgrade, I would expect the existing lightening user profile extension folder to be removed from user profile (but it is not), and the distribution extension installed and activated (instead), which is the case.

Lightening 4.0.5 was installed during the upgrade but not allowing the use of Thunderbird. Same workaround as before applied (start TB in safe mode, remove disable and remove Lightening extension, re-install it via extension manager) which install Lightening 4.0.4.1 instead which works fine!

I haven't tried the test recommended at link above yet but I will try it at next available occasion.
 
Though I am not totally convince that the Windows profile may be the source of that particular issue as while my computer belong to a Windows domain and I use a Windows domain account to connect to it, I do not use roaming profile and still encountered the issue on my Win 7 64bits machine in the past (though not while upgrading from TB38.3.0/L4.0.4.1 to TB38.5.0/L4.0.5).

Other problems that may happens and that we have identified with Windows roaming profile is that:
- if Thunderbird download all the email (by default) then the user profile may become very big if the mailbox is huge. The problem with that is that if there are two much data to sync, Windows Roaming profile sync may timeout before it completes and not all files are synchronized with the server, the manifest files may therefore not properly sync. 
Solutions: Delete Trash, set TB to download only headers of email and full email by default, reduce number of email, repair Inbox and Sent folders, compact Inbox and Sent folders.
- if user connect to another computer with a different version of Thunderbird/Lightening it may not work properly.
Solutions: Make sure that all computers run the same version of TB and Lightening for all users using roaming profiles.
(In reply to Richard Leger from comment #23)
> Though I am not totally convince that the Windows profile may be the source
> of that particular issue as while my computer belong to a Windows domain and
> I use a Windows domain account to connect to it, I do not use roaming
> profile and still encountered the issue on my Win 7 64bits machine in the
> past (though not while upgrading from TB38.3.0/L4.0.4.1 to TB38.5.0/L4.0.5).

After checking with one of my end-user using roaming profile, I can now confirm that immediately after the upgrade to TB38.5.0/L4.0.5 yesterday everything was working fine until end-user logged off in the evening and re-logged on the machine the day after, at which point issue immediately occurred. So issue may well be linked to a combination of Thunderbird upgrade and roaming profile usage.

I may be able to proceed with the recommended test [1] sometime next week with that user and will provide feedback.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1211160#c49
(In reply to MakeMyDay from comment #22)
> I would appreciate if somebody affected can do the test requested in [1].
> Please report back in either of the bugs.
> 
> [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1211160#c49

Done. See test result at https://bugzilla.mozilla.org/show_bug.cgi?id=1211160#c60
(In reply to Richard Leger from comment #25)
> (In reply to MakeMyDay from comment #22)
> > I would appreciate if somebody affected can do the test requested in [1].
> > Please report back in either of the bugs.
> > 
> > [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1211160#c49
> 
> Done. See test result at
> https://bugzilla.mozilla.org/show_bug.cgi?id=1211160#c60

How have things been with the last few updates of TB45?
Component: Build Config → General
Flags: needinfo?(richard.leger)
Flags: needinfo?(eric.peyremorte)
Seems ok in regards of this bug. Thanks for the follow up.

Though upgrade from 45.1 to 45.1.1 seems to have cause performence issue (Delay when typing) that could only be sorted by disabling lightening add-on but does not seems to affect all users. Not yet confirmed as a bug, could have been just a "glitch". Will raise a separate bug only if keeps happening. This had happened already in recent versions of TB but was sorted since. Not seen issue in 45 and 45.1.
Just to confirm, after a short while, the lightening add-on was re-enabled and "glitch" observed previously simply has now disappeared.
Flags: needinfo?(richard.leger)
Very strange. But I guess we can now call this WFM
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.