Add-on options are missing since 2015-10-08

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: cadeyrn, Unassigned)

Tracking

({addon-compat, regression})

Trunk
addon-compat, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8671357 [details]
screenshot.png

It's not longer possible to change add-on preferences in the add-on manager since today's Nightly (2015-10-08). It works in yesterday's Nightly. It affects my add-on https://addons.mozilla.org/de/firefox/addon/new-tab-override/, I didn't test other add-ons because I don't know which other add-ons have visible options in the add-on manager.

Tested on OS X 10.11 with a new profile and I got multiple reports from other users (email, German Firefox support forum).
UA "Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0 SeaMonkey/2.41a1" ID:20151008003001 c-c:5d74f3155ba28dc1606e81ea3db8e9521753d217 m-c:c6ede6f30f3dc886543bb1c76fd7c8b5a151786b

Ah, this is interesting.

In normal "unsafe" mode, with a third-party theme (Early Blue) and several extensions related to add-ons manager appearance, preferences work normally, both in the list page and in the details page.

But in Safe Mode (Help → Restart with Add-ons Disabled), which temporarily disables all extensions and all complete themes other than Default, I don't see any Preferences buttons.

Now which are my addons-manager-related extensions? Let's check the Troubleshooting Information page…

About Add-ons 0.7.1-signed
about:addons-memory 10.1-signed
Add-on Update Checker 2.13
Add-ons Manager - Version Number 1.0.4
Addons Manager Hilite 2.1.2.1-signed
Addons Recent Updates 0.1.6.1-signed
Slim Add-ons Manager 10.1-signed

and let's not forget the theme:

EarlyBlue 2.38

I haven't tried to narrow down which one(s) of these reestablishes the preferences buttons. EarlyBlue is not available for Firefox, but LCARSTrek, by the same author and developed in parallel, is. OTOH I extremely dislike the latter's flashy colors, but of course, beauty is in the eyes of the beholder.

Reporter: You might try to see if a third-party theme makes the problem disappear (try LCARSTREK first, and if it works but you don't like the looks, see if you can find another more pleasing one which also works); and if it doesn't, you might try the addons listed above and see if one (or maybe more) of them makes the problem disappear.

Developers: Maybe a look at the changesets committed between the one from which yesterday's Firefox 44.0a1 for the Mac was built, and the m-c changeset mentioned at the top of this comment, might give you an idea of what might have gone wrong. (I wouldn't know from the commit messages, but maybe one of you might.)
Severity: critical → major
Flags: needinfo?(cadeyrn)
OS: Unspecified → All
Hardware: Unspecified → All
Keywords: regression
Summary: Regression: Add-on options are missing since 2015-10-08 → Add-on options are missing since 2015-10-08
Oh, and I forgot:
Extension Options menu 2.14
(Reporter)

Comment 3

3 years ago
I installed all the add-ons and the theme LCARSTrek, the problem still exists. ;-)
Flags: needinfo?(cadeyrn)
(Reporter)

Comment 4

3 years ago
17:13.80 LOG: MainThread Bisector INFO Last good revision: d6059530b0317e6f6b141582b611469505256be4
17:13.80 LOG: MainThread Bisector INFO First bad revision: cfc1820361f599c55128b29de4332f8d06511e07
17:13.80 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d6059530b0317e6f6b141582b611469505256be4&tochange=cfc1820361f599c55128b29de4332f8d06511e07

@Shu-yu Guo: mozregression says one of your bugs (bug 589199 or bug 1202902) is the culprit.
Flags: needinfo?(shu)
I suspect that the const declaration for startup, shutdown, etc. in your bootstrap.js no longer does what you want since bug 1202902. Switching to a var declaration would probably fix it. Shu can you confirm that?
(In reply to Dave Townsend [:mossop] from comment #5)
> I suspect that the const declaration for startup, shutdown, etc. in your
> bootstrap.js no longer does what you want since bug 1202902. Switching to a
> var declaration would probably fix it. Shu can you confirm that?

And I just spotted that that is probably an add-on built with JPM, so any JPM based add-on is probably broken.
Bug 1212968 has updated JPM to fix the issue so updating JPM to 1.0.2 and rebuilding your add-on would solve your problem.
Depends on: 1212968
(Reporter)

Comment 8

3 years ago
Thanks. I can confirm that updating JPM to 1.0.2 and rebuilding the add-on solves the problem.

Comment 9

3 years ago
Oh okay, so... I don't know what's being asked of me anymore, but judging from comment 8 the issue seems resolved?
Flags: needinfo?(shu)
(Reporter)

Comment 10

3 years ago
For me the issue is resolved but I don't know if it's the plan that all developers of add-ons built with JPM rebuild their add-ons. In this case it should be noted in the add-on compatibility post that it's needed to update JPM and to rebuild the add-on.
Keywords: addon-compat
Bug 1213102 should cover the repacks. It sounds like this particular bug is fixed now. WFM, since it was fixed in the add-on.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
As far as I can tell the "New Tab Override" addon at https://addons.mozilla.org/en-US/firefox/addon/new-tab-override/ still has this problem.  Is that expected?
Flags: needinfo?(jorge)
Flags: needinfo?(cadeyrn)
(Reporter)

Comment 13

3 years ago
It's expected because it's fixed in version 1.1 and AMO rejected the new version 1.1 for a reason I don't understand (I didn't changed the logic compared to version 1.0). I still wait for a response so that I can do whatever the AMO guys want.

Until then you can find version 1.1 on http://git.agenedia.com/firefox-add-ons/newtaboverride/tree/master/dist
Flags: needinfo?(cadeyrn)
(Reporter)

Comment 14

3 years ago
(In reply to Boris Zbarsky [:bz] from comment #12)
> As far as I can tell the "New Tab Override" addon at
> https://addons.mozilla.org/en-US/firefox/addon/new-tab-override/ still has
> this problem.  Is that expected?

The fixed version 1.1 has been fully reviewed today and is now available.
Flags: needinfo?(jorge)
You need to log in before you can comment on or make changes to this bug.