Thunderbird fails to display folders, messages after 2015-10-08 update (due to ton of JS errors caused by change of semantics/scope of variable declarations)

RESOLVED DUPLICATE of bug 1209777

Status

Thunderbird
General
--
blocker
RESOLVED DUPLICATE of bug 1209777
2 years ago
2 years ago

People

(Reporter: bc, Unassigned)

Tracking

({regression})

Trunk
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Linux x86_64.
BuildID=20151008030223
SourceRepository=https://hg.mozilla.org/comm-central
SourceStamp=5d74f3155ba28dc1606e81ea3db8e9521753d217

Beginning with today's build Thunderbird will start but will not display the folder pane or the message pane and as a result in unusable.

It appears the change in JavaScript's let semantics has broken Thunderbird.

Timestamp: 10/08/2015 08:43:21 AM
Error: TypeError: redeclaration of let Cu
Source File: chrome://messenger/content/newmailaccount/uriListener.js
Line: 11

Timestamp: 10/08/2015 08:43:22 AM
Error: TypeError: aDocument.defaultView.FolderDisplayListenerManager is undefined
Source File: resource://gre/modules/quickFilterManager.js
Line: 1318

Timestamp: 10/08/2015 08:43:22 AM
Error: TypeError: gFolderDisplay is null
Source File: chrome://messenger/content/msgViewPickerOverlay.js
Line: 104

Timestamp: 10/08/2015 08:43:22 AM
Error: ReferenceError: Cc is not defined
Source File: chrome://viewabout/content/viewabout.js
Line: 4

Updated

2 years ago
Duplicate of this bug: 1212955

Updated

2 years ago
Duplicate of this bug: 1212957

Comment 3

2 years ago
I assume this is due to the landing of Bug 589199 and Bug 1202902.

Comment 4

2 years ago
Created attachment 8671544 [details] [diff] [review]
startup and new account part

This is a partial patch to at least allow TB to start in a new profile and create an account.
Attachment #8671544 - Flags: review?(mkmelin+mozilla)

Updated

2 years ago
Summary: Thunderbird fails to display folders, messages after 2015-10-08 update → Thunderbird fails to display folders, messages after 2015-10-08 update (due to ton of JS errors caused by change of semantics/scope of variable declarations)

Updated

2 years ago
Depends on: 1213018

Updated

2 years ago
Blocks: 589199, 1202902

Comment 5

2 years ago
Same issue here as well. I thought as earlier version crashed all the time I need to download manually and update it. Now I can't see anything, except all my settings, but no folder at all...

Comment 6

2 years ago
I also lost profiles.ini when trying to recover, but I am not sure if it is directly attributable to the changes.

Updated

2 years ago
Duplicate of this bug: 1213592

Comment 8

2 years ago
Should be fixed by bug 1209777.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1209777

Updated

2 years ago
Attachment #8671544 - Flags: review?(mkmelin+mozilla)
You need to log in before you can comment on or make changes to this bug.