Closed Bug 1216560 Opened 4 years ago Closed 4 years ago

Update change_wallpaper.py and change_layout.py in order to support the new homescreen

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jlorenzo, Assigned: njpark)

References

Details

Attachments

(1 file)

No description provided.
Comment on attachment 8676525 [details] [review]
[gaia] npark-mozilla:1216560 > mozilla-b2g:master

first attempt.  I suppose we need to do some manual merging with each other's PR requests.  

Both scripts are consistently passing.
Attachment #8676525 - Flags: review?(martijn.martijn)
Attachment #8676525 - Flags: review?(jlorenzo)
Comment on attachment 8676525 [details] [review]
[gaia] npark-mozilla:1216560 > mozilla-b2g:master

I'm fine with this.
But I suspect you are on an older tree, because I disabled these tests, so I expect in the pull request changes in the manifest.ini that would re-enable the test.
Attachment #8676525 - Flags: review?(martijn.martijn) → review+
Comment on attachment 8676525 [details] [review]
[gaia] npark-mozilla:1216560 > mozilla-b2g:master

The tests are passing again on my device. With these new changes, one test is a dupe of another we have in Settings. We might want to merge them - or remove one of them. Once that is resolved, I'm fine to land it.
Attachment #8676525 - Flags: review?(jlorenzo)
See Also: → 1216559
Attachment #8676525 - Flags: review?(jlorenzo)
I rebased after martijn's PR was merged
Blocks: 1217205
No longer blocks: 1217205
Comment on attachment 8676525 [details] [review]
[gaia] npark-mozilla:1216560 > mozilla-b2g:master

Looks good to me
Attachment #8676525 - Flags: review?(jlorenzo) → review+
I just realized the manifest is not updated. The tests have been disabled in bug 1216084.
Merged:
https://github.com/mozilla-b2g/gaia/commit/353a4abc812f181a9856f17af84493eefb7d3123
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Obviously the wrong bug number was referenced in the check-in of this. Not sure if it matters, but I'll CC the patch author. Not sure what the correct bug number is here.
Flags: needinfo?(esawin)
The landing of bug 1216460 has gone horribly wrong, thanks for notifying!
Flags: needinfo?(esawin)
You need to log in before you can comment on or make changes to this bug.