(Gaia RTL 2.5) CSS refactoring: Callscreen

RESOLVED FIXED in FxOS-S11 (13Nov)

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: pelloux, Assigned: pelloux)

Tracking

unspecified
FxOS-S11 (13Nov)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
This bug is for the CSS refactoring of the Callscreen app, following the new BiDi guidelines.
Depends on: 1217759
Depends on: 1217762
No longer depends on: 1217759
No longer depends on: 1217762
(Assignee)

Updated

3 years ago
Blocks: 1217762
(Assignee)

Updated

3 years ago
Blocks: 1217759
Created attachment 8680034 [details] [review]
[gaia] Phoxygen:bug1217377-callscreen-rtl-css > mozilla-b2g:master

Updated

3 years ago
Duplicate of this bug: 1217755

Updated

3 years ago
Duplicate of this bug: 1217759

Updated

3 years ago
Duplicate of this bug: 1217762
(Assignee)

Comment 5

3 years ago
Comment on attachment 8680034 [details] [review]
[gaia] Phoxygen:bug1217377-callscreen-rtl-css > mozilla-b2g:master

Hi Gabriele,
Could you review this PR please?
Attachment #8680034 - Flags: review?(gsvelto)
Comment on attachment 8680034 [details] [review]
[gaia] Phoxygen:bug1217377-callscreen-rtl-css > mozilla-b2g:master

Looks good to me, thanks!
Attachment #8680034 - Flags: review?(gsvelto) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/51879e8e6d8ac18dc2d8c455f11918fab3fc1111
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S11 (13Nov)
Comment on attachment 8680034 [details] [review]
[gaia] Phoxygen:bug1217377-callscreen-rtl-css > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): None
[User impact] if declined: Bad rtl experience for callscreen
[Testing completed]: on flame
[Risk to taking this patch] (and alternatives if risky): medium because the patch is big. There is no alternative to support RTL for the callscreen.
[String changes made]: none.
Attachment #8680034 - Flags: approval-gaia-v2.5?
Comment on attachment 8680034 [details] [review]
[gaia] Phoxygen:bug1217377-callscreen-rtl-css > mozilla-b2g:master

Clearing uplift as it is already in 2.5
Attachment #8680034 - Flags: approval-gaia-v2.5?

Comment 10

3 years ago
(In reply to Augustin Trancart [:autra] from comment #9)
> Comment on attachment 8680034 [details] [review]
> [gaia] Phoxygen:bug1217377-callscreen-rtl-css > mozilla-b2g:master
> 
> Clearing uplift as it is already in 2.5

I saw the commits on github history (Commits on Oct 28, 2015), but the patch doesn't work.
The action buttons on the dialer screen are at the same location.
Please refer to the bug 1217755.
You need to log in before you can comment on or make changes to this bug.