Go back to default collection settings on logout

RESOLVED FIXED in Firefox OS v2.5

Status

Firefox OS
Sync
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: On parental leave, Assigned: On parental leave)

Tracking

(Blocks: 1 bug)

unspecified
FxOS-S10 (30Oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.5 fixed)

Details

(Whiteboard: [partner-cherry-pick])

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

2 years ago
Assignee: nobody → ferjmoreno
Blocks: 824026
Priority: -- → P2
Target Milestone: --- → FxOS-S10 (30Oct)
(Assignee)

Updated

2 years ago
Depends on: 1216163

Comment 1

2 years ago
Created attachment 8679465 [details] [review]
[gaia] ferjm:bug1217381.default.settings > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Priority: P2 → P3
(Assignee)

Updated

2 years ago
Priority: P3 → P2
(Assignee)

Updated

2 years ago
Attachment #8679465 - Flags: review?(yliao)
Attachment #8679465 - Flags: review?(mbdejong)
(Assignee)

Comment 2

2 years ago
I filed bug 1220600 to also save/restore user preferences.
Comment on attachment 8679465 [details] [review]
[gaia] ferjm:bug1217381.default.settings > mozilla-b2g:master

Thanks! Should we enable save/restore settings per user?
Attachment #8679465 - Flags: review?(yliao) → review+
(Assignee)

Comment 4

2 years ago
(In reply to yifan [:yifan][:yliao] from comment #3)
> Comment on attachment 8679465 [details] [review]
> [gaia] ferjm:bug1217381.default.settings > mozilla-b2g:master
> 
> Thanks! Should we enable save/restore settings per user?

That's bug 1220600
Comment on attachment 8679465 [details] [review]
[gaia] ferjm:bug1217381.default.settings > mozilla-b2g:master

Cool! Comments on github.
Attachment #8679465 - Flags: review?(mbdejong) → review+
It's not ideal that the user needs to change settings each time they log in, and as discussed on irc, the proper solution for that would be if we could have real Gonk-level or Gecko-level user profiles on Firefox OS.

For the case of multiple users using the TV, this is patch is indeed an improvement. Getting the device's default settings each time is better than inheriting whatever the last user's settings were. :)
(Assignee)

Comment 7

2 years ago
https://github.com/mozilla-b2g/gaia/commit/64248276ddd182888d68a3cb68c22460bfbc91e3
(Assignee)

Comment 8

2 years ago
Comment on attachment 8679465 [details] [review]
[gaia] ferjm:bug1217381.default.settings > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Firefox Sync
[User impact] if declined: New users will inherit old users preferences.
[Testing completed]: Unit tests added.
[Risk to taking this patch] (and alternatives if risky): Low risk. This is part of a new feature that is under QA testing right now.
[String changes made]: None
Attachment #8679465 - Flags: approval-gaia-v2.5?
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Whiteboard: [partner-cherry-pick]
Comment on attachment 8679465 [details] [review]
[gaia] ferjm:bug1217381.default.settings > mozilla-b2g:master

Approved for 2.5 uplift. 

Thanks
Attachment #8679465 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Hi, this has conflicts uplifting to 2.5. Could you create a PR request for the 2.5 uplift, thanks!
Flags: needinfo?(ferjmoreno)
(Assignee)

Comment 11

2 years ago
This one is already in 2.5. I requested approval before the merge of master and 2.5. Sorry for the confusion.
Flags: needinfo?(ferjmoreno)
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #11)
> This one is already in 2.5. I requested approval before the merge of master
> and 2.5. Sorry for the confusion.

np :) setting flag too
status-b2g-v2.5: --- → fixed
You need to log in before you can comment on or make changes to this bug.