Update linux test slaves from Ubuntu 12.04 to 16.04

RESOLVED WONTFIX

Status

Release Engineering
Platform Support
RESOLVED WONTFIX
2 years ago
3 months ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Doing development on the test slaves is a pain because they are so old. They are also not very representative of what are users are running.
We won't tackle this in the existing automation. This will be easier once we've switched over to Task Cluster.
It looks like we have a 16.04 test image now and are starting to transition tests over to it. See for example bug 1281179.
See Also: → bug 1281179
Depends on: 1290183
Blocks: 1223198
AFAIK there are now no 32-bit Linux tests running and so this is covered by bug 1290183.
Status: NEW → RESOLVED
Last Resolved: a year ago
No longer depends on: 1290183
Resolution: --- → DUPLICATE
Duplicate of bug: 1290183
No longer blocks: 1223198
Huh? There most certainly are Linux32 tests running. There are no Linux32 tests running on Taskcluster, yet, both because the people doing the moving hope that Linux32 will die before they have to move it and because they've stalled out trying to move Linux64 opt/PGO, but it's not currently the case that we've dropped Linux32 testing.
Thanks for correcting me, Phil, and for the helpful info.  I must have
looked at treeherder at the wrong time, and/or not looked hard enough.
Blocks: 1223198
Status: RESOLVED → REOPENED
Depends on: 1290183, 1253315, 1209932
Resolution: DUPLICATE → ---
So we still want to use 14.04 and not 16.04 (bug 1281179 and dependencies) which is already in place in Taskcluster for a couple of test suites on Linux64? I think it should be way lesser work to take the docker configs and adapt those for 32bit by keeping all the necessary modules our suites need. Joel should be able to tell more about it.
we really should plan on 16.04 if possible.  There is work being done in bug 1287099 to get existing 12.04 tests running inside a docker image- then we can mirror the 16.04 image creation from 64 bit to 32 bit and repeat the greening up process.
16.04 is better than 14.04, yes.
Depends on: 1287099
Summary: Update linux test slaves from Ubuntu 12.04 to 14.04 → Update linux test slaves from Ubuntu 12.04 to 16.04
Component: Other → Platform Support
QA Contact: mshal → coop

Updated

3 months ago
Status: REOPENED → RESOLVED
Last Resolved: a year ago3 months ago
Resolution: --- → WONTFIX
Wontfix? Hasn't this been done already successfully for both Linux 32 and 64 TC workers? Or do I miss something?
Flags: needinfo?(jmaher)
this is specifically for the linux-ix (hardware) machines we have in the datacenter.  They only run Talos and on the new hardware that we are currently testing and will get the first batch next month, that will have Ubuntu 16.04
Flags: needinfo?(jmaher)
You need to log in before you can comment on or make changes to this bug.