Closed Bug 1218439 Opened 4 years ago Closed 4 years ago

[Aries] Apps display improperly in Landscape orientation, homescreen wallpaper visible on right side of screen

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-master --- verified

People

(Reporter: Marty, Assigned: mcav)

References

Details

(Keywords: regression, smoketest, Whiteboard: [2.5-Daily-Testing][Spark][dogfood-blocker][systemsfe])

Attachments

(5 files)

Description:
If the user views an app in Landscape orientation, the app window will only take up the left side of the screen, with the homescreen wallpaper visible on the right side of the screen.

This issue occurs in Landscape Marketplace apps (Cut the Rope, Swoop), as well as Browser, Gallery, 

Repro Steps:
1) Update a Aries to 20151026111709
2) Launch the Browser app
3) Rotate the device to Landscape Orientation

Actual:
The app will not display properly in landscape orientation, only showing in the left side of the device with the homescreen wallpaper visible on the right side.

Expected:
App displays properly in landscape orientation, and homescreen wallpaper is not visible.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151026111709
Gaia: a677ddd3aa3a81058775938bd56008d96dbc78b0
Gecko: 5ca03a00d26823ce91ee0eaa2937bed605bd53c1
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/6073/
See attached: Screenshot, Logcat
This issue does NOT occur on the latest Flame 2.5 Master build, or on the latest Spark Aries 2.5 Master build.
App displays properly in landscape orientation, and homescreen wallpaper is not visible.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151026030217
Gaia: a677ddd3aa3a81058775938bd56008d96dbc78b0
Gecko: 5ca03a00d26823ce91ee0eaa2937bed605bd53c1
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20151023103340
Gaia: 410e91ddabc7ba82a9b43b3711a3fdf2cb8de309
Gecko: 8ffcf080c975b372cc39a58b8b76d61de1767417
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:
Multiple apps can no longer properly show landscape mode.
blocking-b2g: --- → 2.5?
Apologies for being unclear.  This issue DOES happen on the latest Spark Aries 2.5 Master build (20151026111709).

This issue does NOT occur on the *previous* Spark Aries 2.5 Master build (20151023103340), or on the latest Flame 2.5 Master build (20151026030217).
Summary: Apps display improperly in Landscape orientation, homescreen wallpaper visible on right side of screen. → [Aries] Apps display improperly in Landscape orientation, homescreen wallpaper visible on right side of screen
QA Contact: jthomas
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Caused by changes made in Bug 920734

Mozilla Inbound Regression Window

Last Working
Environmental Variables:
Device: Aries 2.5
BuildID: 20151024055047
Gaia: 1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gecko: a120a9c5014542445741878642ba6ca030da04ef
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Aries 2.5
BuildID: 20151024054910
Gaia: 1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gecko: b227e94179e245747b321ec4bc106960afd731b4
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko
Gaia: 1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gecko: b227e94179e245747b321ec4bc106960afd731b4

Last Working gecko / First Broken gaia - This issue does NOT occur with broken Gaia
Gecko: a120a9c5014542445741878642ba6ca030da04ef
Gaia: 1c6628ed1e40575e5ec3669ab6ef389d4ebeea65

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a120a9c5014542445741878642ba6ca030da04ef&tochange=b227e94179e245747b321ec4bc106960afd731b4
Blocks: 920734
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qaurgent
Willian the changes for bug 920734 seem to have caused this issue.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(wchen)
I find it really odd that adding support for window.orientation/orientationchange event can affect the Browser and Gallery apps (3rd party apps would be less surprising).
It looks like we have been using 'orientationchange' in the codebase (as a custom event?): 

https://github.com/mozilla-b2g/gaia/blob/01ffe82cf088ca8fda9fe6783dc5cad2c3dde01c/apps/system/js/layout_manager.js#L187
https://github.com/mozilla-b2g/gaia/blob/fe82461fb410de261a77318847704863aec46403/apps/system/js/app_window_manager.js#L589

In some other places we use '_orientationchange'. 

I don't have a working build env for B2G, but I'm curious if we're not being buggy because we fire "real" orientationchange events now too.
Bug 920734 should not have changed the behavior of any existing orientation APIs. However, the patch introduced two new properties on the window, namely window.orientation and window.onorientationchange. This means that any script that use a variable named "orientation" on the global scope will likely break. The patch also introduced a new event on the window named "orientationchange" which may also conflict with any existing usage of that name. From a quick search, it looks like we were already using using it for something else: http://mxr.mozilla.org/gaia/source/apps/system/js/software_button_manager.js#68
Flags: needinfo?(wchen)
I went through the current usages of "orientationchange" that I could find and renamed it to "gaiaorientationchange" and I think this is enough to fix the bug (at least from my brief testing). Also, it seems to only happen when the software home button is enabled (which makes sense since the event listener is in "software_button_manager.js")
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][dogfood-blocker]
Assignee: nobody → m
Comment on attachment 8679178 [details] [review]
[gaia] mcav:wchen-gaiaorientationchange > mozilla-b2g:master

This is essentially :wchen's patch in PR format.
Attachment #8679178 - Flags: review?(timdream)
Whiteboard: [2.5-Daily-Testing][Spark][dogfood-blocker] → [2.5-Daily-Testing][Spark][dogfood-blocker][systemsfe]
blocking-b2g: 2.5? → 2.5+
Duplicate of this bug: 1218567
Comment on attachment 8679178 [details] [review]
[gaia] mcav:wchen-gaiaorientationchange > mozilla-b2g:master

Sorry for the trouble, but maybe the better name is "appwindow-orientationchange"?

It will be more specifically telling the consumer in system on where the event is come from.
Attachment #8679178 - Flags: review?(timdream) → review+
r+ because you should not worry about my comment if you disagree.
Priority: -- → P1
Renamed to "appwindow-orientationchange" as requested. Good names are worth it. :)

master: https://github.com/mozilla-b2g/gaia/commit/c517fe38823a5b7d4176de9e23c9bc57d2cbb603
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1218736
This bug has been verified as "pass" on the latest build of Aries KK v2.5 by the STR in comment 0.

Actual results: Rotate the device to Landscape Orientation, app displays properly and homescreen wallpaper is not visible.

See attachment: Verified_Aries_KK_v2.5_land.3gp

Reproduce rate: 0/10

Device: Aries KK 2.5 
Build ID               20151027221526
Gaia Revision          a26eadc5e1133d5112b6cbc10badbb7670a1090f
Gaia Date              2015-10-27 17:36:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2b333a1d94e805a59c619ee41a6dec7fdcce505d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151027.213419
Firmware Date          Tue Oct 27 21:34:27 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
See Also: → 1220071
See Also: → 1220102
This bug can be repro with new STRS. I filed a new bug 1220102.
You need to log in before you can comment on or make changes to this bug.