bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

History collection checkbox enabled although refresh auth didn't succeed

RESOLVED FIXED in Firefox OS v2.5

Status

Firefox OS
Sync
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ferjm, Assigned: ferjm)

Tracking

unspecified
FxOS-S10 (30Oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.5 fixed)

Details

(Whiteboard: [partner-cherry-pick])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Even if the user closes the refresh auth dialog, we still keep the history checkbox checked. The setting is not changed though, so there's not a privacy issue, but an UI one.
(Assignee)

Updated

3 years ago
Assignee: nobody → ferjmoreno
Blocks: 824026
Priority: -- → P3
Target Milestone: --- → FxOS-S10 (30Oct)
Created attachment 8681380 [details] [review]
[gaia] ferjm:bug1220117.history.setting.auth.ignored > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8681380 - Flags: review?(yliao)
Comment on attachment 8681380 [details] [review]
[gaia] ferjm:bug1220117.history.setting.auth.ignored > mozilla-b2g:master

Thank you!
Attachment #8681380 - Flags: review?(yliao) → review+
Comment on attachment 8681380 [details] [review]
[gaia] ferjm:bug1220117.history.setting.auth.ignored > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: A user will not know the history sync request fails.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=38f0591378e6de9324014f213c267060da3f6972
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8681380 - Flags: approval-gaia-v2.5?

Updated

3 years ago
Blocks: 1220541
(Assignee)

Comment 4

3 years ago
https://github.com/mozilla-b2g/gaia/commit/ef6800f3b30fe3269c9da1773b5b087769d62285
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Whiteboard: [partner-cherry-pick]
Comment on attachment 8681380 [details] [review]
[gaia] ferjm:bug1220117.history.setting.auth.ignored > mozilla-b2g:master

Approved for 2.5 uplift. 

Thanks
Attachment #8681380 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
This cause conflicts on uplifting to 2.5 - could you take a look and provide a 2.5 PR request ? Thanks!
Flags: needinfo?(ferjmoreno)
(Assignee)

Comment 7

3 years ago
This was fixed on 2.5 with bug 1220541
status-b2g-v2.5: --- → fixed
Flags: needinfo?(ferjmoreno)
You need to log in before you can comment on or make changes to this bug.