Closed Bug 1220605 Opened 4 years ago Closed 4 years ago

[TV Browser] The Browser Setting page disappears for a few seconds

Categories

(Firefox OS Graveyard :: Gaia::TV::Browser, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

VERIFIED FIXED
2.6 S2 - 12/4
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: cynthiatang, Assigned: yifan)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(2 files)

Attached file Video
STR:
 1. Launch Browser
 2. Sign in to Sync

Actual Result:
 - After typing the password and pressing enter, the Browser Setting page disappears for a few seconds. Please see the attachment. 

Expected Result:
 - After typing the password and pressing enter, the Browser Setting page should not disappear
QA Whiteboard: [COM=TV Firefox Account]
Priority: -- → P2
Hi Dan,
Over to you and feel free to reassign to Yifan if you like.
Assignee: nobody → dhuang
Flags: needinfo?(yliao)
Flags: needinfo?(dhuang)
Priority: P2 → P1
blocking-b2g: --- → 2.5+
Assignee: dhuang → yliao
Flags: needinfo?(yliao)
Status: NEW → ASSIGNED
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Comment on attachment 8691761 [details] [review]
[gaia] begeeben:1220605_the_browser_setting_page > mozilla-b2g:master

This problem happens at the 1st time a user sign in the fx account from the toolbar. The patch opens the settings page at the background after a user clicks the sign in button on the toolbar. Thus when the sign in flow is finished, the settings page will be displayed.
Flags: needinfo?(dhuang)
Attachment #8691761 - Flags: review?(ferjmoreno)
After bug 1219259 when Sync is enabled we don't show the settings panel but a popup letting the user know that Sync was enabled.

Tori, should we also show the settings panel when the user signs in from the toolbar and while Sync is enabling? Note that the settings panel won't be seen until the user finishes the FxA flow. So the UI flow when login from the toolbar would be something like:

1. Click on 'Sign in to Sync' will open the settings panel *and* the FxA flow. The FxA flow will be placed on top of the settings panel.
2. Once the user logs into FxA, the FxA flow will be hidden and the settings panel will be visible (with the 'Signing in...' label.
3. Eventually the popup informing about the enabled state will be shown. Dismissing the popup will show the settings panel again.

I am ok with this flow as it is similar to what happens when the user logs in from the settings panel instead of the toolbar, but I wanted to double check with you.
Flags: needinfo?(tchen)
> 2. Once the user logs into FxA, the FxA flow will be hidden and the settings
> panel will be visible (with the 'Signing in...' label.
> 3. Eventually the popup informing about the enabled state will be shown.

I was thinking the part would be like this:
A spinner/loading icon on login button when the user signing in. Once it's finished, the pop-up show up. So the user will not see the setting panel after the user press login button.

"the FxA flow will be hidden and the settings panel will be visible, then bring up the pop-up" seems strange to me. 

> Dismissing the popup will show the settings panel again.

Isn't it "Dismissing the popup and return to previous browsing tab"? The behavior should be same as user login from the settings panel.

Overall, the difference between login from setting panel and toolbar should be only that login from toolbar will be lead to to FxA flow directly. 

Hope I am understanding it right:P
Flags: needinfo?(tchen) → needinfo?(ferjmoreno)
Thank you Tori.

(In reply to Tori Chen [:tori] from comment #5)
> > 2. Once the user logs into FxA, the FxA flow will be hidden and the settings
> > panel will be visible (with the 'Signing in...' label.
> > 3. Eventually the popup informing about the enabled state will be shown.
> 
> I was thinking the part would be like this:
> A spinner/loading icon on login button when the user signing in.

We show the 'Signing in...' string in the toolbar login button, but it is not visible to the user until the FxA flow is closed.

> Once it's
> finished, the pop-up show up. So the user will not see the setting panel
> after the user press login button.
> 

No, with the attached patch, the user will see the settings panel *after* the FxA flow is closed.

Without the attached patch, the user will not see the settings panel at all, if the login was triggered from the toolbar.

> "the FxA flow will be hidden and the settings panel will be visible, then
> bring up the pop-up" seems strange to me. 
> 
> > Dismissing the popup will show the settings panel again.
> 
> Isn't it "Dismissing the popup and return to previous browsing tab"? The
> behavior should be same as user login from the settings panel.

1. If the login click happens from settings, the user will return to the settings panel after dismissing the popup.

2. If the login click happens from the toolbar:

2.1 With the attached patch, the user will return to the settings panel after dismissing the popup.
2.2 Without the attached patch, the user will return to previous browsing tab after dismissing the popup.

> 
> Overall, the difference between login from setting panel and toolbar should
> be only that login from toolbar will be lead to to FxA flow directly. 
>

In both cases we show the FxA flow directly.
 
> Hope I am understanding it right:P

It would be great if you could check the different behaviors with YiFan in real life :)
Flags: needinfo?(ferjmoreno) → needinfo?(tchen)
Thanks for explanation. It's clear to me now. 

> 1. If the login click happens from settings, the user will return to the settings panel after dismissing the popup.
> 2. If the login click happens from the toolbar:
> 2.1 With the attached patch, the user will return to the settings panel after dismissing the popup.
> 2.2 Without the attached patch, the user will return to previous browsing tab after dismissing the popup.

To be consistent, I'll vote 2.1. So your proposal (comment 4) is good to me.
Flags: needinfo?(tchen)
Comment on attachment 8691761 [details] [review]
[gaia] begeeben:1220605_the_browser_setting_page > mozilla-b2g:master

Thank you!
Attachment #8691761 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/97bd29ec28a873f694801d96546a0c7be02f690a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Blocks: fxos-sync
Priority: P1 → P3
Target Milestone: --- → 2.6 S2 - 12/4
Comment on attachment 8691761 [details] [review]
[gaia] begeeben:1220605_the_browser_setting_page > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: Sign in flow is not aligned to the spec
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=2ea8dc502071135f516677f7ce64f190157dd208
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8691761 - Flags: approval-gaia-v2.5?
Hi Tori,
Please update UX spec for this change. If the visual spec should be update, please ni the visual expert. Thank you!

(In reply to Tori Chen [:tori] from comment #7)
> Thanks for explanation. It's clear to me now. 
> 
> > 1. If the login click happens from settings, the user will return to the settings panel after dismissing the popup.
> > 2. If the login click happens from the toolbar:
> > 2.1 With the attached patch, the user will return to the settings panel after dismissing the popup.
> > 2.2 Without the attached patch, the user will return to previous browsing tab after dismissing the popup.
> 
> To be consistent, I'll vote 2.1. So your proposal (comment 4) is good to me.
Flags: needinfo?(tchen)
Comment on attachment 8691761 [details] [review]
[gaia] begeeben:1220605_the_browser_setting_page > mozilla-b2g:master

Approve for TV 2.5
Attachment #8691761 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Flags: needinfo?(tchen)
Verify this issue on the latest build.
After typing the password and pressing done to sign in, the screen shows the Success Sign-in message. And then pressing the OK button will back to the Browser Setting page.
[Build Info]
Environment: 2.6 Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/435a9320454ccc3ffdebff4d5d680f1254a15e26
gecko:
https://hg.mozilla.org/mozilla-central/rev/a9e33d8c48b5ca93ca1937eba4220f681a0f05ec
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.