Closed Bug 1220860 Opened 5 years ago Closed 5 years ago

[AccessFu] Error (intermediate value).documentElement is undefined resource://gre/modules/accessibility/AccessFu.jsm:526

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla45
Tracking Status
firefox45 --- fixed
b2g-v2.5 --- fixed

People

(Reporter: yzen, Assigned: yzen)

References

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

In some cases documentElement is not available and causes an error.
Caused by bug 1214398
What this also results in is that Pointer Adapter is not shut down and thus even though the AccessFu is stopped, the pointer events are still blocked and the device is inoperable.
Attached patch 1220860 patch (obsolete) — Splinter Review
Attachment #8682195 - Flags: review?(eitan)
Comment on attachment 8682195 [details] [diff] [review]
1220860 patch

Review of attachment 8682195 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/jsat/Presentation.jsm
@@ +697,5 @@
>      aPosition, aOldPosition, aReason, aStartOffset, aEndOffset, aIsUserInput) {
>      let context = new PivotContext(
>        aPosition, aOldPosition, aStartOffset, aEndOffset);
> +    if (context.accessible) {
> +      this.displayedAccessibles.set(context.accessible.document.window, context);

This seems to fail, because sometimes context.accessible is null
Attached patch 1220860 patch v2Splinter Review
Updated
Attachment #8682195 - Attachment is obsolete: true
Attachment #8682195 - Flags: review?(eitan)
Attachment #8682206 - Flags: review?(eitan)
Attachment #8682206 - Flags: review?(eitan) → review+
https://hg.mozilla.org/mozilla-central/rev/0aea92b111d7
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Duplicate of this bug: 1217386
Depends on: 1231833
For some reason the patch looks missing in v2.5 branch:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/file/tip/accessible/jsat/AccessFu.jsm#l526

If it didn't stick, is it possible to re-land it on v2.5?
Flags: needinfo?(cbook)
Blocks: 1231833
No longer depends on: 1231833
Flags: needinfo?(cbook)
You need to log in before you can comment on or make changes to this bug.