Thunderbird 38.x can't subscribe to more than 2 levels nested IMAP folders.

NEW
Unassigned

Status

Thunderbird
Folder and Message Lists
--
major
2 years ago
4 months ago

People

(Reporter: gangelies, Unassigned, NeedInfo)

Tracking

({regression})

38 Branch
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB38])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151015172906

Steps to reproduce:

1. Create more than 2 levels of nested IMAP folders
2. Unsubscribe from the IMAP folders you've created
3. Try to subscribe again
It seems a regression of Bug 592633


Actual results:

After unsubscribe the arrow for expanding the folder tree disappears, so I cannot see and subscribe the subsubdolders.
Using a different IMAP client (for example Roundcube Mail) the three level subfolders are regularly showed.


Expected results:

All IMAP folders with subfolders should have an arrow for unfolding them, no matter how deep the level is.
(Reporter)

Updated

2 years ago
Severity: normal → major
OS: Unspecified → All
Hardware: Unspecified → All
See Also: → bug 592633, bug 611280

Comment 1

2 years ago
gangelies,
At the time you reported the bug, had you tried the same thing in some prior months and not had the problem?
Flags: needinfo?(roberto.bartali2)
(Reporter)

Comment 2

2 years ago
Yes, with previous versions the problem does not occur
Flags: needinfo?(roberto.bartali2)

Comment 3

2 years ago
Thanks. 
The other bugs you cited would not likely be related because they were fixed so long ago. But let's leave them there for now.
See Also: → bug 1089351
Whiteboard: [regression:TB??]

Comment 4

2 years ago
I also suffer from this crippling bug. Using version 42. Somehow my local copies were compromised and it had to rebuild all my imap folders. Unfortunately I have about a dozen level-2 subfolders which I can't access anymore in thunderbird. There are still on the webmail though. I will install an older version of TB if I have to, which version should I install? 37?

Comment 5

2 years ago
I confirm the bug on TB 38.5.1 Linux_64 version and reiterate Geoffroy Menard req.
Can anybody tell if an old version of TB is not affected by this bug ? (37, 36 ......)
(Reporter)

Comment 6

2 years ago
I tried an old version of TB, the 24.0 Win32, and I found that it's not affected by this bug: I created 4 level nested folders, then I unsusbcribed e re-subcribed all that folders without problem.
Instead I confirm the bug in the latest version of TB (38.5.1 Linux_32).
Thanks

Comment 7

2 years ago
In 38.6 subscribing was possible, in later versions the bug reappeared!

Comment 8

2 years ago
(In reply to Christian from comment #7)
> In 38.6 subscribing was possible, in later versions the bug reappeared!

I've to add sth: maybe this issue happens only when using shared folders with cyrus or public namespace with dovecot. Haven't tried personal accounts.

Comment 9

2 years ago
It's not public namespace only, private folders are also affected.

Comment 10

2 years ago
Created attachment 8742069 [details]
thunderbird-folder.png

those folders should be shown:

    a2 LIST "" "*"
    * LIST (\HasChildren) "/" privat1
    * LIST (\HasChildren) "/" privat1/p1b
    * LIST (\HasNoChildren) "/" privat1/p1b/p1c
    * LIST (\HasNoChildren) "/" INBOX/Sent
    * LIST (\HasNoChildren) "/" INBOX/Drafts
    * LIST (\HasNoChildren \Sent) "/" Sent
    * LIST (\HasNoChildren \Drafts) "/" Drafts
    * LIST (\HasNoChildren \Trash) "/" Trash
    * LIST (\HasNoChildren) "/" test
    * LIST (\Noselect \HasChildren) "/" public
    * LIST (\HasChildren) "/" public/test-pub
    * LIST (\HasChildren) "/" public/test-pub/p1
    * LIST (\HasChildren) "/" public/test-pub/p1/p11
    * LIST (\HasChildren) "/" public/test-pub/p1/p11/p12b
    * LIST (\HasNoChildren) "/" public/test-pub/p1/p11/p12b/p123a
    * LIST (\HasNoChildren) "/" public/test-pub/p1/p11/p12b/p123b
    * LIST (\HasNoChildren) "/" public/test-pub/p1/p11/p12
    * LIST (\HasChildren) "/" INBOX
    a2 OK List completed.

Comment 11

2 years ago
@2016-04-08 09:56:27 PDT: before 38.6 it was possible, in 38.6 it isn't.

Updated

2 years ago
Duplicate of this bug: 1244779

Comment 13

2 years ago
So here is my analysis.

The issue first appears in TB 38, and continues into TB 45.

Actually newer versions still work in the backend the same way that they did in TB 31, and you actually can see the unsubscribed folders, but because of a UI change that is not apparent.

The work around with TB 38 and TB 45.0 is this. Suppose I have multiple levels of folders:

P1
--P12
----P123
------P1234

and that all are unsubscribed. In TB 31 and earlier, when I open the subscribe dialog, it only has top-level folders open, so I see:

>INBOX
>P1

If I open P1, P12 will appear. If I open P12, then P123 will appear etc.

In TB 38, I would see:

>INBOX
|P1
--P12

(">" is the closed children marker, "|" the open children marker)

That is, I see two open levels, but there is no indicator on P12 that it has children, and no way to open it to see its children. However, I can do exactly what I did in TB 31 and it works. If I close P1 and reopen it, then I see P12 with a children marker. I can open P12, then I see P123.  You may have to close and open sometimes, but you can see all of the unsubscribed folders. This is the workaround. (You can also just disable Show Only Subscribed Folders for the account, and all folders will appear in the folder pane.)

So there is some issue in the UI changes for TB 38. Either it needs to start collapsed, or we need to figure out why the HasChildren information is not propagating to the initial display of P12 in the open dialog.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

2 years ago
Whiteboard: [regression:TB??] → [regression:TB38]

Comment 14

2 years ago
So at this point this issue is a UI problem and not an IMAP backend problem, or at least the next step is to investigate the UI display issues, with a possible workaround to just open this dialog fully collapsed.

Comment 15

2 years ago
Kent, sorry, maybe I haven't understood something, but your workaround isn't working for me (TB 38.6.0, Linux). In the subscribe dialog I get two levels only for unsubscribed folders. If they were subscribed with another client before all folders are shown in subscribe-dialog. 

I can disable "Show Only Subscribed Folders" and then all are shown (only in main window, not in subscribe window).

Comment 16

2 years ago
"In the subscribe dialog I get two levels only for unsubscribed folders. If they were subscribed with another client before all folders are shown in subscribe-dialog. "

I don't really understand this, probably a language issue. Could you try to reword this?

Comment 17

2 years ago
I only see two levels of unsubscribed folder. Closing and re-opening the parent folder doesn't help.
I see only more than two levels in the subscribe window, when those folders were subscribed in another client before. But if they are not subscribed, there are only two levels. Is this description clearer? Or did I understand the work around wrongly?

Comment 18

2 years ago
Thanks, yes now I understand.

In the test account that you setup, running TB trunk (48.0a1 local build Windows 10) here are more details of what I see and do.

There is a namespace "public", with a subscribed subfolder "test-pub". test-pub has an unsubscribed subfolder "p1" that in turn is the parent to a whole tree of unsubscribed folders.

Opening the subscribe dialog, I see (using "|" to mean downarrow):

|public
  |test-pub
    p1

If I open and close public, nothing changes. If I open and close test-pub, after a short delay of less than a second, p1 gets the down arrow:

|public
  |test-pub
    |p1

If I open and close p1, I see:

|public
  |test-pub
    |p1
      |p11

etc.

That does not work for you?

Comment 19

2 years ago
I've intentionally used another account, but I have access to the same public folder.

In 38.6.0 I only see this:

|public
  |test-pub
    p1

I can click test-pub as often as I want. It doesn't change anything.

Comment 20

2 years ago
Christian, is this on Windows or Ubuntu for you? I see different OSes in your history.

Comment 21

2 years ago
My test today is Ubuntu.

Comment 22

2 years ago
In Windows 10 Thunderbird 45.0 (beta Update channel), Earlybird 46.0a2 and 47.0a2 don't get any further:

|public
  |test-pub
    p1

Updated

2 years ago
Keywords: regression

Comment 23

2 years ago
Here's an update.

I've tried restoring the UI behavior of pre-38 releases, namely starting with all folders collapsed in the subscribe dialog. This mostly works for me, but unfortunately there is some sort of race condition that prevents it from working in some cases. Christian from Bug 1264724 sees this always, but I have seen it occasionally in my environment as well. Also, unfortunately I am not seeing it now so I cannot debug it. This is all made worse by the fact that this is an old RDF template implementation that has been mostly removed from Mozilla code, precisely because it is so darn hard to debug any issues that occur there such as this one.

So I am tempted to just accept the patch in bug 1244779, and live with the consequences for environments where there are large numbers of unsubcribed folders. That is better than not working at all. But still looking at it all.

Comment 24

2 years ago
There are many outlook.com/IMAP issues on the net, that are probably not related to this bug, but they mention also this subscription problem: https://bugzilla.mozilla.org/show_bug.cgi?id=1212852

Comment 25

a year ago
I confirm of existanse of this bug. I suffer from this bug from TB 31 ver. So, if I install ver 31 - it is working. ver 38 and 45 - doesn't work :(
The patch in bug 1244779, which I initially rejected, scans all folders at multiple levels. That was not done originally because of the risk that it would lock the system if there are large numbers of unsubscribed folders.

But that seems to me to be a lesser evil than the current state, which is not working. Any opinions about whether we are likely to see users with lots and lots of unsubscribed folders?

Comment 27

a year ago
obvious workaround is to create a global variable which sets the depth of scanning. Let it be 5 by default. When the system finishs the scaning of 5 levels, a dialog with to continue scanning may appear. It should be possibility to change global variable value using ediror.

Updated

a year ago
Duplicate of this bug: 1244021
NI myself to consider a solution like my comment 26.
Flags: needinfo?(rkent)

Comment 30

a year ago
@Kent: Your workaround is working for me. I double clicked the parent folders and that's not working. You have to click on the small arrow on the left.

Comment 31

a year ago
TB 45.2.0 on ubuntu 16.04 64bit, outlook server

i'm in the same situation here, for now i have used the webclient (outlook web app) to move my sub-level-2 folders to level 2 as a temp workaround

FWIW : today i ran into this bug and it seems like it was triggered by subscribing to a folder and hitting the 'ok' button before hitting the 'subscribe' button (hope that makes sense)
Once i hit the 'ok' button all of my folder subscriptions were gone and when i wanted to subscribe again i ran into this issue

if i create a new 'level 3' folder it shows up, but old level 3 folders dont show up

Comment 32

a year ago
This has bitten my twice in the past month (most recently with version 45) and is quite a pain to fix. I hope it can be resolved soon.
I'm leaning toward just accepting that patch in bug 1244779 that I initially rejected, because although it adds the risk of UI jank if there are zillions of folders, that is a lesser evil than the current situation. There is probably a better way to do that, but in the interest of just fixing it maybe that is what we should do.
Flags: needinfo?(rkent)
Didn't mean to remove the NI to myself.
Flags: needinfo?(rkent)

Comment 35

7 months ago
Issue still exists in 45.7.0/Linux. It has cost me half a day now to figure out why all folder are suddenly gone. Are there any plans to fix this? Reading through the bug reports, it is really disappointing that this does not get implemented just because there could be some UI issues in extreme cases? How many people have a zillions of subfolders practially compared to how may people have a few level here and can't access them.

Please fix this. It seem perfectly ok to me if there is a config option that limits the number of subfolders to a reasonable value by default, say five levels? One can increase this if needed to any number.

Comment 36

7 months ago
@Axel: Open and close the folder by clicking on the triangle on the left. Do not use double-click. Start at the topmost folder level and continue for all sub levels. Then all folders are shown.

Thunderbird is able to display all folders, it's only an UI issue.

Comment 37

7 months ago
@Christian: Thanks, that worked. So it's really implemented, but just very hard to find. And even harder to understand why/when the triangles appear and when not.

Comment 38

4 months ago
How in the world would one know when to do this exercise?

If you've only got a few sub-folders, you easily notice if one is missing. If there are a lot more, it becomes guesswork. Just to be on the safe side, you've got to do the click-dance on every single one of them. Really?
You need to log in before you can comment on or make changes to this bug.