Browser history search page shows extra space (RTL alignment) on URL for some websites

VERIFIED FIXED

Status

Firefox OS
Gaia::Search
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: piwei, Assigned: autra)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing] [spark][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8682848 [details]
Screenshot of issue

Description:
On search bar when user types things in there the search panel will start to populate results based on sites they have visited. On this page some visited websites will show extra space in front of URL, making the appearance non unified and weird.

STR:
1) Open Browser, type in www.nfl.com into address bar and hit enter
2) Kill the browser app after the website loads
3) On Homescreen top, invoke search bar UI by tapping on 'Search or enter address'
4) Notice the alignment of text being displayed here

Optional step:
5) Go to google.com. And repeat steps 3 & 4 to see how this page should look like

Expected at step 4:
Search panel displays text correctly aligned (aligned to the left)

Actual at step 4:
Extra space in front of URL on some websites. It appears to align to the right (RTL) instead of aligning to the left.

Notes:
This doesn't occur on all websites. So far I've see this reproduce when the panel tries to display nfl.com, kotaku.com, cnn.com, or imgur.com

Repro rate: 5/5

Attaching screenshot and logcat on following comment.

Device: Aries 2.6
BuildID: 20151103140850
Gaia: 06de78d2c61c084956640c480280ba518b2fe29f
Gecko: 59a6ad6a921f4809dfc37d943d765300c65721e5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.6
BuildID: 20151103030244
Gaia: 06de78d2c61c084956640c480280ba518b2fe29f
Gecko: bb4d614a0b09bcb9738c151dccfcd9b3857a6a7c
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
(Reporter)

Comment 1

3 years ago
Created attachment 8682850 [details]
logcat of issue
(Reporter)

Comment 2

3 years ago
Flame 2.5 is also affected.

Device: Flame 2.5
BuildID: 20151103004501
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 4e0955369a51850f2982087145ac5c2df257ffe9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

---------

Flame 2.2 is unaffected. Tried all the affected websites and it displays their results as LTR.

Device: Flame 2.2
BuildID: 20151103032504
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: b8b7f4efaa6e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.6-Daily-Testing], [spark]
This issue doesn't seem major so not nominating to block.  Alison can I get your opinion as well?

Let's get a window here regardless.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ashiue)
Whiteboard: [2.6-Daily-Testing], [spark] → [2.6-Daily-Testing] [spark]
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
QA Contact: pcheng

Comment 4

3 years ago
www.mozilla.org also has this problem.

Add developers in CC list to aware this issue.
Flags: needinfo?(ashiue)
Whiteboard: [2.6-Daily-Testing] [spark] → [2.6-Daily-Testing] [spark][systemsfe]
(Reporter)

Comment 5

3 years ago
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20151020021908
Gaia: d3becb4a5dfd01f3b150b6c52a2afb1e7a129819
Gecko: bab3e830f65d7466df7f4e0ee90615425a2d47fb
Version: 44.0a1
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Device: Flame
BuildID: 20151020031325
Gaia: 71540b8d8cc086c863bb6e91dc5b00799d6f4871
Gecko: 660daf08abd88aff95b409a860b97df9bbbfc2d9
Version: 44.0a1
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working Gaia First Broken Gecko - no repro
Gaia: d3becb4a5dfd01f3b150b6c52a2afb1e7a129819
Gecko: 660daf08abd88aff95b409a860b97df9bbbfc2d9

Last Working Gecko First Broken Gaia - repro
Gaia: 71540b8d8cc086c863bb6e91dc5b00799d6f4871
Gecko: bab3e830f65d7466df7f4e0ee90615425a2d47fb

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/d3becb4a5dfd01f3b150b6c52a2afb1e7a129819...71540b8d8cc086c863bb6e91dc5b00799d6f4871

This issue is likely caused by changes made in Bug 1214136.
Blocks: 1214136
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Augustin can you please take a look at this?  Seems to have been caused by the changes for bug 1214136.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(augustin.trancart)
(Assignee)

Updated

3 years ago
Blocks: 1181921
(Assignee)

Updated

3 years ago
No longer blocks: 1214136
Flags: needinfo?(augustin.trancart) → needinfo?(augustin.trancart)
(Assignee)

Updated

3 years ago
Assignee: nobody → augustin.trancart
Status: NEW → ASSIGNED
Flags: needinfo?(augustin.trancart)
Created attachment 8684113 [details] [review]
[gaia] Phoxygen:1221367-browser_meta_alignment > mozilla-b2g:master
(Assignee)

Comment 8

3 years ago
Comment on attachment 8684113 [details] [review]
[gaia] Phoxygen:1221367-browser_meta_alignment > mozilla-b2g:master

hi Kevin,

I'm ashamed of this! Please r?
Attachment #8684113 - Flags: review?(kevingrandon)
Comment on attachment 8684113 [details] [review]
[gaia] Phoxygen:1221367-browser_meta_alignment > mozilla-b2g:master

Sorry for not catching this, this looks good. Thanks.
Attachment #8684113 - Flags: review?(kevingrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/8e1f4f8156232e39d5e5df90d41fdd59de9c028d
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

3 years ago
Comment on attachment 8684113 [details] [review]
[gaia] Phoxygen:1221367-browser_meta_alignment > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: Bad RTL support.
[Testing completed]: on flame master
[Risk to taking this patch] (and alternatives if risky): Very low, only text-alignment.
[String changes made]: none
Attachment #8684113 - Flags: approval-gaia-v2.5?
This bug has been verified as "pass" on the latest build of Flame KK v2.5&2.6 512mb and Aries KK v2.5&2.6 by the STR in comment 0 .

Actual results: Search panel displays text correctly aligned (aligned to the right)
See attachment: Virified1_v2.6.png
Reproduce rate: 0/5.

Device: Aries kk v2.6 master(Pass)
Build ID               20151109151826
Gaia Revision          23cab7ea0fcecab7689d340baf604e024e88f9a3
Gaia Date              2015-11-09 06:13:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e1ef2be156de1dad31bb4189a51b178b12b23340
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151109.143842
Firmware Date          Mon Nov  9 14:38:50 UTC 2015
Bootloader             s1

Device: Flame kk v2.6 master(Pass)
Build ID               20151109150204
Gaia Revision          23cab7ea0fcecab7689d340baf604e024e88f9a3
Gaia Date              2015-11-09 06:13:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e1ef2be156de1dad31bb4189a51b178b12b23340
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.182508
Firmware Date          Mon Nov  9 18:25:22 EST 2015
Bootloader             L1TC000118D0


Device: Flame KK 2.2  512mb(Pass)
Build ID               20151109032503
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6ea91190b53
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.065527
Firmware Date          Mon Nov  9 06:55:39 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-v2.5: affected → verified
status-b2g-master: affected → verified
Created attachment 8685333 [details]
Virified1_v2.6.png

Comment 14

3 years ago
(In reply to zouyi from comment #12)
 
> Device: Flame KK 2.2  512mb(Pass)
> Build ID               20151109032503
> Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
> Gaia Date              2015-10-07 13:05:24
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6ea91190b53
> Gecko Version          37.0
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20151109.065527
> Firmware Date          Mon Nov  9 06:55:39 EST 2015
> Firmware Version       v18D v4
> Bootloader             L1TC000118D0

Is this a typo? Are you verifying it on v2.5 or v2.2?
Flags: needinfo?(yi.zou)
Sorry for typo. The bug is verified to pass on v2.5 build. Below is the v2.5 build info.

Device: Flame KK v2.5 512mb(Pass)
Build ID               20151109004552
Gaia Revision          cf646c52bb947af28329b0a100df91d1b1f2a907
Gaia Date              2015-11-09 02:55:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/4eafef5b80f8985c94c4a067f130d37513e1a581
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.041411
Firmware Date          Mon Nov  9 04:14:26 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20151110094357
Gaia Revision          07baf613699fa6225359c7f04825c5caeb71d424
Gaia Date              2015-11-09 21:32:50
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/e14287b00a514a15418dfaa89287030c588ad19d
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.090331
Firmware Date          Tue Nov 10 09:03:39 UTC 2015
Bootloader             s1
Flags: needinfo?(yi.zou)
Comment on attachment 8684113 [details] [review]
[gaia] Phoxygen:1221367-browser_meta_alignment > mozilla-b2g:master

Tested and verified. Approved for 2.5 uplift. 

Thanks
Attachment #8684113 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.