Music completely stops as soon as user returns Home

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: pcheng, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing], [spark])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8683819 [details]
logcat of issue

Description:
This audio issue could be more widespread as I had noticed that sound seems to get interrupted when it enters FTU after flashing. I assume that's the screen reader sound but since it got interrupted I'm not sure what that is supposed to be.

The most obvious one which is this bug, music sound stops altogether as soon as user returns Home.

STR:
1) Play any music in Music app
2) Press Home button

Expected: Music continues to play

Actual: Music stops. As soon as user returns to Music app, music resumes to play. However I've seen it not resuming and music just seems to stuck.

Repro rate: 4/5

Video of issue:
https://www.youtube.com/watch?v=qU8pw4WHYDY

Also attaching a logcat.

Device: Flame 2.6 Master
BuildID: 20151105043936
Gaia: c3be747b993f0c70e7b93a709ef691383c88fc01
Gecko: 61dcc13d0848230382d5c85cdcf6721a05ee37c6
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Aries 2.6 Master
BuildID: 20151105134116
Gaia: c3be747b993f0c70e7b93a709ef691383c88fc01
Gecko: 61dcc13d0848230382d5c85cdcf6721a05ee37c6
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
(Reporter)

Comment 1

3 years ago
This issue does not occur on today's smoke test central build. (the above affected builds are latest central builds)

Device: Flame KK 2.6 (512MB)
BuildID: 20151105030203
Gaia: 607b9c5db7fdbbafc16a572e7c319baa266a3372
Gecko: 59c648a3f95524cb1ee42f2306c1db2698d35258
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6)
Firmware Version: v18D v4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.5: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.6-Daily-Testing], [spark]
(Reporter)

Comment 2

3 years ago
2.5 is unaffected.

Device: Flame 2.5
BuildID: 20151105004500
Gaia: 47da49f8206788d70d834c3a63d9245d50c89103
Gecko: 5c9fd135d4309239794126f1942d6e7aa8b3579c
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
This is a major break in functionality.  Let's get a window here.  Ni? No-Jun for awareness.
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(npark)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
QA Contact: pcheng
I flashed my Aries yesterday with the latest 2.6 build, and this does not repro.
Pushing today's Music app to my Aries with yesterday's Gecko does not cause this bug. So I don't think that the Music app has broken anything.

But if I do a make reset-gaia with today's Gaia on top of yesterday's gecko then I do see this bug. So that probably means that this is a Gaia bug.
This bug is not specific to the homescreen.  If I run Camera or Browser then run music, and then swipe to go back to the other app, the music will stop, even though homescreen is not invoked.

That makes me think that this is a regression in the system app.  And I see that this bug is already filed under AudioChannel, so that seems good.

Pulling down the notification tray does not interrupt the music.  Bringing up the task manager does not interrupt the music. But selecting any app in the task manager, including the music app itself does interrupt the music.

For me, when I return to he music app after it has paused, I get about a half a second of music then it stops again. But it thinks it is still playing so displays a pause button rather than a play button. To get the music to come back in this state, I have to tap the button twice.

If I push the sleep button while music is playing, music keeps playing, and there are playback controls on the lockscreen. This is good.

If I play music and then go to the homescreen, the music stops, and there are no playback controls on the lockscreen or in the notification tray. That makes me think that this isn't just a temporary interruption in the music playback but that it has actually stopped.
(Reporter)

Comment 7

3 years ago
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20151104233436
Gaia: 8950676a273bd902a9ae63d7ef9afc59e14ebd81
Gecko: 4b9fc19085ce64853fc9766fe23427ed338067a3
Version: 45.0a1 (2.6 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Device: Flame
BuildID: 20151105001240
Gaia: cf0703f147e17bea1b18b58ada82625151238220
Gecko: 7ef21759cf8a07131691b09b4862fff1153830d4
Version: 45.0a1 (2.6 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working Gaia First Broken Gecko - no rero
Gaia: 8950676a273bd902a9ae63d7ef9afc59e14ebd81
Gecko: 7ef21759cf8a07131691b09b4862fff1153830d4

Last Working Gecko First Broken Gaia - repro
Gaia: cf0703f147e17bea1b18b58ada82625151238220
Gecko: 4b9fc19085ce64853fc9766fe23427ed338067a3

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/8950676a273bd902a9ae63d7ef9afc59e14ebd81...cf0703f147e17bea1b18b58ada82625151238220

Caused by changes made in Bug 1209062.
Blocks: 1209062
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Yura can you please take a look at this issue.  Seems to have been caused by the changes for Bug 1209062.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(yzenevich)
I just came to the same conclusion. Backing out bug 1209062 fixes this.
Jim: flagging you so that this is on your radar. Yura's accessibility patch in bug 1209062 seems to somehow activate the screen reader on every app transition, and that is somehow causing audio channel issues that are interrupting music. What I don't get is why the music doesn't resume once the screen reader is done.  I don't know if there is anything you can do differently in Music to accomodate this gracefully. Are you handling mozinterruptbegin/mozinterruptend at all, for example?
Flags: needinfo?(squibblyflabbetydoo)
(In reply to David Flanagan [:djf] from comment #9)
> I just came to the same conclusion. Backing out bug 1209062 fixes this.

I have a feeling landing lastest PR for bug 12909062 only exposed the issue with the audio channel that is mentioned in comment 6.

Regardless my PR is backed out or not, the audio problems really make screen reader unusable.
Investigating more.
I will also make sure (followup) we don't speak if screen reader is off.
Flags: needinfo?(yzenevich)

Updated

3 years ago
Depends on: 1222249
Fixes with bug 1222249
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 14

3 years ago
Hi, David,
I think the problem might be the same as [1].
We found that the "content" (music) type audio doesn't be resumed after the "normal" (media from setting app) type audio ended.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1037745#c3

Updated

3 years ago
Flags: needinfo?(npark)
Duplicate of this bug: 1222304
Duplicate was a smoketest blocker so putting that tag here.
Keywords: smoketest

Updated

3 years ago
Duplicate of this bug: 1222302

Updated

3 years ago
Flags: needinfo?(squibblyflabbetydoo)
Created attachment 8684789 [details]
Verified video:Aries_v2.6.3gp

This bug has been verified as "pass" on the latest build of Aries KK v2.6 and Flame KK v2.6 512mb by the STR in comment 0.

Actual results: After step two,Music continues to play.

See attachment:Verified Aries_v2.6.3gp.
Reproduce rate: 0/10.

Device: Aries KK v2.6 (master)(Pass)
Build ID               20151107001102
Gaia Revision          c3436122d678911d04b8f491724596116890ff9b
Gaia Date              2015-11-06 18:22:03
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e2a910c048dc82fc3be53475f18e7f81f03e377b
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151106.232924
Firmware Date          Fri Nov  6 23:29:32 UTC 2015
Bootloader             s1

Device: Flame KK v2.6 512mb (master)(Pass)
Build ID               20151108150206
Gaia Revision          c3436122d678911d04b8f491724596116890ff9b
Gaia Date              2015-11-06 18:22:03
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e2a910c048dc82fc3be53475f18e7f81f03e377b
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151108.183921
Firmware Date          Sun Nov  8 18:39:33 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [MGSEI-Triage+]
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.