Closed Bug 1222295 Opened 6 years ago Closed 6 years ago

Cancel button from sharing ringtone action menu is incorrect

Categories

(Firefox OS Graveyard :: Gaia::Ringtones, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-, b2g-v2.2 unaffected, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g -
Tracking Status
b2g-v2.2 --- unaffected
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: ashiue, Assigned: kgrandon)

References

Details

Attachments

(4 files)

STR: 
1. Go to Setting > Sound > Manage Tones
2. Tap any "..." for any ringtone
3. Check the action menu

Expected result:
1. Cancel buttons shows correctly

Actual result:
1. Incorrect cancel buttons 

Build info:
[Flame]
Build ID               20151105004500
Gaia Revision          47da49f8206788d70d834c3a63d9245d50c89103
Gaia Date              2015-11-03 21:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/5c9fd135d4309239794126f1942d6e7aa8b3579c
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.043012
Firmware Date          Thu Nov  5 04:30:24 EST 2015
Bootloader             L1TC000118D

[Aries]
Build ID               20151105235624
Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919
Gaia Date              2015-11-05 18:52:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151105.231433
Firmware Date          Thu Nov  5 23:14:41 UTC 2015
Bootloader             s1
[Blocking Requested - why for this release]:
Regression issue

Hi Kevin, could you please help to check this issue? Thank you.
blocking-b2g: --- → 2.5?
Flags: needinfo?(kevingrandon)
Comment on attachment 8684034 [details] [review]
[gaia] KevinGrandon:bug_1222295_ringtones_menu_rendering > mozilla-b2g:master

Converting this menu to use gaia-menu fixes the problem.

Jim - could you take a look when you have time? Thanks!
Flags: needinfo?(kevingrandon)
Attachment #8684034 - Flags: review?(squibblyflabbetydoo)
Component: Gaia::Components → Gaia::Ringtones
Hi Kevin,

    I also find this bug occurs on Email app, Usage app and Video app on latest Flame KK v2.5/2.6 and Aries KK v2.5/2.6, the "Cancel" button is not displayed as an oval button, and it appears as a rectangular button similar to other options in the menu, which is similar with comment 0. Please see attachment "Flame_v2.6.png". 
    Could you please help to confirm this? Or may I submit a new bug for your resolution?

Thanks.


---------------------------------------------
Device: Flame KK 2.5  512mb (affected)
Build ID               20151109004552

Device: Flame KK v2.6 512mb (master)(affected)
Build ID               20151109150204

Device: Aries KK 2.5 (affected)
Build ID               20151107112205

Device: Aries KK 2.6 (master)(affected)
Build ID               20151109151826
Flags: needinfo?(kevingrandon)
QA Whiteboard: [MGSEI-Triage+]
(In reply to Shally Li from comment #4)
> Hi Kevin,
> 
>     I also find this bug occurs on Email app, Usage app and Video app on
> latest Flame KK v2.5/2.6 and Aries KK v2.5/2.6, the "Cancel" button is not
> displayed as an oval button, and it appears as a rectangular button similar
> to other options in the menu, which is similar with comment 0. Please see
> attachment "Flame_v2.6.png". 
>     Could you please help to confirm this? Or may I submit a new bug for
> your resolution?

Sigh, each one of these spots should be a new bug. Can you open a new bug for each one of these issues and block bug 1196268? Thanks!
Flags: needinfo?(kevingrandon) → needinfo?(lixia)
Hi Kevin,

    I have submitted three new bugs for the Email app/Usage app/Video app, please see Bug 1223683, Bug 1223684, Bug 1223685, thanks.
Flags: needinfo?(lixia) → needinfo?(kevingrandon)
Flags: needinfo?(kevingrandon)
Assignee: nobody → kevingrandon
Comment on attachment 8684034 [details] [review]
[gaia] KevinGrandon:bug_1222295_ringtones_menu_rendering > mozilla-b2g:master

Looks good to me. Sorry for the review delay!
Attachment #8684034 - Flags: review?(squibblyflabbetydoo) → review+
Thanks for the review. In master: https://github.com/mozilla-b2g/gaia/commit/27834daeddc381e79c9bab275ce7be0cdbc4a08f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8684034 [details] [review]
[gaia] KevinGrandon:bug_1222295_ringtones_menu_rendering > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Platform regression requiring UI updates.
[User impact] if declined: Poor UX in ringtones menu.
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, we're moving to a shared component.
[String changes made]: None.
Attachment #8684034 - Flags: approval-gaia-v2.5?
Not a release blocker per criteria. 

Thanks
Hema
blocking-b2g: 2.5? → -
Comment on attachment 8684034 [details] [review]
[gaia] KevinGrandon:bug_1222295_ringtones_menu_rendering > mozilla-b2g:master

For consistent behavior can we have other similar bugs finished too?

Approving this patch for 2.5, few others have already landed.
Attachment #8684034 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
This bug has been verified as "pass" on the latest build of Flame KK 2.6 and Aries KK 2.6 by the STR in comment 0.

Actual results: Cancel button from sharing ringtone action menu is shown as an oval button correctly.
See attachment: verified_Flame_v2.6.png
Reproduce rate: 0/10


Device: Flame KK 2.6(master) 512mb (Pass)
Build ID               20151119150204
Gaia Revision          94a821b49f4dca3f9321cd80e13c44c4a6696952
Gaia Date              2015-11-19 15:35:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc325db44f6f8a58604d60b746c140e73f3d8216
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151119.182720
Firmware Date          Thu Nov 19 18:27:32 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.6 (master)(Pass) 
Build ID               20151118150439
Gaia Revision          cba7e4b86361af31b153cfebaf99900e0b860f7b
Gaia Date              2015-11-18 09:45:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1d6155d7e6c91fa5ec1ef6927f3d3a044187896d
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151118.142334
Firmware Date          Wed Nov 18 14:23:42 UTC 2015
Bootloader             s1
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aries KK 2.5 by the STR in comment 0.

Actual results: Cancel button from sharing ringtone action menu is shown as an oval button correctly.
Reproduce rate: 0/10


Device: Flame KK 2.5_512mb (Pass)
Build ID               20151126113148
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104320
Firmware Date          Thu Nov 26 10:43:29 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151126113601
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104443
Firmware Date          Thu Nov 26 10:44:51 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.