[Contacts]Cursor locates at middle of the first and second row, and there's no gray word "Comment" at the first row after relocating cursor to top left via tapping the clear button on keyboard continuely.

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
3 years ago
9 months ago

People

(Reporter: hedan, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.2 unaffected, b2g-v2.5 unaffected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8684112 [details]
Aries kk v2.6.3gp

[1.Description]:
[Aries KK v2.6]&[Flame KK v2.6]The cursor locates at middle of the first and the second row after tapping Comment box, and there is no gray word: "Comment" at the first row after relocating the cursor to top left by tapping the clear button on keyboard continuely.

Occur Time: 13:54
Attachment: Aries kk v2.6.3gp & logcat1354.txt

[2.Testing Steps]: 
1.Launch Contacts app.
2.Tap the "+" icon to create a new contact,swipe down to the Comment box.
3.Tap the first row of Comment box,and make the cursor to top left by tapping the clear button on keyboard continuely; tap the second row of Comment box,and make the cursor to top left by tapping the clear button on keyboard continuely, there is gray word:"Comment".

[3.Expected Result]: 
2.There should be a gray word:"Comment".
3. The cursor should locate at left-most of the first row after tapping Comment box, and there should be a word: "Comment" at the first row after relocating the cursor to top left by tapping the clear button on keyboard continuely.

[4.Actual Result]: 
2.There is no gray word: "Comment".
3.The cursor locates at middle of the first and the second row after tapping Comment box, and there is no gray word: "Comment" at the first row after relocating the cursor to top left by tapping the clear button on keyboard continuely.

[5.Reproduction build]: 
Device: Aries kk v2.6 master  ( Affected )     
Build ID               20151105235624
Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919
Gaia Date              2015-11-05 18:52:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151105.231433
Firmware Date          Thu Nov  5 23:14:41 UTC 2015
Bootloader           s1                                                                         

Device: Flame kk v2.6 master 512mb ( Affected )
Build ID               20151105150203
Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919
Gaia Date              2015-11-05 18:52:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.182857
Firmware Date          Thu Nov  5 18:29:10 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame kk v2.5  512mb ( Unaffected )
Build ID               20151105004500
Gaia Revision          47da49f8206788d70d834c3a63d9245d50c89103
Gaia Date              2015-11-03 21:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/5c9fd135d4309239794126f1942d6e7aa8b3579c
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.043012
Firmware Date          Thu Nov  5 04:30:24 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame kk v2.2  512mb (Unaffected )
Build ID               20151105032504
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9d91dfad5e16
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.064912
Firmware Date          Thu Nov  5 06:49:23 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8684115 [details]
logcat1354.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
We need to fix the lack of the string identifying the field.

Related to where the cursor stars, that's something new to me, just checked and the cursor places wherever you type, a bit odd tbh.
The comment is pre-filled with spaces. Deleting all spaces causes the field identifier to appear again.
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK v2.6 master
Build ID               20151104094738
Gaia Revision          70f54574900565d23ee61f5e00ba23d33d62acf9
Gaia Date              2015-11-04 16:17:46
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/5ec3f4cee5c9059d78de06f398bb0eb96aadc242
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151015.183044
Firmware Date          Thu Oct 15 18:30:54 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK v2.6 master
Build ID               20151104102837
Gaia Revision          607b9c5db7fdbbafc16a572e7c319baa266a3372
Gaia Date              2015-11-04 17:47:11
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/c787c2eb8c32085905a9ea28ce353de7f4a1ab99
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151015.183044
Firmware Date          Thu Oct 15 18:30:54 EDT 2015
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          607b9c5db7fdbbafc16a572e7c319baa266a3372
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/5ec3f4cee5c9059d78de06f398bb0eb96aadc242

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gaia Revision          70f54574900565d23ee61f5e00ba23d33d62acf9
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/c787c2eb8c32085905a9ea28ce353de7f4a1ab99

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/70f54574900565d23ee61f5e00ba23d33d62acf9...607b9c5db7fdbbafc16a572e7c319baa266a3372
QA Whiteboard: [MGSEI-Triage+]
This is a regression, nom as 2.6?
blocking-b2g: --- → 2.6?
Hei Boris, is this the same case than bug 1207083
blocking-b2g: 2.6? → 2.6+
Flags: needinfo?(boris.chiou)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #6)
> Hei Boris, is this the same case than bug 1207083

I have to to test this tomorrow to make sure this. (Keep ni for myself.) Thanks for your ni.
Marking as 2.6+ P1 since the string identifying the field does not appear.
Priority: -- → P1
(In reply to Boris Chiou [:boris] from comment #7)
> (In reply to Francisco Jordano [:arcturus] [:francisco] from comment #6)
> > Hei Boris, is this the same case than bug 1207083
> 
> I have to to test this tomorrow to make sure this. (Keep ni for myself.)
> Thanks for your ni.

Sorry for my lately replying.

I tried to reproduce this bug at the tip of the master branch today.

Result:
1. Before disabling rich text support on clipboard API
   a. The cursor locates at middle of the first and the second row before tapping the clear button.
   b. I can see the grey word: "Comment" after clearing all the white spaces. (I don't know why there are some
      unknown white spaces in the comment box.)
2. After disabling rich text support on clipboard API (by applying the patch in Bug 1212188)
   a. The result is the same.

I am not sure whether Bug 1207083 can also fix this bug (which depends on its implementation), but we can try and verify it later. All I know is Bug 1212188 cannot fix this bug.
Flags: needinfo?(boris.chiou)
Duplicate of this bug: 1241822

Comment 11

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.