Closed Bug 1223037 Opened 4 years ago Closed 4 years ago

Move the network monitor toolbar to the top

Categories

(DevTools :: Netmonitor, defect)

defect
Not set

Tracking

(firefox47 fixed)

RESOLVED FIXED
Firefox 47
Tracking Status
firefox47 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

Details

(Whiteboard: [devtools-ux])

Attachments

(2 files, 2 obsolete files)

Pros:
- More visible toolbar
- More consistent placing with other panels
- More consistent placing with Google Chrome DevTools
- We can place the pane toggle button and the clear button on the same toolbar

Cons:
- Cluttered toolbar (maybe not?)
See Also: → 1220208
Whiteboard: [devtools-ux]
Helen, can you take a look at this?  Just quick thoughts, still need to prioritize this with other work.
Flags: needinfo?(hholmes)
It might be worth tackling bug 1226566 while working on this one (both are related).
(In reply to Bryan Clark (Firefox PM) [:clarkbw] from comment #1)
> Helen, can you take a look at this?  Just quick thoughts, still need to
> prioritize this with other work.

There's a bunch of discussion with Bug 1220208 sort of about this same issue—I'm all for making the changes Tim's requesting, and in Bug 1120208 I've attached an SVG we can be using.
Flags: needinfo?(hholmes)
Since Bug 1220208 isn't for the exact same issue though let me reclarify—I think Tim's changes make sense and that way it will match the filtering placement in console. I think we should make the changes.
Attached image WIP screenshot
Thoughts ?
Attachment #8724554 - Flags: feedback?(hholmes)
Attached patch WIP patch (obsolete) — Splinter Review
Attached patch Patch v1 (obsolete) — Splinter Review
Assignee: nobody → ntim.bugs
Attachment #8724555 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8724566 - Flags: review?(vporof)
Attachment #8724554 - Flags: feedback?(hholmes)
Attachment #8724566 - Flags: ui-review?(hholmes)
Attached patch Patch v1.1Splinter Review
Attachment #8724566 - Attachment is obsolete: true
Attachment #8724566 - Flags: ui-review?(hholmes)
Attachment #8724566 - Flags: review?(vporof)
Attachment #8724571 - Flags: ui-review?(hholmes)
Attachment #8724571 - Flags: review?(vporof)
Summary: Investigate moving netmonitor filter toolbar to the top → Move the network monitor toolbar to the top
Comment on attachment 8724571 [details] [diff] [review]
Patch v1.1

The two bars (filtering bar, network requests table header bar) look a little strange next to each other because they both have that bright white background.

Let's change the request table header bar to background-color: #f8f8f8. That's not currently in our variables file, so we might consider something like var(--theme-secondary-toolbar-background).
Attachment #8724571 - Flags: ui-review?(hholmes) → feedback+
Attachment #8724571 - Flags: review?(vporof) → review?(odvarko)
Comment on attachment 8724571 [details] [diff] [review]
Patch v1.1

Review of attachment 8724571 [details] [diff] [review]:
-----------------------------------------------------------------

this is super sexy
Attachment #8724571 - Flags: review?(odvarko) → review+
https://hg.mozilla.org/mozilla-central/rev/c2977d29a60b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Reproduced this according to (2016-11-09)

It's verified on Latest Nightly 
Nightly--Build ID(20160304030206),Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0 

Tested OS--windows7 32bit
QA Whiteboard: [testday-2016-03-04]
Depends on: 1288294
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.