[gatt] gaia-taskenv, tester images need to be updated to node v4

RESOLVED FIXED in mozilla46

Status

defect
RESOLVED FIXED
4 years ago
6 months ago

People

(Reporter: aus, Assigned: aus)

Tracking

unspecified
mozilla46
Dependency tree / graph

Details

Attachments

(2 attachments, 1 obsolete attachment)

Autolander is messed up and can't create new try runs using the original bug. :(

+++ This bug was initially created as a clone of Bug #1208230 +++

We want to start using node v4 everywhere and the first step is to get the images updated and uploaded to be ready to be turned on.

It's straightforward, and I have the necessary credentials to update the images.
No longer depends on: 1208230
Duplicate of this bug: 1208230
Attachment #8685793 - Attachment is obsolete: true
Attachment #8685794 - Flags: review?(gaye)
Attachment #8685794 - Flags: review?(garndt)
Comment on attachment 8685794 [details] [review]
[gaia] nullaus:bug1223661 > mozilla-b2g:master

Left a couple of comments and a question in the PR, but nothing blocking this from landing.  I skimmed over the parts related to marionette and some sock-it stuff as I'm not familiar with that.
Attachment #8685794 - Flags: review?(garndt) → review+
Comment on attachment 8686190 [details] [diff] [review]
Patch - v1 - Update base-test, tester to use node 4.2.2.

Review of attachment 8686190 [details] [diff] [review]:
-----------------------------------------------------------------

So far I don't see anything obvious that would break, but could we push this path to try and run all tests that require this tester image (pretty much almost everything except fx desktop tests I think).  I want to make sure none of those break because of the node change.

Also, out of curiosity, what is clang and node-gyp being used for that they have to be installed in the image?
(In reply to Greg Arndt [:garndt] from comment #6)
> Comment on attachment 8686190 [details] [diff] [review]
> Patch - v1 - Update base-test, tester to use node 4.2.2.
> 
> Review of attachment 8686190 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> So far I don't see anything obvious that would break, but could we push this
> path to try and run all tests that require this tester image (pretty much
> almost everything except fx desktop tests I think).  I want to make sure
> none of those break because of the node change.

Indeed. I was planning on doing a full try run today. I'll need to customize which gaia is used during the build but, that's all that I should need to have to do.

> 
> Also, out of curiosity, what is clang and node-gyp being used for that they
> have to be installed in the image?

sockit-to-me now requires clang to be compiled because node 4+ v8 includes are meant to be used with clang.
Sorry :aus but there seem to be some oranges there.  Is that related to any of these changes?  Looking at m-c, they look green.  I'm not sure what goes on the tests to understand if the node version matters, but I worry about checking in something that might turn orange.  If there is anything I can help debug let me know.

Also, I believe this image is also used for emulators so I'm not sure if it matters if we run some tests against that as well or if it's good enough using b2g-desktop. 

Just let me know what I can do to help out.
is chunk 29 from here intermitten and not caused by your changes? https://treeherder.mozilla.org/#/jobs?repo=try&revision=d2ba56aa3467
(In reply to Greg Arndt [:garndt] from comment #10)
> is chunk 29 from here intermitten and not caused by your changes?
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=d2ba56aa3467

Indeed, 29 is a known intermittent.
Comment on attachment 8686190 [details] [diff] [review]
Patch - v1 - Update base-test, tester to use node 4.2.2.

Review of attachment 8686190 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for all the testing done on this.  Looks good to me!
Attachment #8686190 - Flags: review?(garndt) → review+
Alright everyone, I'm going to try and land this in the next few hours. I'm doing one more round on try with everything rebased to master / latest, just to be certain and then I'll go ahead and push.
Blocks: 1226811
Commit (master): https://github.com/mozilla-b2g/gaia/commit/b93f975cc713364b657f125d116f1d98bc47a739

Fixed!
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/integration/b2g-inbound/rev/36228281fd55bdccab7869c8c57b03f4bd2daf5b
Bug 1223661 - Update base-tester, tester to node v4.2.2 (LTS). r=garndt
Attachment #8685794 - Flags: review?(gaye)
Blocks: 1221763
Moving closed bugs across to new Bugzilla product "TaskCluster".
Component: TaskCluster → Integration
Product: Testing → Taskcluster
Target Milestone: --- → mozilla46
Component: Integration → Services
You need to log in before you can comment on or make changes to this bug.