new search UI has poorer user experience than the old one

RESOLVED DUPLICATE of bug 1109851

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1109851
3 years ago
3 years ago

People

(Reporter: gyorokpeter, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151109145326

Steps to reproduce:

Try to use the Search UI in Firefox 43+.


Actual results:

The search UI has been replaced with a new version that is less efficient to use. The current search engine is no longer visible when not focusing on the box (just a magnifying glass and the word "Search", instead of the search engine name and icon). When clicking in the search box the window only pops up when I start to type or press "down". There is no way to change the search engine with a single click as in the old version - it requires either two clicks (right click on the icon and then left click on the menu item) or Ctrl+Up/Down but possibly multiple times.


Expected results:

The old search UI (the one that browser.search.showOneOffButtons=false would show in versions before 43) was perfect. The new UI should have customization options to behave like the old one, in order to reduce time spent on a simple search.

Comment 1

3 years ago
(In reply to gyorokpeter from comment #0)
> The current search engine is no longer visible when not focusing on the
> box (just a magnifying glass and the word "Search", instead of the search
> engine name and icon).

Bug 1102922.

> When clicking in the search box the window only pops up when I start to
> type or press "down". There is no way to change the search engine with
> a single click as in the old version - it requires either two clicks
> (right click on the icon and then left click on the menu item) or
> Ctrl+Up/Down but possibly multiple times.

If you want to perform a query with a non-default engine, simply type
something, then click the respective engine from the list.
Changing the default engine isn't likely to be considered a frequently
used action; I doubt any effort will be put into to eliminating that
one extra click.
Component: Untriaged → Search
OS: Unspecified → All
Hardware: Unspecified → All
Whiteboard: [DUPEME]
(Reporter)

Comment 2

3 years ago
For me changing the search engine is a frequent action. I have Google and 3 different languages of Wikipedia as search engines and I frequently switch between them. Also the ability to switch before searching meant I could *first* select the search engine, start typing and *then* see the suggestions for the selected search engine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1109851
You need to log in before you can comment on or make changes to this bug.