[Contact]'Confirmation message' and 'Action1' is displayed instead of 'No contacts in your contacts list' and 'OK'.

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
3 years ago
8 months ago

People

(Reporter: huayu.li, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.2 unaffected, b2g-v2.5 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8688359 [details]
Arieskk_v2.5 _1.png

[1.Description]:
[Arieskk_v2.5][Flamekk_v2.5][Contact]There is no contact in phone. If we make a call, then switch language and open the call information again, tap the add to existing contact, the prompt message is missing, 'Confirmation message' and 'Action1' is displayed
Found at:4:18
See attachment: logcat1.txt, Arieskk_v2.5_1.png

[2.Testing Steps]: 
Precondition:There is no contact in your contacts app, set language or Serbian Cyrillic or Romanian
1.Launch dialer and make a call.
2.Open call history.
3.Long tap the number and select 'Call information'.
4.Tap 'Add to exist contact'

[3.Expected Result]: 
'No contacts in your contacts list' and 'OK' should be displayed.

[4.Actual Result]: 
'Confirmation message' and 'Action1' is displayed

[5.Reproduction build]: 
Device: AriesKK v2.5 build (Affected):
Build ID               20151116174534
Gaia Revision          9473dbcbebf4e758a3b73200968efc69071b4312
Gaia Date              2015-11-16 15:49:25
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/17877d161e5f62726027ee70101a7004dcad5a69
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151116.165317
Firmware Date          Mon Nov 16 16:53:25 UTC 2015
Bootloader             s1

Device: FlameKK 512mb v2.5  build (Affected)
Build ID               20151116173604
Gaia Revision          9473dbcbebf4e758a3b73200968efc69071b4312
Gaia Date              2015-11-16 15:49:25
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/17877d161e5f62726027ee70101a7004dcad5a69
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151116.164743
Firmware Date          Mon Nov 16 16:47:52 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: FlameKK 512mb v2.2(Unaffected)
Build ID               20151116032504
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e772f343b736
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151116.073855
Firmware Date          Mon Nov 16 07:39:06 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,7/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8688362 [details]
logcat1.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → affected
[Blocking Requested - why for this release]: Visual regression that will confuse an end-user.

I'd recommend adding a Gij test to catch pre-emptively this issue.
blocking-b2g: --- → 2.5?
Keywords: regression
blocking-b2g: 2.5? → 2.5+
Duplicate of this bug: 1226066
This Regression Window was originally created for the duplicate Bug 1226066

This Bug was likely caused by changes from Bug 1066347

B2G Regression Window
Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150410033337
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: b99b34dc9bd4
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 40.0a1 (2.5) 
Firmware Version: v18D


First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150410044437
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: 5a1b56e833f0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 40.0a1 (2.5) 
Firmware Version: v18D

Last Working gaia / First Broken gecko - Issue does not occur
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: 5a1b56e833f0

First Broken gaia / Last Working gecko - Issue does occur
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: b99b34dc9bd4

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/749b6eb12c103f4119f1f85c72dbe7791684d8dc...6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Blocks: 1066347
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: mmurrell
Zibi this issue seems to have been caused by the changes for bug 1066347.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(gandalf)
It looks like a dupe of bug 1137546?
Flags: needinfo?(gandalf)
There would not be work on this bug as part of 2.5 so changing the nom to 2.6.
blocking-b2g: 2.5+ → 2.6?
blocking-b2g: 2.6? → 2.6+
Priority: -- → P1

Comment 8

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.