Dashed and dotted borders are not well rendered when there is a border radius

RESOLVED DUPLICATE of bug 382721

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 382721
2 years ago
2 years ago

People

(Reporter: julienw, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8688957 [details]
test-dashed.html

Hi,

while at the Open Source Summit someone brought me this issue on her website (she doesn't want that I share the actual website). She has an animation that's generated automatically by a tool from Adobe. This animation uses a circle that's implemented using a border-radius of 50% with dashed borders. But the "dashed" border style is not working at all with rounded borders so it doesn't show up at all.

Here is a simple testcase that also shows the issue with "dotted" borders.

I know bug 382721 is moving forward and I also know bug 780366 and bug 995677, though I don't know which one of these bugs could fix this (if any ?).
Seems like bug 382721 is the obvious problem here....  How is this not a duplicate?
Depends on: 382721
(Reporter)

Comment 2

2 years ago
yes I think you're right.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382721
You need to log in before you can comment on or make changes to this bug.