Closed Bug 1228865 Opened 4 years ago Closed 4 years ago

AM/PM is not removed on lockscreen for some locales

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: VP7, Unassigned)

References

Details

(Keywords: foxfood, Whiteboard: [bzlite])

Attachments

(1 file)

User-Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

In home screen the clock is displayed. But it is not showing AM or PM.

in local language (in Tamil) it showed PM. But in English it is not showing.
Attached image 2015-11-29-20-55-31.png
Zibi, if I’m reading the code correctly, we’re removing AM/PM on lockscreen for all locales, right?

https://github.com/mozilla-b2g/gaia/blob/master/apps/system/lockscreen/js/widgets/clock/lockscreen_clock_widget.js#L34

Any idea why it’s still displayed in Tamil? See screenshot here https://bugzilla.mozilla.org/attachment.cgi?id=8693348

At first glance, when AM/PM translations are different than "AM" or "PM", they are not removed.
Status: UNCONFIRMED → NEW
Component: Gaia::Feedback → Gaia::System::Lockscreen
Ever confirmed: true
Flags: needinfo?(gandalf)
Summary: Whether it is AM or PM IS MISSING → AM/PM is not removed on lockscreen for some locales
Duplicate of this bug: 1228863
This depends on bug 1216150
Depends on: 1216150
Flags: needinfo?(gandalf)
Duplicate of this bug: 1236669
This is fixed now, we're not showing dayperiod on lockscreen in all locales.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.