[Aries] crash in mozilla::GonkVideoDecoderManager::CreateVideoDataFromGraphicBuffer

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: KTucker, Assigned: sotaro)

Tracking

(4 keywords)

unspecified
ARM
Gonk (Firefox OS)
crash, regression, reproducible, smoketest

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-bcf6ae0a-2bf6-465d-a26a-298182151203.
=============================================================

Crashing Thread
Frame 	Module 	Signature 	Source
0 	libxul.so 	mozilla::GonkVideoDecoderManager::CreateVideoDataFromGraphicBuffer(android::MediaBuffer*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits>&) 	dom/media/platforms/gonk/GonkVideoDecoderManager.cpp
1 	libxul.so 	mozilla::GonkVideoDecoderManager::CreateVideoData(android::MediaBuffer*, long long, mozilla::VideoData**) 	dom/media/platforms/gonk/GonkVideoDecoderManager.cpp
2 	libxul.so 	mozilla::GonkVideoDecoderManager::Output(long long, RefPtr<mozilla::MediaData>&) 	dom/media/platforms/gonk/GonkVideoDecoderManager.cpp
3 	libxul.so 	mozilla::GonkDecoderManager::ProcessToDo(bool) 	dom/media/platforms/gonk/GonkMediaDataDecoder.cpp
4 	libxul.so 	mozilla::GonkDecoderManager::onMessageReceived(android::sp<android::AMessage> const&) 	dom/media/platforms/gonk/GonkMediaDataDecoder.cpp
5 	libstagefright_foundation.so 	android::ALooperRoster::deliverMessage(android::sp<android::AMessage> const&) 	/home/worker/workspace/B2G/frameworks/av/media/libstagefright/foundation/ALooperRoster.cpp:148
6 	libstagefright_foundation.so 	android::ALooper::loop() 	/home/worker/workspace/B2G/frameworks/av/media/libstagefright/foundation/ALooper.cpp:213
7 	libutils.so 	android::Thread::_threadLoop(void*) 	/home/worker/workspace/B2G/system/core/libutils/Threads.cpp:770
8 	libutils.so 	thread_data_t::trampoline(thread_data_t const*) 	/home/worker/workspace/B2G/system/core/libutils/Threads.cpp:95
9 	libc.so 	__thread_entry 	/home/worker/workspace/B2G/bionic/libc/bionic/pthread_create.cpp:105
10 	libc.so 	pthread_create 	/home/worker/workspace/B2G/bionic/libc/bionic/pthread_create.cpp:224

Summary (title) Field:
[Component][Location](Concise statement of the issue)

Description:
(Expand upon the Summary - but not a copy of the Summary!)


Repro Steps:
1) Update a Aries to 20151203121905
2) Open the video app.
3) Tap on the "Camcorder" icon to record a video.
4) Record a 15 second video.
5) After recording the video, tap the home button and reopen the video app.
6) Tap on the video that was recorded in step 3 and play it.
7) While it is playing, keep moving the slider back and forth.

Actual:
The video app will crash when moving the slider back and forth while recording a video.

Expected:
The video app does not crash when moving the slider back and forth while watching a video.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151203121905
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 5/5, 100%
See attached: video clip, logcat
status-b2g-master: --- → affected
Keywords: reproducible
OS: Android → Gonk (Firefox OS)
Hardware: Unspecified → ARM
Whiteboard: [2.6-Daily-Testing][Spark]
Created attachment 8695442 [details]
Video_Crash.txt
This issue does NOT occur on Aries 2.5 or Flame 2.6.

Let's get a window here.

Environmental Variables:
Device: Aries 2.5
BuildID: 20151203092237
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: 241f079cd53c932561c6aa32b9b93c44cd0846d0
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.6
BuildID: 20151203053521
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
blocking-b2g: --- → 2.6?
Keywords: regression, regressionwindow-wanted, smoketest
status-b2g-v2.5: --- → unaffected
Keywords: qaurgent
QA Contact: jmercado
Summary: crash in mozilla::GonkVideoDecoderManager::CreateVideoDataFromGraphicBuffer → [Aries] crash in mozilla::GonkVideoDecoderManager::CreateVideoDataFromGraphicBuffer
This has taken me longer to finish than I expected.  I will continue narrowing this down tomorrow, but here is my central pushlog for this bug.  No-Jun if anything stands out to you let me know.

Central Regression Window:

Last Working 
Environmental Variables:
Device: Aries 2.6
BuildID: 20151125125537
Gaia: 9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gecko: ef95cb431736da42d3b21ae288140225100d9f97
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken 
Environmental Variables:
Device: Aries 2.6
BuildID: 20151125125652
Gaia: 9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gecko: 1835baed2a38429a3cc301d21778a113d3a9e7d8
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working gaia / First Broken gecko -  Issue DOES occur
Gaia: 9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gecko: 1835baed2a38429a3cc301d21778a113d3a9e7d8

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gecko: ef95cb431736da42d3b21ae288140225100d9f97

Gecko Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ef95cb431736da42d3b21ae2881402251
Flags: needinfo?(npark)
milan, do you know someone who can take a look at this?
Flags: needinfo?(npark) → needinfo?(milan)
QA Contact: jmercado → pcheng
Jean-Yves, anything that catches your eye here?
Flags: needinfo?(milan) → needinfo?(jyavenard)
mozilla-inbound regression window:

Last Working
Device: Aries 2.6
BuildID: 20151125074118
Gaia: 37250b125e0db6966875d3b37b117f6d9b76cbc0
Gecko: 83b622d14755ae051788858efbea067ac48d7e33
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Device: Aries 2.6
BuildID: 20151125073535
Gaia: 37250b125e0db6966875d3b37b117f6d9b76cbc0
Gecko: e1372ddbf94d3e3891b4ec99533ecc076077f2e9
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=83b622d14755ae051788858efbea067ac48d7e33&tochange=e1372ddbf94d3e3891b4ec99533ecc076077f2e9

This issue is caused by changes made in Bug 1227415.
Blocks: 1227415
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qaurgent, regressionwindow-wanted
Sotaro this Smoketest blocker seems to have been caused by the changes for bug 1227415.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(sotaro.ikeda.g)
Assignee: nobody → sotaro.ikeda.g
Flags: needinfo?(jyavenard)
(Assignee)

Comment 8

3 years ago
Hmm, I tries the STR in comment 0 on my aries. But I could not reproduce the problem. And the crash might be addressed by bug 1219210. The fix of bug 1219210 is already in m-i and waiting to merged to m-c.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 9

3 years ago
I succeeded to reproduce the crash.
(Assignee)

Comment 10

3 years ago
When I applied the fix of bug 1219210, I did not see the crash on aries.
I cannot reproduce on today's build which has the fix of bug 1219210 in.  Let's have someone else verify as well.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: verifyme
Resolution: --- → FIXED
This issue is verified fixed. I am also unable to reproduce this issue on the latest Aries 2.6 Dogfood build after more than 20 attempts.
Video app does not crash when scrubbing rapidly back and forth in a video.

Environmental Variables:
Device: Aries 2.6
BuildID: 20151207143802
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 59bc3c7a83de7ffb611203912a7da6ad84535a5a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: affected → verified
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)

Updated

3 years ago
blocking-b2g: 2.6? → 2.6+
You need to log in before you can comment on or make changes to this bug.