The PDF viewer only shows blank pages

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: sxean, Unassigned)

Tracking

({foxfood, regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.5 unaffected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
When click on link to open a .pdf the Mozilla browser downloads 
the file, however upon completion there is no prompt to open with 
an available .pdf reader, or a prompt that informs user that a "reader" 
is required to open the .pdf file. 

Repro Steps:
1) Update a Aries to 20151207143802
2) Go to a link for a .pdf file such as: http://www.tinaja.com/glib/pdflink.pdf
3) Proceed to click on link to open .pdf. 

Actual:
When click on link the file proceeds to open in browser but never open. There is no further
dialogue, just a blank webpage. 

Expected:
When file is completed opening or downloaded, a message prompt informing the user that
a reader is required to open file or a message prompt giving the user a choice of which 
reader to open the .pdf file with. OR, the .pdf opens within the browser unerringly. 

Notes: Bad User experience. Even with downloaded .pdf readers there is no current way 
to associate the .pdf readers with a .pdf document in order to open it from a link 
or upon download. 

Environmental Variables:
Device: Aries 2.6
Build ID: 20151207143802
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 59bc3c7a83de7ffb611203912a7da6ad84535a5a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: (5/5)

See attached: (video clip, logcat)

NO REPRO per this build: 

Environmental Variables:
Device: Aries 2.5
BuildID: 20151203092237
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: 241f079cd53c932561c6aa32b9b93c44cd0846d0
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

REPRO per this build: 

Environmental Variables:
Device: Flame 2.5
BuildID: 20151207121611
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: c491dedc389de5c4686543b990c92d4f47715ee8
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

NOTE: on the flame 2.5 build instead of a blank page a confirmation message is presented stating, " 
Browse to URL? " name of URL", with buttons (cancel) and (OK). When press (OK) the .pdf file proceeds
to download then opens into a blank webpage, then crashes with the Message: " Unable to Open",  
with buttons ( Keep File ) or ( Delete ) or reboots device after crash.
(Reporter)

Comment 1

3 years ago
Posted file Pdf not opening.txt
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Summary: No Message prompt to inform user to open with installed readers when downloading a .pdf document when either a .pdf reader is available or not. → No Message prompt to inform user to open with installed readers when downloading a .pdf document when either a .pdf reader is available or not
Whiteboard: [2.6-Daily-Testing]
This issue does NOT occur on Flame 2.6.

Actual Results: The PDF Viewer loads and shows the pdf as expected.

Environmental Variables:
Device: Flame 2.6
BuildID: 20151207030216
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 528ea05671e9bd9ccb33d1558a20691a72c85f98
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Summary: No Message prompt to inform user to open with installed readers when downloading a .pdf document when either a .pdf reader is available or not → [Aries] The PDF viewer only shows blank pages on Aries
Nominating to block since this prevents use of any pdf file on Aries.  Let's get a window here.
blocking-b2g: --- → 2.6?
(Reporter)

Comment 4

3 years ago
Flame 2.5 build: BuildID: 20151207121611 from above: ( memory at 319 ) 

Update: NO REPRO per Flame 2.5 build: ( memory at 512 ) 

Environmental Variables:
Device: Flame 2.5
Build ID: 20151207121611
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: c491dedc389de5c4686543b990c92d4f47715ee8
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Contact: jmercado
Jonas this issue seems to have been caused by the changes to either Bug 1216687 or Bug 1226909.  Can you please take a look?

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Aries 2.6
BuildID: 20151206221706
Gaia: b930e25e9f2e5ec2106dd31005468575cdf87d50
Gecko: 0aa2be7bf89908f74cf1aeaf417e55775857ea34
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken 
Environmental Variables:
Device: Aries 2.6
BuildID: 20151207003111
Gaia: b930e25e9f2e5ec2106dd31005468575cdf87d50
Gecko: 7b9b0ce58fbf2acad28fd85a2a0ff8a3978cb7ea
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: b930e25e9f2e5ec2106dd31005468575cdf87d50
Gecko: 7b9b0ce58fbf2acad28fd85a2a0ff8a3978cb7ea

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: b930e25e9f2e5ec2106dd31005468575cdf87d50
Gecko: 0aa2be7bf89908f74cf1aeaf417e55775857ea34

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0aa2be7bf89908f74cf1aeaf417e55775857ea34&tochange=7b9b0ce58fbf2acad28fd85a2a0ff8a3978cb7ea
Blocks: 1226909, 1216687
Flags: needinfo?(jonas)
Is this reproducible in Mulet? Or is there any other way I can try to debug this without having to set up a full B2G build stack?
Flags: needinfo?(jonas)
I'm not familiar with Mulet but I know No-Jun is so he may be able to assist here.
Flags: needinfo?(npark)
I built the Mulet with the latest gaia/gecko, and the PDF opens properly within the browser on all available resolution.  I think this might be Aries specific issue, since this is not reproducible on Flame either.
Flags: needinfo?(npark)
I was able to reproduce this with the latest Flame Nightly 2.6 build, as well as the latest Aries Dogfood build.

I downloaded a 1040 form from wwww.irs.gov, and the pdf viewer displays the file as a blank page.

Environmental Variables:
Device: Aries 2.6
BuildID: 20160114140113
Gaia: 2d6c11a1e82bd9f9b7491863c8d1ea4a14aea69f
Gecko: 27eb5e90eeee2e6a1ffe61c368c294d3de51b797
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: Flame 2.6
BuildID: 20160114030239
Gaia: 2d6c11a1e82bd9f9b7491863c8d1ea4a14aea69f
Gecko: 6fa2ab99f52feb1b6ead5581b8f5d398546a55a5
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0
Summary: [Aries] The PDF viewer only shows blank pages on Aries → The PDF viewer only shows blank pages on Aries
Duplicate of this bug: 1239942

Updated

3 years ago
Summary: The PDF viewer only shows blank pages on Aries → The PDF viewer only shows blank pages

Updated

3 years ago
Keywords: foxfood
Based on the original report : 
12-07 16:22:20.131  2603  2603 W PDF Viewer: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "jar:file:///system/b2g/omni.ja!/components/DirectoryProvider.js" line: 88}]
12-07 16:22:20.421  2603  2641 I PDF Viewer: PAC file installed from data: URI
12-07 16:22:20.661  2603  2603 W PDF Viewer: [JavaScript Warning: "unreachable code after return statement" {file: "app://pdfjs.gaiamobile.org/content/web/viewer.js" line: 4765 column: 8 source: "        self.error(loadingErrorMessage, moreInfo);
12-07 16:22:20.661  2603  2603 W PDF Viewer: "}]
12-07 16:22:20.861   320   320 I GeckoDump: DeveloperHUD: [app://pdfjs.gaiamobile.org/manifest.webapp] Warning (content javascript): "unreachable code after return statement" in app://pdfjs.gaiamobile.org/content/web/viewer.js:4765:8
12-07 16:22:20.991  2603  2603 W PDF Viewer: [JavaScript Warning: "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/" {file: "app://pdfjs.gaiamobile.org/content/web/l10n.js" line: 108}]
12-07 16:22:21.021   320   320 I GeckoDump: DeveloperHUD: [app://pdfjs.gaiamobile.org/manifest.webapp] Warning (DOM Core): "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/" in app://pdfjs.gaiamobile.org/content/web/l10n.js:108:4
12-07 16:22:21.311  2603  2603 E PDF Viewer: [JavaScript Error: ": InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable" {file: "app://pdfjs.gaiamobile.org/content/build/pdf.worker.js" line: 1619}]
12-07 16:22:21.321   320   320 I GeckoDump: DeveloperHUD: [app://pdfjs.gaiamobile.org/manifest.webapp] Error (Web Worker): ": InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable" in app://pdfjs.gaiamobile.org/content/build/pdf.worker.js:1619:0
Not sure if you guys are going to work on this further... at the same time, PDF looks broken based on the report.
Flags: needinfo?(ydelendik)
Flags: needinfo?(bdahl)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #12)
> Not sure if you guys are going to work on this further... at the same time,
> PDF looks broken based on the report.

I don't really understand what was asked above. The regression is not caused by the PDF.js update, right? 

We can look into bad rendering of the PDFs when the integration between Gaia and PDF.js will be restored. BTW, the updating of the PDF.js for Gaia is blocked by bug 1171998, so current version is outdated and might not work for some PDFs.
Flags: needinfo?(ydelendik) → needinfo?(nhirata.bugzilla)

Comment 14

3 years ago
This used to work until the 6-th of December 2015. The next day it got broken. Ever since we cannot see any PDF files on Firefox OS.
Oh!  Not 100 % sure if there might be any breaks or not in today's build due to gecko.  If it is gaia, then yes.  It could be fixed.  So all we have to do is get a new version checked into the main repo?

With the way that spark is setup, it should be possible for at least the aries device.  It just needs to be in the spark distro.  At the same time, not sure what's going to happen with b2g.
Flags: needinfo?(nhirata.bugzilla)
There's a regression range here. So this is almost surely due to bug 1226909.
Flags: needinfo?(bdahl)
FYI, with bug 1247266 Pdf.JS works again on my Z3c KK build.

Comment 18

a year ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.