Closed Bug 1231504 Opened 4 years ago Closed 4 years ago

Copy over APZ physics prefs from b2g to fennec and generally clean up APZ prefs

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 45
Tracking Status
firefox45 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(7 files)

We should copy over the b2g physics prefs to fennec to start with, and then tune it further.
So I did this, and I also did a bunch of cleanup of the APZ prefs while I was at it. To verify my cleanup didn't change any unnexpected prefs I wrote a script [1] to preprocess the pref files and spit out the final pref values for the various platforms. That allowed me to compare the prefs before and after my change to ensure that only things that I intended to change did change.

I'm attaching the commands and output from the check. It turns out I did modify some overscroll and touch tolerance prefs for desktop as well but I decided to keep those changes since overscroll is not used on desktop and the touch tolerance should probably be the same on desktop as it is on mobile (for whenever we enable touch support).

[1] https://github.com/staktrace/moz-scripts/blob/master/allprefs.sh
Summary: Copy over APZ physics prefs from b2g to fennec → Copy over APZ physics prefs from b2g to fennec and generally clean up APZ prefs
Attachment #8697169 - Flags: review?(botond)
Attachment #8697170 - Flags: review?(botond)
Attachment #8697171 - Flags: review?(botond)
Attachment #8697172 - Flags: review?(botond)
Attachment #8697173 - Flags: review?(botond)
Attachment #8697174 - Flags: review?(botond)
Attachment #8697169 - Flags: review?(botond) → review+
Comment on attachment 8697170 [details] [diff] [review]
Part 2 - Make fennec use the same pan_repaint_interval as b2g

Review of attachment 8697170 [details] [diff] [review]:
-----------------------------------------------------------------

Is this changing b2g's pan_repaint_interval from 16 to 250?
Attachment #8697171 - Flags: review?(botond) → review+
Comment on attachment 8697172 [details] [diff] [review]
Part 4 - Move more b2g prefs to all.js

Review of attachment 8697172 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/libpref/init/all.js
@@ +581,5 @@
>  pref("apz.minimap.enabled", false);
>  pref("apz.num_paint_duration_samples", 3);
>  pref("apz.overscroll.enabled", false);
>  pref("apz.overscroll.min_pan_distance_ratio", "1.0");
> +pref("apz.overscroll.stretch_factor", "0.35");

Alphabetize this while you're at it?
Attachment #8697172 - Flags: review?(botond) → review+
Attachment #8697173 - Flags: review?(botond) → review+
Attachment #8697174 - Flags: review?(botond) → review+
(In reply to Botond Ballo [:botond] from comment #8)
> Is this changing b2g's pan_repaint_interval from 16 to 250?

No, the default in all.js is 16 for all platforms. Previously it was overriden in all.js for b2g to 250 and then overridden back to 16 in b2g.js. This just takes out the unnecessary overriding.

(In reply to Botond Ballo [:botond] from comment #9)
> > +pref("apz.overscroll.stretch_factor", "0.35");
> 
> Alphabetize this while you're at it?

Good catch, will do
Attachment #8697170 - Flags: review?(botond) → review+
Duplicate of this bug: 1231229
You need to log in before you can comment on or make changes to this bug.