PostScript/default should always be the last entry in the list of printers

VERIFIED FIXED in mozilla0.9.9

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: graham.knap, Assigned: roland.mainz)

Tracking

Trunk
mozilla0.9.9
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
After a brief conversation on IRC, trying to get my printer working under
Mozilla/linux by setting the shell variable:

MOZILLA_PRINTER_LIST="esc400 lp"

The result was that the print dialog showed three available printers, in this order:

PostScript/default
PostScript/esc400
PostScript/lp

I believe the desired behaviour is that the first entry in my Printer List
should be the first entry in the print dialog, and "default" should get appended
to the end of the list.
(Reporter)

Updated

17 years ago
Summary: "PostScript/default should always be the last PostScript/default should always be the last entry in the list of printers → PostScript/default should always be the last entry in the list of printers PostScript/default should always be the last entry in the list of printers
(Assignee)

Comment 1

17 years ago
In theory the "PostScript/default" printer entry should always be the last
entry.

First the printers from Xprint should be listed, then any PostScript module
printers from the MOZILLA_PRINTER_LIST env var - and finally the
"PostScript/default" entry...

I can fix this after bug 120916 ("PostScript/Xprint module revamp") has been
checked in...
... rods ?
Status: UNCONFIRMED → NEW
Depends on: 120916
Ever confirmed: true
Summary: PostScript/default should always be the last entry in the list of printers PostScript/default should always be the last entry in the list of printers → PostScript/default should always be the last entry in the list of printers

Comment 2

17 years ago
We have a bug for setting the default printer (i.e. the printer that will be
selected in the list when the dialog displays), and I am not sure what Linux
will be setting as the default printer. Roland?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
(Assignee)

Comment 3

17 years ago
One idea for the new Linux XUL print dialog was to populate the list of printers
based on the MOZILLA_PRINTER_LIST env var - and that the first entry in the var
should be the default printer (unless there are Xprint printers which are always
in front of the printers from the PostScript module) ...

... somehow this "feature" was shot dead, no clue why. But I have already a fix
for the issue and integrated it into the patch for bug 80625 ...
Assignee: rods → Roland.Mainz
Status: ASSIGNED → NEW
Depends on: 80625
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0.1 → mozilla0.9.9
(Assignee)

Comment 4

17 years ago
Patch for bug 80625 checked in...

Changes:
1. I renamed the env var from "MOZILLA_PRINTER_LIST" to
"MOZILLA_POSTSCRIPT_PRINTER_LIST" to avoid confusion with other printing
modules.
2. The "PostScript/default" entry is now added as last entry to the list of
PostScript module printers (previously it was the first one) - unless someone
adds explicitly a "default" entry to the "MOZILLA_POSTSCRIPT_PRINTER_LIST" env
var. The entry can explicitly placed at any position in the env var. If there is
no "default" entry mozilla will place it at the end of the list. The first
entry  in the env var is always the default printer - unless there are any
printers from the Xprint module (which are always in front of the PostScript
printers - who wants to use the PostScript module when he/she can use the Xprint
module... :-) ).

... marking bug as FIXED.
(Assignee)

Comment 5

17 years ago
Trying again to mark this bug as FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Roland please verify...thanks!

Comment 7

17 years ago
 can someone please verify this bug
(Assignee)

Updated

17 years ago
QA Contact: sujay → Roland.Mainz
(Reporter)

Comment 8

17 years ago
This now works for me.

Well, at least the printer list is in the right order.

But when "PostScript/esc400" is selected, the job lands in the "lp" queue, not
in the "esc400" queue. ... Maybe I should file another bug for that...

Also - could someone please make sure this environment variable stuff gets into
the release notes? Thanks...
(Assignee)

Comment 9

17 years ago
gknap wrote:
> This now works for me.

Care to mark this bug as VERIFIED ? :)

> Well, at least the printer list is in the right order.
>
> But when "PostScript/esc400" is selected, the job lands in the "lp" queue, not
> in the "esc400" queue. ... Maybe I should file another bug for that...

Just guessing: Did you change the print command ?

Default for all printers should be "lpr
${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}", where the $MOZ_PRINTER_NAME env
var is set _internally_ by the PostScript module to match the current printer in
use...
Optionally you may set the print command per printer in the prefs to something
like "lpr -P esc400" (for the esc400 queue).

Or use the Xprint module for printing.
You need the Xprt server for that (you can get a working Linux x86 binary from
http://puck.informatik.med.uni-giessen.de/download/xprint_linux_x86_005.tar.gz
(current release, check
http://puck.informatik.med.uni-giessen.de/download/#Xprint for updates, higher
numbers are better)) - once you have it configured and running it should do all
the stuff automagically (you only have to set the XPSERVERLIST env var on the
mozilla-side to tell it where it can find the Xprt server(s)) ...

> Also - could someone please make sure this environment variable stuff gets 
> into the release notes? Thanks...

Care to file a bug against the documentation folks and CC: me, please ? The
whole PostScript module needs better documentation...
(Reporter)

Comment 10

17 years ago
Hi Roland --

>> VERIFIED ? :)

Sure, why not (I didn't know that I had permission to do such things...)

>> Did you change the print command ?

Nope. I just checked and it matches what you said the default should be.

I could probably switch to Xprint, but for now let's assume that I don't want
to, for reasons unspecified (I'm lazy, and short on disk space)... :-)

If you'd like me to file a separate bug or something, let me know.

>> documentation

Done -- see bug 134854.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 11

17 years ago
gknap wrote:
> >> VERIFIED ? :)
> Sure, why not (I didn't know that I had permission to do such things...)

Thanks!

> >> Did you change the print command ?
> Nope. I just checked and it matches what you said the default should be.

1. Mhhh, does your "lpr" command recognise the "-P"-option ?
2. Please open a new bug, CC: me, describe the problem, reference this bug and
attach the mozilla-bin output which gets created when you this:
% export NSPR_LOG_MODULES=nsPostScriptObj:5
% ./mozilla
# print something with the postscript module
(NSPR_LOG_MODULES=nsPostScriptObj:5 enables some debug code in the module and
logs what the module is doing...)

> I could probably switch to Xprint, but for now let's assume that I don't want
> to, for reasons unspecified (I'm lazy, and short on disk space)... :-)

;-((((((((((((((((((((((((

[snip]
>> documentation
>
> Done -- see bug 134854.

Thanks!
(Reporter)

Comment 12

17 years ago
Discussion of the above problem moved elsewhere as requested.
The new bug is bug 134914.
You need to log in before you can comment on or make changes to this bug.