about:profiles, It is not clear which profile to be subjected to "Start Nightly"

RESOLVED FIXED in Firefox 46

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: baku)

Tracking

46 Branch
mozilla46
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR
0. Provide many profile
1. start firefox.exe -P

Actual Results:
 It is not clear which profile to be subjected to "Start Nightly", "Restart with Add-ons Disabled..." and "Restart normally..."
Expected Results:
Should indicate which profile to be subjected to these button.
(Assignee)

Comment 1

2 years ago
those entries are not shown once bug 1233007 is landed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233007
(Reporter)

Comment 2

2 years ago
Bug 1233007 is landed, however, I cannot distinguish which profile is used for "Start Nightly"  button.

STR
0. Provide many profile
1. start firefox.exe -P

Actual Results:
 It is not clear which profile to be subjected to "Start Nightly"

Expected Results:
Should indicate which profile to be subjected to.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: about:profiles, It is not clear which profile to be subjected to "Start Nightly", "Restart with Add-ons Disabled..." and "Restart normally..." → about:profiles, It is not clear which profile to be subjected to "Start Nightly"
(Reporter)

Comment 3

2 years ago
I think "Start Nightly" should use "Last used profile" or "Newly Created Profile"
It is not obvious which profile will be run.  Best I could tell is that you have to set the profile you want to use as the "Default."  

However, it takes two attempts to switch profiles as follows:

1) Set the profile you want to use as default. (ensure it says "yes" as default in that profile listing, all other profiles should say "no" for the same)
2) Start nightly. (result: Nightly does not start up in the profile just selected as default, instead it started with the profile that was previously set as default)
3) Shutdown Nightly.
4) Start Nightly again to get about:profiles. In about:profiles, note that the profile you want to start Nightly with is still set as default, then start Nightly.  

Finally, the browser is running the profile I intend to use.

It should be more clear how to select a profile for use. The browser should start with the selected profile the first time.
It is also not possible to run two browsers simultaneously through the new profile management system of about:profile.  With one latest Nightly already running, attempt to run a second latest Nightly installation is not possible, as you must switch the default profile, which you can't do because the default profile is already in use (reported by a dialog).
[Tracking Requested - why for this release]:
I think all has been said here already. It's a pain right now to start Firefox with the wanted profile. Especially if multiple instances of Firefox have to run. 

Please get this fixed and make it obvious which is the profile to start Firefox with.
Severity: normal → major
tracking-firefox46: --- → ?
(Assignee)

Comment 7

2 years ago
Created attachment 8699797 [details] [diff] [review]
profile8.patch
Attachment #8699797 - Flags: review?(ehsan)
(Assignee)

Updated

2 years ago
Assignee: nobody → amarchesini

Comment 8

2 years ago
Can you please explain what your patch is trying to do?  Thanks!
(Assignee)

Comment 9

2 years ago
This patch changes:

1. |<h2>name of the profile</h2>| in |<h2><input type="radio" name="profile" value="name of the profile" />name of the profile</h2>|. Of course only in about:profile?manage

2. when a new profile is created, we set it as 'selected' by default (input type="radio" checked)

3. when a profile is selected (input.onchange) we set that as the selected profile.

4. clicking on 'start nightly' we open the selected profile.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1233130
(In reply to Andrea Marchesini (:baku) from comment #9)
> 2. when a new profile is created, we set it as 'selected' by default (input
> type="radio" checked)

Which does not mean being the default profile, right? That would not be that ideal if you have to create new profiles for testing a lot.
(Assignee)

Comment 12

2 years ago
> Which does not mean being the default profile, right? That would not be that
> ideal if you have to create new profiles for testing a lot.

Correct: The selected profile is 'selected' because the user wants to open it, and that means that the input type=radio is checked.  The default browser is the profile opened in case the user doesn't select a different profile manually via profileManager. This means, opening firefox, by default we open the default profile. With the profileManager you can 'select' to open the profile you prefer for that particular firefox instance.

Comment 13

2 years ago
Comment on attachment 8699797 [details] [diff] [review]
profile8.patch

Review of attachment 8699797 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/aboutProfiles.js
@@ +101,5 @@
> +  if (gManage) {
> +    let checkBox = document.createElement('input');
> +    checkBox.setAttribute('type', 'radio');
> +    checkBox.setAttribute('name', 'profile');
> +    checkBox.setAttribute('value', profileData.profile.name);

You don't need to set @value, I think.
Attachment #8699797 - Flags: review?(ehsan) → review+
(Reporter)

Updated

2 years ago
Blocks: 1234496
(Reporter)

Updated

2 years ago
Depends on: 1234497

Comment 15

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3c64b18f74a7
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
status-firefox46: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46

Updated

2 years ago
Depends on: 1234765
tracking-firefox46: ? → +
You need to log in before you can comment on or make changes to this bug.