Closed Bug 1233097 Opened 5 years ago Closed 5 years ago

Links no longer activable by TalkBack in Android 6

Categories

(Core :: Disability Access APIs, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1238368
Tracking Status
firefox46 --- affected

People

(Reporter: MarcoZ, Unassigned)

References

Details

Got a user report on Twitter basically saying that on Android M, links no longer activate in Firefox 43 with TalkBack. Filing here so we don't forget, but haven't had a chance to investigate myself yet. But since this is going around the eyes-free list by now, it is probably valid.
Duplicate of this bug: 1233131
(In reply to Marco Zehe (:MarcoZ) from comment #0)
> Got a user report on Twitter basically saying that on Android M, links no
> longer activate in Firefox 43 with TalkBack. Filing here so we don't forget,
> but haven't had a chance to investigate myself yet. But since this is going
> around the eyes-free list by now, it is probably valid.

on android 4.4.4 with latest talkback problem exists also
on android 4.4.4 with espeak synthesizer there is also problem with reading, sentences are cutted and not read entirelly, it looks like the application is unstable. Problem on sony xperia z1 compact so the phone it is fast enough
Eitan, this seems to be directly related to our modernized Android support. And it seems to primarily affect Android M for some reason. Thoughts?
Flags: needinfo?(eitan)
Sorry this is taking forever for me to get back. Frankly, I have been trying to reproduce this with no luck. If anyone could give me some solid steps to reproduce it will be good. Otherwise I'll keep the needinfo flag here to remind me to keep trying.
Start Talkback
open any web page that has a link 
double tap on the link and nothing happens. 
I tested this using google..com and activating the privacy link. 
This is with firefox 43 and android 6.
Roy, what device are you using? I just tried this with a Nexus 5 running latest update of Android 6, and it worked for me. So there does seem to be a device or other dependency which you are hitting and we are not.
Flags: needinfo?(roy.nickelson)
I am using a nexus 7 the 2013 model with the camera.
Flags: needinfo?(roy.nickelson)
Looks like this may be a duplicate of bug 1238368 that never landed. I had it in my local build, so I couldn't reproduce the error. Big oops. I'll give it a try run now.
Flags: needinfo?(eitan)
Possibly related: bug 1248133.

Eitan, how did the try run play out?
Flags: needinfo?(eitan)
This was fixed in bug 1238368. Thanks for the report!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(eitan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1238368
You need to log in before you can comment on or make changes to this bug.