Closed Bug 1238368 Opened 4 years ago Closed 4 years ago

Can't click on some items on Android with Talkback enabled

Categories

(Firefox for Android :: General, defect)

43 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 47
Tracking Status
firefox44 --- wontfix
firefox45 + verified
firefox46 + fixed
firefox47 --- fixed

People

(Reporter: nolan, Assigned: eeejay, NeedInfo)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151229124331
Firefox for Android

Steps to reproduce:

1. On Android 5.1.1 with Talkback enabled, launch Firefox 43.
2. Visit https://oasis.sandstorm.io/demo.
3. Double-tap the "Try a quick demo" button.


Actual results:

Nothing


Expected results:

The button should be clicked.

I've experienced this issue throughout Sandstorm. It happens in my installed instance so isn't just limited to this, but this is the quickest reproduction.

Firefox 42.0.2 works fine on this and other pages, so this regression seems to have emerged in 43.
Has Regression Range: --- → no
Has STR: --- → yes
Component: Untriaged → General
Keywords: regression
OS: Unspecified → Android
Product: Firefox → Firefox for Android
Hardware: Unspecified → ARM
Eitan, seems like an accessibility regression - do you have cycles to look into this?
No longer blocks: clicksdontwork
Flags: needinfo?(eitan)
This may need to be back-ported to other versions.
Attachment #8706556 - Flags: review?(yzenevich)
Flags: needinfo?(eitan)
Comment on attachment 8706556 [details] [diff] [review]
Re-introduce workaround for Android tap gesture.

Review of attachment 8706556 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good and works on latest android, thanks!
Attachment #8706556 - Flags: review?(yzenevich) → review+
Duplicate of this bug: 1233097
[Tracking Requested - why for this release]: Major regression in interaction between TalkBack and Firefox for Android in Android 6.

Eitan, please request to land this on aurora (46) and Beta (45), since this was already a problem in 43 and 44. Thanks!
Assignee: nobody → eitan
Comment on attachment 8706556 [details] [diff] [review]
Re-introduce workaround for Android tap gesture.

Approval Request Comment
[Feature/regressing bug #]: 1238368
[User impact if declined]: Screen reader users won't be able to activate many links and buttons.
[Describe test coverage new/current, TreeHerder]: No specific treeherder tests were introduced. This was tested on Android Marshmallow devices.
[Risks and why]: This bug is bad enough that it is worth the risk of any (doubtful) regression from this fix. It only affects screen reader users who are a small fraction of the userbase.
[String/UUID change made/needed]: None.
Attachment #8706556 - Flags: approval-mozilla-beta?
Attachment #8706556 - Flags: approval-mozilla-aurora?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Tracking to make sure it lands.
https://hg.mozilla.org/mozilla-central/rev/72f6f6c5b98b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Comment on attachment 8706556 [details] [diff] [review]
Re-introduce workaround for Android tap gesture.

Fix for screen reader tap gesture, ok to uplift to beta and aurora.
Attachment #8706556 - Flags: approval-mozilla-beta?
Attachment #8706556 - Flags: approval-mozilla-beta+
Attachment #8706556 - Flags: approval-mozilla-aurora?
Attachment #8706556 - Flags: approval-mozilla-aurora+
Verified as fixed on Firefox 45 Beta 9, on Lenovo Yoga Tablet 2 (Android 4.4.2). 
Nolan, can you please that this is fixed on your device, after updating to Firefox 45 Beta 9?
Flags: needinfo?(nolan)
You need to log in before you can comment on or make changes to this bug.