Status

defect
P1
critical
RESOLVED FIXED
4 years ago
Last year

People

(Reporter: ashughes, Assigned: marco)

Tracking

(Blocks 1 bug, {crash})

unspecified
Unspecified
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(firefox42 wontfix, firefox43+ wontfix, firefox44+ wontfix, firefox45+ wontfix, firefox46- wontfix, firefox47 wontfix, firefox48 wontfix, firefox49 wontfix, firefox-esr38 unaffected, firefox-esr45 unaffected, firefox50 wontfix, firefox52 wontfix, firefox-esr52 wontfix, firefox53 wontfix, firefox54 fixed, firefox55 fixed)

Details

(Whiteboard: [gfx-noted], crash signature)

Attachments

(2 attachments)

This bug was filed from the Socorro interface and is 
report bp-695430d9-0b82-4b23-8827-23f332151217.
=============================================================
 0 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x6172 	
Ø 1 	ntdll.dll 	ntdll.dll@0x12151 	
Ø 2 	ntdll.dll 	ntdll.dll@0x11d9a 	
Ø 3 	ntdll.dll 	ntdll.dll@0x11f43 	
Ø 4 	ntdll.dll 	ntdll.dll@0x11070 	
Ø 5 	ntdll.dll 	ntdll.dll@0x109b3 	
Ø 6 	ntdll.dll 	ntdll.dll@0x10df2 	
Ø 7 	ntdll.dll 	ntdll.dll@0x10f8b 	
Ø 8 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x38d4f 	
Ø 9 	ntdll.dll 	ntdll.dll@0x114da 	
Ø 10 	ntdll.dll 	ntdll.dll@0x374de 	
Ø 11 	ntdll.dll 	ntdll.dll@0x89fb 	
Ø 12 	kernelbase.dll 	kernelbase.dll@0x56bf2 	
Ø 13 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x476ef 	
Ø 14 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0xc5c0 	
Ø 15 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x476ef 	
Ø 16 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x240f 	
Ø 17 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x476ef 	
Ø 18 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x6791 	
Ø 19 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x448df 	
Ø 20 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x448df 	
Ø 21 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x5ed9 	
22 		@0x7ffbf5c7ffff 	
Ø 23 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x4700f 	
Ø 24 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x4708f 	
25 		@0x7ffc0977ffff 	
Ø 26 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x3354 	
Ø 27 	nahimicmsiosd.dll 	nahimicmsiosd.dll@0x4708f 	
28 		@0x7ffc0977ffff 	
Ø 29 	nahimicmsidevprops.dll 	nahimicmsidevprops.dll@0xa01e 	
Ø 30 	nahimicmsidevprops.dll 	nahimicmsidevprops.dll@0x3268f 	
31 	nss3.dll 	PR_WaitCondVar 	nsprpub/pr/src/threads/combined/prucv.c
32 		@0x4f0044004e0048 	
=============================================================
Just stumbled upon a whole bucket of these crashes going back as least as far as Firefox 7. It would appear this dll correlates to MSI's Nahimic audio software: http://gaming.msi.com/features/nahimic. We've seen about 180 crashes reported against Release over the last week.

This is highly correlated to Windows 10 with 92% on that platform and also appears to be a startup crash with 91% reported within the first minute of startup time.

[Tracking Requested - why for this release]: nominating to track since this is a startup crash and on the off chance that we have a contact at MSI.
Summary: crash in nahimicmsiosd.dll → startup crash in nahimicmsiosd.dll
Adding other signatures related to the same library.
Crash Signature: [@ nahimicmsiosd.dll@0x6172] → [@ nahimicmsiosd.dll@0x46b2] [@ nahimicmsiosd.dll@0x4be9] [@ nahimicmsiosd.dll@0x4c29] [@ nahimicmsiosd.dll@0x4c32] [@ nahimicmsiosd.dll@0x4c39] [@ nahimicmsiosd.dll@0x4c69] [@ nahimicmsiosd.dll@0x5d19] [@ nahimicmsiosd.dll@0x5eb9] [@ nahimicmsios…
Hi Anthony,

I'm updating the issue component in order to be more visible. If my searches were right, I suppose this relates to audio/video. If not, please feel free to change it to a more appropriate one.

Thanks,
Paul
Component: Untriaged → Audio/Video
Product: Firefox → Core
Paul/Matthew - Moving to cubeb, but really this is likely a driver problem.  Perhaps we can tell them more details about why, or side-step the problem.
Rank: 15
Component: Audio/Video → Audio/Video: cubeb
Flags: needinfo?(padenot)
Flags: needinfo?(kinetik)
Priority: -- → P1
nical can get me an MSI machine where I can try to repro, I'll keep the NI so I don't forget.
Let's see if Paul can repro since he has access to the necessary equipment.

A couple of quick thoughts:

In the linked crash, the crash is on the main thread (thread 0).  We never initialize cubeb on the main thread.  The crash stack looks suspect since the last recognizable Gecko code is a call to PR_WaitCondVar.

There are no cubeb stacks anywhere in the crash report (on other threads).

Regarding startup crashes: cubeb is initialized lazily on first use, so a startup crash shouldn't be cubeb related unless tabs with some form of audio are being restored during startup.

Digging around the other crash reports related to these Nahimic DLLs: 9adf1db9-db5e-4a6f-870c-8ac282160104 is a crash in nahimicmsiosd.dll with a stack passing through gfxWindowsPlatform::InitializeDevices() where d3dd11.dll is being loaded dynamically.

28472de1-3042-43f8-9cf6-2b1a42160104 and dfa29d06-a01f-45c8-9e95-938d32160104 are crashes in nahimicmsiosd.dll with a stack passing through gfx::VRManager::VRManager() -> InitializeOculusCAPI() loading Oculus VR related DLLs.

6fa8d021-bd28-45a5-a54d-1565f2151229 and 982fea02-8f14-4028-8bd4-21a882160102 are crashing with Flash in the stacks.

d25f4f8b-dbbd-4628-88e8-edef52151227 is a different Flash stack where initD3D11Lib is the last recognizable call before entering into nahimicmsidevprops.dll.

So from a first glance this looks more like a D3D11 initialization and/or library hooking problem than something audio related.
Flags: needinfo?(kinetik)
Tracking for 43, in case we come up with a hotfix. This doesn't look very high volume so it is probably more reasonable to aim a fix for 44.
Wontfix for 44 as well. Not a top crash, no one working on it, and we are late in 44 beta. 
I am sending this off to crash-debug list to see if someone can investigate further.
padenot, have you had any luck with hardware access?
Hi Maire, we have a week before Fx44 goes live, if this startup crash shows up on win10 on release channel, we should be treating this as a high-priority from an investigation point of view. If there is an easy fix, I hope we can take it in Beta44. Thanks for your help!
Flags: needinfo?(mreavy)
Per kinetik's evaluation in comment 6, this is likely a graphics/D3DX11 driver/hooking issue, not cubeb.  Moving to gfx and NIing milan for further triage
Rank: 15
Component: Audio/Video: cubeb → Graphics
Flags: needinfo?(padenot)
Flags: needinfo?(mreavy)
Flags: needinfo?(milan)
I actually meant to wontfix this for 43 (and 44... it is a startup crash but doesn't seem to happen very often, even on the release channel.) It still seems worth investigation and fixing, maybe not realistic for 44 though. Ritu, I will leave it to you for 44, but adding tracking flags for 44-45.
I'm not sure what we can do on the graphics side, but we can at least see if there is a correlation of NahimicMSIOSD.dll and other crashes; in other words, are there people that do not have a start up crash when they use this DLL? (We can see if there are non-startup crashes that have this DLL in there.)  Anthony, can you do that search?
Flags: needinfo?(milan) → needinfo?(anthony.s.hughes)
Whiteboard: [gfx-noted]
Adding some new signatures that have showed up since I last checked.

This is predominantly but not exclusively a startup crash.
> 62% happen within the first 10 seconds.
> 20% happen within the first 10-30 seconds.
>  6% happen within the first 30-60 seconds.
> 10% happen within the first 1 - 5 minutes.
>  2% happen after more than 5 minutes.

Note that by rank this is around #273 in 43.0.4 in combined signatures.

To answer Milan's question, are there people that do not have a start up crash when they use this DLL? I would say that there are but they are an extreme minority.
Crash Signature: [@ nahimicmsiosd.dll@0x46b2] [@ nahimicmsiosd.dll@0x4be9] [@ nahimicmsiosd.dll@0x4c29] [@ nahimicmsiosd.dll@0x4c32] [@ nahimicmsiosd.dll@0x4c39] [@ nahimicmsiosd.dll@0x4c69] [@ nahimicmsiosd.dll@0x5d19] [@ nahimicmsiosd.dll@0x5eb9] [@ nahimicmsios… → [@ nahimicmsiosd.dll@0x44ab] [@ nahimicmsiosd.dll@0x46b2] [@ nahimicmsiosd.dll@0x4be9] [@ nahimicmsiosd.dll@0x4c22] [@ nahimicmsiosd.dll@0x4c29] [@ nahimicmsiosd.dll@0x4c32] [@ nahimicmsiosd.dll@0x4c39] [@ nahimicmsiosd.dll@0x4c69] [@ nahimicmsios…
Flags: needinfo?(anthony.s.hughes)
Yeah, I don't see how it's going to be graphics.  Somebody with a system level understanding needs to look at this.  Johnny, who's a good person for that?
Flags: needinfo?(jst)
Still seeing this signature in nightly 47, still seems to be all Windows 10 users. Passing this on to the crashdebug list.
Liz, have you heard back from them? Thanks
Flags: needinfo?(lhenry)

Comment 18

3 years ago
those Nahimic dlls also show up in some crashes with the [@ RtlInitUnicodeStringEx | SearchPathW ] signature, which seems to be increasing in 45.0b & 46.0a2.

sample: https://crash-stats.mozilla.com/report/index/3f59216c-398d-47e3-b975-109cc2160211
Too late for Fx44, wontfix.
Anthony, can you find someone to dig into this? Seems like a very significant problem for a set of our users...
Flags: needinfo?(jst) → needinfo?(ajones)
Flags: needinfo?(lhenry)
These are all plugin crashes:

https://crash-stats.mozilla.com/report/list?signature=nahimicmsiosd.dll%400x5eb9#tab-reports

We need an expert in Windows to look into it, rather than an expert in audio.
Flags: needinfo?(ajones)
Component: Graphics → Plug-ins
Benjamin - thoughts?
Flags: needinfo?(benjamin)
None of these are in the Firefox process, so it doesn't make sense to call this a "startup" crash. Most are in Flash, although I did find a few in content processes as well.

This also doesn't seem like a very serious problem, with only 580 across all channels last week:
https://crash-stats.mozilla.com/search/?signature=%5Enahimicmsiosd.dll&_facets=signature&_facets=process_type&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=process_type&_columns=plugin_name#facet-signature

Example: https://crash-stats.mozilla.com/report/index/0ac26537-2aa5-4f28-bd79-de24d2160307#allthreads

I don't think this is a high priority, but I will load one minidump and see if there are other clues deeper in the stack trace.
Component: Plug-ins → General
Flags: needinfo?(benjamin)
Summary: startup crash in nahimicmsiosd.dll → child process crashes in nahimicmsiosd.dll

Comment 25

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #24)
> None of these are in the Firefox process

That's wrong. The process type numbers in your query only sum up to ~72% of all crashes, which means the remaining ~28% are in the main process (which has an empty/non-existent process type).
Summary: child process crashes in nahimicmsiosd.dll → crashes in nahimicmsiosd.dll
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #26)
> I have found Thunderbird crashes, but I cannot find any Firefox crashes:

This is Firefox? https://crash-stats.mozilla.com/report/index/5da7f566-7b70-4a30-bd06-426f22160522

Only 11 crashes last week though.

Comment 31

3 years ago
(In reply to Milan Sreckovic [:milan] from comment #30)
> (In reply to Benjamin Smedberg  [:bsmedberg] from comment #26)
> > I have found Thunderbird crashes, but I cannot find any Firefox crashes:
> 
> This is Firefox?
> https://crash-stats.mozilla.com/report/index/5da7f566-7b70-4a30-bd06-
> 426f22160522
> 
> Only 11 crashes last week though.

This is probably because people either stop using Firefox, Disable E10s or Disable Hardware Acceleration since it is impossible use Hardware Acceleration with E10s on certain PC's such as mine.

I've disabled E10's to be able to use Firefox for example, therefore you won't see any crashes from my setup even it crashes every single time when I enable Hardware Accel. with E10s.
Flags: needinfo?(milan)
Is nahimic2osd.dll@0x5ee2 going to be the same issue? I see about half as many of these signatures in 6-1 Windows Nightly, making it #3 for that build.
So, if you add up all the crashes from nahimic2osd.dll and nahimicmsiosd.dll, there are ~2500.  Out of those, ~1300 are Flash crashes.  A few Flash crashes I've seen, the calls come from d3d11.dll.

Most of the content (~1200) crashes don't have that of an interesting stack, at least to me :)

This one: https://crash-stats.mozilla.com/report/index/7db5bbb4-b056-48f4-aa78-c7b532160602 calls from LdrpApplyFileNameRedirection (manifest redirection in load.)

Bug 1262348 dealt with another place where LdrpApplyFileNameRedirection and "third party" DLL were conspiring to crash us, and we resolved it by blocking that DLL (in the bug 1262348, that was ss2osd.dll).  Both audio related, both causing trouble to gamers out there.  Apply the same solution?

I'd suggest we add this to mozglue/build/WindowsDllBlocklist.cpp:

  // NAHIMICMSIOSD, bug 1233556
  { "nahimicmsiosd.dll", ALL_VERSIONS },
  { "nahimic2osd.dll", ALL_VERSIONS },

Benjamin, thoughts?
Flags: needinfo?(milan) → needinfo?(benjamin)

Updated

3 years ago
Duplicate of this bug: 1277987
Surveying recent content process reports it looks like the app notes are the same. A spike triggered by some sort of a driver update?

FP(D000-L10010-W00000000-T0000) AdapterVendorID: 0x8086, AdapterDeviceID: 0x191b, AdapterSubsysID: 116d1462, AdapterDriverVersion: 20.19.15.4331
Has dual GPUs. GPU #2: AdapterVendorID2: 0x10de, AdapterDeviceID2: 0x13d8, AdapterSubsysID2: 116d1462, AdapterDriverVersion2: 10.18.13.6472

gfx adapter list:
0x8086 	0x191b 	651 	99.4%
0x10de 	0x1617 	4 	0.6%
Yes, there's a clear spike on Nightly. E.g. Nightly 20160603030242 has 32 of these crashes, which is very high.
The spike in submissions seems to be from bug 1269998. You can tell because of the SubmittedFromInfobar metadata.
(In reply to Bill McCloskey (:billm) from comment #38)
> The spike in submissions seems to be from bug 1269998. You can tell because
> of the SubmittedFromInfobar metadata.

Thanks, I didn't realize we tagged those reports. Ever one of these crashes was unreported until now thanks to that work.
Milan, have you talked to Nahimic about this? If this DLL is never valuable in the Firefox process, then blocking it is probably fine, but if we're talking about a case where it's useful to some users and crashes others, we're in a slightly tougher spot.

Have you also verified that adding this to the blocklist actually works? Sometimes (often?) 3rd-party software injects itself in ways that our blocklist cannot detect.
Flags: needinfo?(benjamin)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #40)
> Milan, have you talked to Nahimic about this?

Did not.  Have no idea how to do that, nor have done it before for similar scenarios.  Who usually does this kind of stuff?  Or is it the "tech evangelism" type of thing?
Flags: needinfo?(benjamin)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #40)
> ...
> Have you also verified that adding this to the blocklist actually works?
> Sometimes (often?) 3rd-party software injects itself in ways that our
> blocklist cannot detect.

No to this either.  This kind of blocking is magic to me, and I assume it works, and if it doesn't, we don't see the crashes go down.

I'm just trying to keep this Core::General bug going, it's been six months and it seems like it'd be worth finding a resolution, but I don't have any expertise on the subject, and it doesn't seem to be graphics related, so I'm shooting in the dark :)
Because DLL blocks can cause crashes in addition to fixing them, we very rarely deploy them blind without testing verification unless all other avenues have been exhausted. We have a policy of trying to contact the author before deploying blocks: https://wiki.mozilla.org/Blocklisting#Blocklisting_Process

Jorge can help reach out to 3rd parties if you can't do it yourself, but driving these kinds of bugs is definitely not simple. Perhaps with the uptime project we can get PM assistance from Harald? To the extent that we've decided that a block is the right solution, you can move this bug to the blocklisting component for better tracking.
Flags: needinfo?(benjamin) → needinfo?(hkirschner)
Dees, do we have relations with MSI?
Flags: needinfo?(hkirschner) → needinfo?(dchinniah)
(In reply to Harald Kirschner :digitarald from comment #44)
> Dees, do we have relations with MSI?

I don't. But will try to unlock something...
Flags: needinfo?(dchinniah)
I've just made an intro to Harald to two technical folks (Peter and Ruudt) at MSI. Hopefully they are able to re-direct to the correct folks within Nahimic.

Harald - please add others in Mozilla as necessary.
Flags: needinfo?(hkirschner)

Comment 47

3 years ago
Hi all, I am Ruudt Swaanen and I am an engineer at MSI in the Netherlands.
We are trying to reproduce this issue but we have not been able to see the issue yet.

MSI has different versions of Nahimic for different product groups (Notebooks, Desktop Systems and Motherboards).
Also the Realtek/Cmedia Audio driver needs to be the correct version (always update Realtek/Cmedia audio driver when you update Nahimic (for Notebook and Desktop Systems, it's one package Nahimic+Audio driver).
When updating Nahimic you should also take care of the correct order how to uninstall/install the audio driver and Nahimic. 
https://www.msi.com/faq/notebook-2215


What we have tried so far:
MSI GT72S 6QE notebook: Windows 10 Home x64 v10.0.10586, Realtek Audio driver v6.0.1.7848, Nahimic v2.2.7 with Firefox 47.0
MSI X99A GODLIKE GAMING motherboard: Windows 10 Pro x64 v10.0.10586, Realtek Audio driver v6.0.1.7806, Mahimic v2.2.6 with Firefox 47.0

We opened some websites, played some youtube videos but no crashes or errors yet.

Is there anything we need to do to see this issue?
 
Is there anyone who can reproduce the crash/error in Firefox 47.0 on an MSI product with the latest audio driver and Nahimic version?

BTW any MSI product that came with Nahimic version 1.x can be upgraded to Nahimic v2.x
Hi Rudy, can you tell anything from the DLL offsets at the time of the crash?  nahimicmsiosd.dll@0x6172, for example (see comment 0.)  Can't tell the version of Nahimic library, but all the crashes in the past week have come from Flash, if that helps.
(In reply to Milan Sreckovic [:milan] from comment #48)
> Hi Rudy, 

I'm sorry Ruudt, I have no idea where Rudy came from.
Looks like we got the right people on this now.
Flags: needinfo?(hkirschner)
Erdin, would you be willing for us to send one or more of your minidumps directly to Nahimic for them to debug? Because minidumps contain process memory, we generally can't share them outside of Mozilla, but with your permission it will likely make it much easier for them to debug this problem.

Updated

3 years ago
Flags: needinfo?(unique.ek)

Comment 53

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #52)
> Erdin, would you be willing for us to send one or more of your minidumps
> directly to Nahimic for them to debug? Because minidumps contain process
> memory, we generally can't share them outside of Mozilla, but with your
> permission it will likely make it much easier for them to debug this problem.

Would that contain my private information? If not, I would be happy to let you guys share it.

If it contains private information, I would be glad if you could let me know what kind of information that this minidump would contain.
platform-rel: --- → +

Comment 54

3 years ago
@Erdin, can you try the latest Nahimic 2.2.7 and Realtek audio driver for your notebook from our website:
https://www.msi.com/Laptop/support/GT72S-6QE-DOMINATOR-PRO-G.html#down-driver&Win10%2064

Direct Link:
http://download.msi.com/nb_drivers/ad/Audio%20driver_6.0.1.7818%20and%20Nahimic_2.2.7.zip

(first uninstall old Nahimic, then uninstall old Realtek audio driver, then install new Realtek audio driver, then install new Nahimic)?

Which Firefox version are you using?
I couldn't find that easily in the logs.

Comment 55

3 years ago
BTW, I cannot find a a file Nahimicmsiosd.dll in Nahimic 2 (v2.2.6 on X99 motherboard). I think this file has been replaced in Nahimic v2 by Nahimic2osd.dll.

Comment 56

3 years ago
we also see crashes in firefox with nahimic2osd.dll:
https://crash-stats.mozilla.com/search/?signature=^nahimic2osd.dll&date=>2016-04-01

Comment 57

3 years ago
I've just checked with A-Volute (who creates Nahimic for MSI) and they say it is a known issue (Nahimic version v2.2.x and earlier). 
They are currently working on this issue and expect this issue to be solved in version v2.3.0 (ETA somewhere in July).

There is no easy workaround atm, the only thing to do is to right click on the Nahimic Icon in systray and choose "Exit" to close Nahimic completely.

I will update again when Nahimic v2.3.0 is released, so you can test it.
Assignee

Comment 58

3 years ago
Should we blocklist versions < 2.3.0 for the time being then?
(In reply to Marco Castelluccio [:marco] from comment #58)
> Should we blocklist versions < 2.3.0 for the time being then?

These DLLs don't seem to be versioned, so we can't do a version specific block.
Now would be a good time to request that they start versioning their DLLs so that we can selectively block broken versions in the future.
Assignee

Comment 61

3 years ago
(In reply to Milan Sreckovic [:milan] from comment #59)
> (In reply to Marco Castelluccio [:marco] from comment #58)
> > Should we blocklist versions < 2.3.0 for the time being then?
> 
> These DLLs don't seem to be versioned, so we can't do a version specific
> block.

Ouch, this means users who don't update (most users I guess) and have this machine will always experience this crash.
Assignee

Comment 62

3 years ago
One question that hasn't been answered yet (comment 40) is whether this library is actually useful in Firefox. If it isn't, maybe we can blocklist it always.

Comment 63

3 years ago
(In reply to Ruudt Swaanen from comment #54)
> @Erdin, can you try the latest Nahimic 2.2.7 and Realtek audio driver for
> your notebook from our website:
> https://www.msi.com/Laptop/support/GT72S-6QE-DOMINATOR-PRO-G.html#down-
> driver&Win10%2064
> 
> Direct Link:
> http://download.msi.com/nb_drivers/ad/Audio%20driver_6.0.1.
> 7818%20and%20Nahimic_2.2.7.zip
> 
> (first uninstall old Nahimic, then uninstall old Realtek audio driver, then
> install new Realtek audio driver, then install new Nahimic)?
> 
> Which Firefox version are you using?
> I couldn't find that easily in the logs.

I will try that as soon as possible. Downloading the latest drivers right now.

Not sure about the Firefox version at the moment the logs were created. But I realized I've marked the bug as 49 branch, so I believe it was probably a nightly version of 49 that was up while I was reporting the bug.

Comment 64

3 years ago
(In reply to Ruudt Swaanen from comment #54)
> @Erdin, can you try the latest Nahimic 2.2.7 and Realtek audio driver for
> your notebook from our website:
> https://www.msi.com/Laptop/support/GT72S-6QE-DOMINATOR-PRO-G.html#down-
> driver&Win10%2064
> 
> Direct Link:
> http://download.msi.com/nb_drivers/ad/Audio%20driver_6.0.1.
> 7818%20and%20Nahimic_2.2.7.zip
> 
> (first uninstall old Nahimic, then uninstall old Realtek audio driver, then
> install new Realtek audio driver, then install new Nahimic)?
> 
> Which Firefox version are you using?
> I couldn't find that easily in the logs.

Just updated the drivers and issue seems to be gone. I will update here again if I come across any other crashes due to Nahimic.

Current Nahimic Version: 2.2.7
Current Firefox Version: 50.0a1 (2016-06-29) (hardware accel and e10's enabled)
OS: Windows 1. 1511 Build 10586.420
Audio Driver Version: 6.0.1.7818
Flags: needinfo?(unique.ek)
(In reply to Marco Castelluccio [:marco] from comment #62)
> One question that hasn't been answered yet (comment 40) is whether this
> library is actually useful in Firefox. If it isn't, maybe we can blocklist
> it always.

Alternatively, is there a way for us to block this based on something other than the (non-existent) version number?  Also, if 2.2.7 does have a version number, then we can block everything that doesn't have a version number.
Crash Signature: nahimicmsiosd.dll@0x4ca2] [@ nahimicmsiosd.dll@0x5b89] [@ nahimicmsiosd.dll@0x5d19] [@ nahimicmsiosd.dll@0x5d82] [@ nahimicmsiosd.dll@0x5eb9] [@ nahimicmsiosd.dll@0x6092] [@ nahimicmsiosd.dll@0x6172] → nahimicmsiosd.dll@0x4ca2] [@ nahimicmsiosd.dll@0x5b89] [@ nahimicmsiosd.dll@0x5d19] [@ nahimicmsiosd.dll@0x5d82] [@ nahimicmsiosd.dll@0x5eb9] [@ nahimicmsiosd.dll@0x6092] [@ nahimicmsiosd.dll@0x6172] [@ nahimic2osd.dll@0x5ee2]
Assignee

Comment 66

3 years ago
I'm talking with a guy from Nahimic, he said they have several DLLs and are not versioning them all, but they are versioning the main one (I don't know which one it is yet).
Assignee

Updated

3 years ago
Crash Signature: nahimicmsiosd.dll@0x4ca2] [@ nahimicmsiosd.dll@0x5b89] [@ nahimicmsiosd.dll@0x5d19] [@ nahimicmsiosd.dll@0x5d82] [@ nahimicmsiosd.dll@0x5eb9] [@ nahimicmsiosd.dll@0x6092] [@ nahimicmsiosd.dll@0x6172] [@ nahimic2osd.dll@0x5ee2] → nahimicmsiosd.dll@0x4ca2] [@ nahimicmsiosd.dll@0x5b89] [@ nahimicmsiosd.dll@0x5d19] [@ nahimicmsiosd.dll@0x5d82] [@ nahimicmsiosd.dll@0x5eb9] [@ nahimicmsiosd.dll@0x6092] [@ nahimicmsiosd.dll@0x6172] [@ nahimic2osd.dll@0x5ee2] [@ nahimicmsiosd.dl…
This crash perhaps isn't as bad as it looks, because we're getting a large number of crashes from a small number of installations. E.g. in the past 7 days:

> Product  Version Count Percentage Installations
> Firefox  51.0b1  129 	 46.2% 	    2
> Firefox  53.0a1   95 	 34.1% 	    5
> Firefox  50.0b7   40 	 14.3% 	    2
> Firefox  50.0b99   6 	 2.2% 	    1
> Firefox  52.0a1    5 	 1.8% 	    1
> Firefox  50.0      3 	 1.1% 	    3
> Firefox  44.0.2    1 	 0.4% 	    1
Assignee

Comment 68

3 years ago
It also depends on which signature you pick, for example for nahimicmsiosd.dll@0x5eb9:

> Product  Version  Count  Percentage  Installations
> Firefox  50.0b7   164    43.9%       1
> Firefox  51.0a2   114    30.5%       9
> Firefox  50.0     53     14.2%       44

It looks like for most signatures we're getting a large number of crashes from a small number of installations only for Beta, while for Release number of installations ~= number of reports.
There were 848 nahimicmsiosd.dll crash reports submitted for Firefox 51.0.
Crash Signature: [@ nahimicmsiosd.dll@0x44ab] [@ nahimicmsiosd.dll@0x46b2] [@ nahimicmsiosd.dll@0x4be9] [@ nahimicmsiosd.dll@0x4c22] [@ nahimicmsiosd.dll@0x4c29] [@ nahimicmsiosd.dll@0x4c32] [@ nahimicmsiosd.dll@0x4c39] [@ nahimicmsiosd.dll@0x4c69] [@ nahimicmsios… → [@ nahimic2osd.dll@0x29b3] [@ nahimic2osd.dll@0x4d62] [@ nahimic2osd.dll@0x5e44] [@ nahimic2osd.dll@0x5ee2] [@ nahimicmsiosd.dll@0x28c3] [@ nahimicmsiosd.dll@0x28e3] [@ nahimicmsiosd.dll@0x2921] [@ nahimicmsiosd.dll@0x2fd3] [@ nahimicmsiosd.dll@0x…
Mass wontfix for bugs affecting firefox 52.
Assignee

Comment 71

2 years ago
If we blocklist the DLLs as part of bug 1356637, this bug will be fixed.
The patch for bug 1356037 only blocks nahimic2devprops.dll. That would likely fix the nahimic2osd.dll (Nahimic v2) signatures, but not the nahimicmsiosd.dll (Nahimic v1) ones.
Meant bug 1356637, of course.
Assignee

Comment 74

2 years ago
We should block nahimicmsiosd.dll too, there are ~800 crash reports over the past week with this DLL.
Assignee

Comment 75

2 years ago
Posted patch PatchSplinter Review
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Attachment #8860563 - Flags: review?(benjamin)

Updated

2 years ago
Attachment #8860563 - Flags: review?(benjamin) → review+

Comment 76

2 years ago
Pushed by mcastelluccio@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/70a0d63da264
Block injection of nahimicmsiosd.dll, as it can cause crashes. r=bsmedberg

Comment 77

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/70a0d63da264
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Assignee

Comment 78

2 years ago
Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Crashes for MSI users with this Nahimic DLL (version 1; version 2 is already blocked)
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: It's been in Nightly for a few days, and the block should have the same effects as the block from bug 1356637, which has also been uplifted to beta.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: It's just a blocklist change that didn't cause problems for version 2 of the DLL. It will cause Nahimic to not apply their audio effects to Firefox.
[String changes made/needed]: None.
Attachment #8865054 - Flags: approval-mozilla-beta?
Comment on attachment 8865054 [details] [diff] [review]
Patch for Beta

Block nahimicmsiosd.dll. Beta54+. Should be in 54 beta 6.
Attachment #8865054 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
These crashes affect ESR52/TB52 as well, but I'm not sure what our policy is for that.
Volume doesn't seem to warrant tracking for ESR52.
Assignee

Updated

2 years ago
platform-rel: + → ---
Component: General → Other
Product: Core → External Software Affecting Firefox
Target Milestone: mozilla55 → ---

Updated

2 years ago
See Also: → 1360029
Blocks: 1435797
No longer blocks: injecteject
You need to log in before you can comment on or make changes to this bug.