Closed Bug 1236156 Opened 4 years ago Closed 4 years ago

Menu button must be hidden on devices with a hardware one

Categories

(Firefox for Android :: General, defect)

45 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: kolan_n, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160101004007

Steps to reproduce:

Open Aurora 45a2 on a device with a hardware menu button


Actual results:

Saw a 3-dot menu button after the tab counter.


Expected results:

It mustn't be shown.
OS: Unspecified → Android
Hardware: Unspecified → ARM
Summary: Menu button must be hidden on devices with hardware one → Menu button must be hidden on devices with a hardware one
Depends on: 1209967
This is an intentions change. There are devices that seem to be reporting that they have a menu button when they don't, such as the One Plus 2. In addition always showing the 3 dot button simplifies the code and support documentation.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
>This is an intentions change. There are devices that seem to be reporting that they have a menu button when they don't, such as the One Plus 2.
For this case there should be a pref to hide that button.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(kbrosnan)
Resolution: WONTFIX → ---
(In reply to KOLANICH from comment #2)
> >This is an intentions change. There are devices that seem to be reporting that they have a menu button when they don't, such as the One Plus 2.
> For this case there should be a pref to hide that button.

In addition to Kevin's point in comment 1, many other modern applications ship one UI for all devices - it's expensive to maintain branching code like this. When deciding to move towards a one-UI-for-all-devices approach (bug 1202076), we agreed that the time we spend maintaining alternative device configurations for a small percentage of users is time we don't spend shipping higher quality features for a large percentage of users.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WONTFIX
Moving NI from bug 1209967.
Flags: needinfo?(s.kaspari)
Flags: needinfo?(kbrosnan)
I agree with mcomella: A menu button is an outdated concept from Android 2.3 and previous versions. Our current code to handle the various menu options is complex and hard to maintain. With the recent One Plus 2 issues there's no incentive anymore to maintain this. Unfortunately a pref would add more complexity than helping here.
Flags: needinfo?(s.kaspari)
I also want this changed back as I said here (maybe the wrong place): https://bugzilla.mozilla.org/show_bug.cgi?id=1229967#c12

I found this change in behavior in 45.0b and it's making me consider to drop Firefox for Android completely. I almost have no space to edit the address in vertical orientation using my Galaxy S4.

Broken phones properties should be taken as an exception, not the rule to break everyone else's experience.
We considered your points from bug 1229967 when making this decision and, unfortunately, we still decided to remove the button. Please see the discussion above for more context.

fwiw, Google applications (e.g. Chrome, Youtube) also always display the software menu button, presumably to reduce code complexity, despite having significantly more resources than us.

(In reply to EmuAGR from comment #6)
> Broken phones properties should be taken as an exception, not the rule to
> break everyone else's experience.

I'm not sure what you mean by this.
(In reply to Michael Comella (:mcomella) from comment #7)
> fwiw, Google applications (e.g. Chrome, Youtube) also always display the
> software menu button, presumably to reduce code complexity, despite having
> significantly more resources than us.
> [...]
> I'm not sure what you mean by this.

I think the GApps shows the option button when there's plenty of space, not always:
- Youtube cleans the upper bar when you push "search" so you have full width text edition.
- Gmail has empty space in the upper bar too.

I'm sorry, I omitted the context. I was referring to what I read about the One Plus, that report hw buttons when it doesn't, or something like that.
(In reply to EmuAGR from comment #8)
> I think the GApps shows the option button when there's plenty of space, not
> always:

Have you experienced any cases when the software overflow menu button does not appear? As far as I know, Google doesn't support that case anymore [1].

> - Youtube cleans the upper bar when you push "search" so you have full width
> text edition.

When you click on the url bar to edit the url on phones, it should expand to fill the entire screen. Do you see this behavior?

> I'm sorry, I omitted the context. I was referring to what I read about the
> One Plus, that report hw buttons when it doesn't, or something like that.

I agree, but it's one of many other reasons.

[1]: http://www.androidbeat.com/2013/12/google-kills-hardware-menu-button-android-4-4-kitkat/
Maybe on narrow screens the menu button should collapse onto the tab button, so that holding the tab button displayed the menu; I don't have a problem with this button being there when in landscape mode but it really affects the url bar in portrait mode.
This feature could be optional, or not.
Reducing the width of the menu button to 1/4 or 1/3 of its current size could be another solution. It is much too wide! But this could be configurable for people who have difficulties for clicking on buttons (but they would already have problems with buttons on web pages).
re comment 11 and comment 12, we're trying to reduce the number of configurations we need to support so that we have more time to work on other things. Most phones sold nowadays are quite large and don't have these sizing issues, meaning that most of our users don't have this issue (or soon will not, as they upgrade). Unfortunately, there just isn't enough time to optimize for every configuration of device using Firefox.
I do have a large phone. But the button is sized as if it were for small phones.
(In reply to Michael Comella (:mcomella) from comment #13)
> Most phones sold nowadays are quite large
"Most phones" have a hard or soft menu button, yet the fact that some phones behave strangely with this respect partly motivated this change.

I'm in favor of simplifying the code in a "one size fits all" fashion though; I was just saying that reduced sizes should use a more compact UI.  For example, the Back button is not shown in phones where there is not much space, only in tablets.  My idea in that comment was to dynamically remove elements from the UI as it shrinks.

Anyway, my main issue with the change is the reduction of the URL, not of the URL bar (which could be reduced to a button FWIW).  Wouldn't it be possible to find a way to use the space more efficiently?  For example, the URL text box could be removed entirely except when typing on it, displaying the text directly on the bar; this would allow for more horizontal and vertical space.  The vertical space could be used to put both URL and title on the top bar, and also rearrange the icons (favicon+security) so that they appear below the URL rather than next to it (in particular, below the https:// part of the URL, so that tapping that area of the URL would open the security info box).

Additionally, the suggestion of bug 755123 of swiping the title bar to change tabs and open the tab menu could allow the removal of the tab button (which could be reduced to a mere non-tappable small number indicating how many open tabs there are).

In short, what I was really after was an efficient use of space, specially on devices where it is scarce.
(In reply to cousteau from comment #15)
> In short, what I was really after was an efficient use of space, specially
> on devices where it is scarce.

We are currently working on bug 1018994 and bug 1236431. Both should hopefully lead to better usage of the available space on small devices.
(In reply to Michael Comella (:mcomella) from comment #13)
> Most phones sold nowadays are quite large and don't have these
> sizing issues, meaning that most of our users don't have this issue (or soon
> will not, as they upgrade).

By the way, my phone is a Samsung Galaxy Trend Plus which I've had for less than 16 months, is that considered an old phone already?  (true, it's not a high end phone, but the model is barely 2 years old; so it's not really an old phone... or is it?)

In case you're curious, attachment 8715757 [details] (from bug 1209967) shows a screenshot of how Firefox looks on my phone (it has a 4" screen, which for me is the perfect pocket size so I probably won't get a much larger phone in a future).
Duplicate of this bug: 1250604
Duplicate of this bug: 1259067
Duplicate of this bug: 1289101
You need to log in before you can comment on or make changes to this bug.