Closed Bug 1236251 Opened 4 years ago Closed 4 years ago

Intermittent apps/ftu/test/marionette/rtl_test.js | First Time Use > Change language to bidi english

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
2.6 S5 - 1/15

People

(Reporter: philor, Assigned: sfoster)

References

Details

(Keywords: intermittent-failure, Whiteboard: [systemsfe])

Attachments

(1 file)

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1236376
Wrong one from the multiple bugs I filed off that single run, this one is a crash with no stack masquerading as just an ordinary failure, not the port silliness.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Or a not-a-crash masquerading as a crash, whatever that is.
Running just this test at https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=f334944730d5072245c14b2f049ade0abfe369e0 to investigate/confirm
Assignee: nobody → sfoster
Target Milestone: --- → 2.6 S5 - 1/15
Works for me - see 20 green runs in Comment #6, and I don't see this failing any more on inbound? (this test is not blacklisted and still running there) Possibly fixed by bug 1188274 or bug 1233892?
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Flags: needinfo?(mhenretty)
Resolution: --- → WORKSFORME
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1236251 says we saw one instance on each of mozilla-inbound and fx-team last Friday, three instances last Wednesday, zero on Thursday. So I'd expect it to be at most more like 0.5-1.0% than the 5% that would make 20 runs likely to hit it.
(In reply to Phil Ringnalda (:philor) from comment #8)
> https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1236251 says
> we saw one instance on each of mozilla-inbound and fx-team last Friday,
> three instances last Wednesday, zero on Thursday. So I'd expect it to be at
> most more like 0.5-1.0% than the 5% that would make 20 runs likely to hit it.

Ok. I see some stuff in this test that could be fixed, so I'll patch it and go from there.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
nm mhenretty, I'll flag you for review when I have something.
Flags: needinfo?(mhenretty)
https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=2df0650c5322d25753edf1655b3239208e42956f 

The PR fixes up the test to use the default timeouts and leverage the new helpers. I see 1/40 failures, and from the logs it looks like the FTU didn't start yet? 

NoSuchElement: Unable to locate element: #windows iframe[src*="app://ftu.gaiamobile.org"]

That's from:

           at getAppWithCheckOnOriginOnly (/home/worker/git_checkout/node_modules/marionette-apps/lib/getapp.js:113:10)
           at getApp (/home/worker/git_checkout/node_modules/marionette-apps/lib/getapp.js:63:10)
           at switchToApp (/home/worker/git_checkout/node_modules/marionette-apps/lib/switchtoapp.js:24:10)
           at Object.Ftu.switchToFtu (/home/worker/git_checkout/apps/ftu/test/marionette/lib/ftu.js:109:22)
           at Object.Ftu.waitForCurtainUp (/home/worker/git_checkout/apps/ftu/test/marionette/lib/ftu.js:94:10)
           at Object.Ftu.waitForFtuReady (/home/worker/git_checkout/apps/ftu/test/marionette/lib/ftu.js:114:10)
           at Context.<anonymous> (/home/worker/git_checkout/apps/ftu/test/marionette/rtl_test.js:24:9)

Would I expect to see something about switchToApp / findElement timing out here? I'm just infering this.
Flags: needinfo?(mhenretty)
Whiteboard: [systemsfe]
> NoSuchElement: Unable to locate element: #windows iframe[src*="app://ftu.gaiamobile.org"]

This means that findElement for the ftu app's iframe when doing a switchToApp is timing out internally inside the marionette driver. Sounds like bootup time for the system is slowing down in these cases, which is indeed not related to this test. I'm ok with closing this bug if that's the only problem we are seeing.
Flags: needinfo?(mhenretty)
Comment on attachment 8706510 [details] [review]
[gaia] sfoster:ftu-rtl-gij-intermittent-bug-1236251 > mozilla-b2g:master

I've re-triggered but this is looking good so far. The patch refactors the test to use new helpers and fixes a bad assertion. It doesnt attempt to address the occasional bootup timeout we've seen.
Attachment #8706510 - Flags: review?(mhenretty)
Comment on attachment 8706510 [details] [review]
[gaia] sfoster:ftu-rtl-gij-intermittent-bug-1236251 > mozilla-b2g:master

Much improved, thanks!
Attachment #8706510 - Flags: review?(mhenretty) → review+
Merged to master: https://github.com/mozilla-b2g/gaia/commit/137679df10f04d4935ba5668b71e30a09a16447b
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Depends on: 1239521
You need to log in before you can comment on or make changes to this bug.