Closed Bug 1236916 Opened 8 years ago Closed 9 months ago

History not imported anymore from Safari 8+

Categories

(Firefox :: Migration, defect, P1)

All
macOS
defect

Tracking

()

RESOLVED FIXED
115 Branch
Tracking Status
firefox44 --- wontfix
firefox45 --- wontfix
firefox46 --- wontfix
firefox47 --- wontfix
firefox48 --- wontfix
firefox72 --- wontfix
firefox115 --- fixed

People

(Reporter: vtamas, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 2 obsolete files)

Reproducible on: Firefox 46.0a1, Firefox 45.0a2 and Firefox 44 beta 6 under Mac OS X 10.10.5 and 10.11

Prerequisites: Safari is installed and has:
- browsing history
- saved bookmarks
- search bar history

STR
1.Run Firefox for the first time or remove the profiles folder.
2.Select Safari from the "Import Settings and Data" window and click on “Next” button.
3.Press "Next" and then “Finish” buttons.
4.Check the imported history.

ER
Firefox has all the other browser's history imported.

AR
The history is not imported.


Additional notes:
- Reproducible on: Firefox 46.0a1 (2016-01-05) and Firefox 45.0a2 (2016-01-05) and Firefox 44 beta 6 (20160104162232) under Mac OS X 10.10.5 with Safari 9.0.2 (10601.3.9) and Mac OS X 10.11 with Safari 9.0 (11601.1.56).
- This issue is not reproducible under Mac OS X 10.9.5 with Safari 9.0.2 (9537.86.3.9.1).
- There are no errors in Browser Console.
Is this still reproducible? Is it a regression?
Flags: needinfo?(vasilica.mihasca)
Tested on Mac OS X 10.11 and still reproducing on latest Nightly (build ID: 20160411030231) when importing from Safari 9.0.1 (11601.2.72).
The available options to import are: prefs / bookmarks / other data.

This is not a regression, it reproduces back to Fx 10.0.2 (where only "prefs" and "bookmarks" are available). Also, on Fx 18.0.2 the same options as in latest builds are displayed and the issue persists.
Flags: needinfo?(vasilica.mihasca)
QA Contact: vasilica.mihasca → cornel.ionce
OK. Looks like this is really an enhancement request.

Jeff - Is importing history from Safari something that the product team thinks is valuable at this point? If yes, can you help to prioritize? If not, I suggest that we resolve wontfix.
Flags: needinfo?(jgriffiths)
Actually, our Safari profile migrator HAS an history migrator
http://mxr.mozilla.org/mozilla-central/source/browser/components/migration/SafariProfileMigrator.js#181

So this is not a wontfix regardless, we should either fix the existing migrator or remove it if we don't care.

It's strange this dates back to FX10 though, since the migrator was added in firefox 14 and it was likely working at that time.
It's more likely Safari changed something in the way it stores history. We currently read from a History.plist file.

we really need a way to test migrators automatically :(
So indeed looks like From Safari 8 they moved from History.plist to History.db (Sqlite)
Summary: [MAC] History not imported from Safari → [MAC] History not imported anymore from Safari 8 on
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #3)
> OK. Looks like this is really an enhancement request.
> 
> Jeff - Is importing history from Safari something that the product team
> thinks is valuable at this point? If yes, can you help to prioritize? If
> not, I suggest that we resolve wontfix.

It's valuable especially if we implement features that rely heavily on browsing history to work, eg activity stream or even just the awesomebar. It's not critical though, assigning P2.
Flags: needinfo?(jgriffiths)
Priority: -- → P2

A friend tried to switch to Firefox today and was met with the broken Safari importer. I replicated on a fresh profile. This seems like a bad first impression to give to users. I took up Marco's suggestion from comment 4 and prepared a patch to disable it. This patch doesn't actually remove SafariProfileMigrator.jsm or do anything too drastic: it just removes the UI option to import from Safari. This seems like something that could still be fixed if it becomes a priority?

Uh, can you provide more details? This bug is specifically about history. AIUI we support importing other things (bookmarks incl. reading list). When you say "broken" - comment #0 suggests that all that happens is you ask it to import history and it does not, in fact, import history - but there are no errors and comment #0 doesn't suggest bookmarks are broken, too. Is that what's happening? If so it'd seem to be more sensible to just disable the history portion...

Flags: needinfo?(htwyford)

Ah, I was just typing a clarification and our comments collided! Nothing at all is imported. The console prints

JavaScript error: resource://gre/modules/PropertyListUtils.jsm, line 159: Error: aBuffer cannot be parsed as a DOM document: Error: aDoc is not a property list document

when one runs the Safari importer. I tried to import using Nightly 71.0a1 (2019-09-30) and my friend is running is running the latest version of Release. Maybe Safari bookmarks and reading list migrated to a Sqlite DB sometime since Safari 8 just like History did, as pointed out by Marco.

Flags: needinfo?(htwyford)

(In reply to Harry Twyford [:harry] from comment #10)

Ah, I was just typing a clarification and our comments collided! Nothing at all is imported. The console prints

JavaScript error: resource://gre/modules/PropertyListUtils.jsm, line 159: Error: aBuffer cannot be parsed as a DOM document: Error: aDoc is not a property list document

when one runs the Safari importer.

This seems like a separate bug that may be worth tracking separately (or at least figuring out when it broke), and possibly fixable. I'd say history is probably less important than bookmarks, and from just this error it's not clear what exactly is breaking things.

Depends on: 1586378
Attachment #9098917 - Attachment is obsolete: true
Depends on: 1493103
No longer depends on: 1586378

Still reproducible on Mac OS X 10.15 with FF 72.0a1(2019-10-22).

Severity: normal → S3
Summary: [MAC] History not imported anymore from Safari 8 on → History not imported anymore from Safari 8+
Assignee: nobody → eliang

Re-assigning this over to Mark to pick-up the patch and move it forward. Thanks to eliang for getting this started.

Assignee: eliang → mstriemer
Priority: P2 → P1
Attachment #9335922 - Attachment description: Bug 1236916 - Fix Safari history migration r?mconley → Bug 1236916 - Part 1: Fix Safari history migration r?mconley
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2f5b34d7551
Part 1: Fix Safari history migration r=mconley
https://hg.mozilla.org/integration/autoland/rev/2f004b59bfdb
Part 2: Test Safari history migration r=mconley
Attachment #9335922 - Attachment description: Bug 1236916 - Part 1: Fix Safari history migration r?mconley → Bug 1236916 - Part 1: Fix Safari history migration r?mconley!
Attachment #9336022 - Attachment description: Bug 1236916 - Part 2: Test Safari history migration r?mconley → Bug 1236916 - Part 2: Test Safari history migration r?mconley!
Attachment #9335922 - Attachment description: Bug 1236916 - Part 1: Fix Safari history migration r?mconley! → Bug 1236916 - Part 1: Fix Safari history migration r?mconley
Attachment #9336022 - Attachment description: Bug 1236916 - Part 2: Test Safari history migration r?mconley! → Bug 1236916 - Part 2: Test Safari history migration r?mconley
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7989dfc3c15c
Part 1: Fix Safari history migration r=mconley
https://hg.mozilla.org/integration/autoland/rev/2c9ee3c4df9f
Part 2: Test Safari history migration r=mconley

Backed out for causing mochitests failures in browser_aboutwelcome_multistage_mr.js.

  • Backout link
  • Push with failures
  • Failure Log
  • Failure line: TEST-UNEXPECTED-FAIL | browser/components/newtab/test/browser/browser_aboutwelcome_multistage_mr.js | Panel should be tightly anchored to the bottom of the button shadow node. - -389.7166748046875 == 0 - got -389.7166748046875, expected 0 (operator ==)
Attachment #9335922 - Attachment description: Bug 1236916 - Part 1: Fix Safari history migration r?mconley → Bug 1236916 - Part 1: Fix Safari history migration r?mconley!
Attachment #9336022 - Attachment description: Bug 1236916 - Part 2: Test Safari history migration r?mconley → Bug 1236916 - Part 2: Test Safari history migration r?mconley!
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a0b5a7ade705
Part 1: Fix Safari history migration r=mconley
https://hg.mozilla.org/integration/autoland/rev/539dfe08bec7
Part 2: Test Safari history migration r=mconley

Backed out for causing xpcshell failures on test_Safari_bookmarks.js

Backout link

Push with failures

Failure log

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b64adfdf9ffa
Part 1: Fix Safari history migration r=mconley
https://hg.mozilla.org/integration/autoland/rev/d9149151cfdc
Part 2: Test Safari history migration r=mconley
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 115 Branch
Flags: needinfo?(mstriemer)
Attachment #9328599 - Attachment is obsolete: true
Regressions: 1837604
You need to log in before you can comment on or make changes to this bug.