Closed Bug 1493103 Opened 3 years ago Closed 7 months ago

[Mac 10.14] Data Migration from Safari is not working due to lack of "Full Disk Access" permission

Categories

(Firefox :: Migration, defect, P2)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
83 Branch
user-doc-firefox docs-completed
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 - wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox83 --- verified

People

(Reporter: Ovidiu, Assigned: Gijs)

References

(Blocks 4 open bugs, )

Details

Attachments

(5 files, 1 obsolete file)

[Affected versions]:

Firefox Nightly 64.0a1(2018-09-20)
Firefox beta 63.0b8
Firfox 62 release 

[Affected platforms]:

Mac OS X 10.14   System Version: macOS 10.14 (18A389)

[Steps to reproduce]:

Preconditions
Safari is installed and closed/open
custom preferences (including a custom homepage)
browsing history
saved bookmarks



1. Run Firefox for the first time, start Fx from the terminal using -migration command or simply remove the profiles folder from:

Library\Application Support\Firefox

2. Select Safari from the Import Settings and Data window and then click Continue.

3. The window changes state and The following items were successfully imported: Bookmarks and Other Data.


4. Click Done or wait for a few seconds.



[Expected result]:

Firefox has all the other browser settings and data imported.


[Actual result]:

The data and settings are not imported. 


[Additional notes]:


We tested with Mac OS X 10.13 and the issue is not reproducible, seems that this is related only with 10.14 OS.
Moving to Firefox | Migration which is probably a better component.
Component: Widget: Cocoa → Migration
Product: Core → Firefox
OK, so according to https://wiki.mozilla.org/QA/Firefox_migrators#Supported_data_types we should import Bookmarks, History, Home Page (I think we removed this?), and Search History and some Settings (not sure which). Can you list specifically which data types don't work. Do you see any errors/warnings in the Browser Console once the Firefox window opens? I'm not running 10.14 yet so can't test myself.
Flags: needinfo?(ovidiu.boca)
If I want to import from Safari I have only the option "Bookmarks", if I do the same action with Chrome I have "Cookies", "Browsing History", "Bookmarks".
With data from Safari the import is not working and in the browser console I have this error:





Handler function DebuggerProgressListener.prototype.onWindowCreated threw an exception: TypeError: window is undefined; can't access its "windowUtils" property Stack: getWindowID@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:54:3 DebuggerProgressListener.prototype.onWindowCreated<@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:1562:21 exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14 _fireEvent@chrome://global/content/bindings/wizard.xml:418:26 set_currentPage@chrome://global/content/bindings/wizard.xml:94:11 advance@chrome://global/content/bindings/wizard.xml:281:15 wizard_XBL_Constructor@chrome://global/content/bindings/wizard.xml:196:9 Line: 54, column: 3 ThreadSafeDevToolsUtils.js:88:5 
OpenGL compositor Initialized Succesfully. Version: 2.1 INTEL-12.0.34 Vendor: Intel Inc. Renderer: Intel Iris Pro OpenGL Engine FBO Texture Target: TEXTURE_2D 

Handler function DebuggerProgressListener.prototype.onWindowCreated threw an exception: TypeError: window is undefined; can't access its "windowUtils" property Stack: getWindowID@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:54:3 DebuggerProgressListener.prototype.onWindowCreated<@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:1562:21 exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14 _fireEvent@chrome://global/content/bindings/wizard.xml:418:26 set_currentPage@chrome://global/content/bindings/wizard.xml:94:11 advance@chrome://global/content/bindings/wizard.xml:281:15 @chrome://global/content/bindings/wizard.xml:148:15 EventListener.handleEvent*_initWizardButton@chrome://global/content/bindings/wizard.xml:371:12 wizard_XBL_Constructor@chrome://global/content/bindings/wizard.xml:184:9 Line: 54, column: 3 ThreadSafeDevToolsUtils.js:88:5 

Handler function DebuggerProgressListener.prototype.onWindowCreated threw an exception: TypeError: window is undefined; can't access its "windowUtils" property Stack: getWindowID@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:54:3 DebuggerProgressListener.prototype.onWindowCreated<@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:1562:21 exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14 _fireEvent@chrome://global/content/bindings/wizard.xml:418:26 set_currentPage@chrome://global/content/bindings/wizard.xml:94:11 advance@chrome://global/content/bindings/wizard.xml:281:15 @chrome://global/content/bindings/wizard.xml:148:15 EventListener.handleEvent*_initWizardButton@chrome://global/content/bindings/wizard.xml:371:12 wizard_XBL_Constructor@chrome://global/content/bindings/wizard.xml:184:9 Line: 54, column: 3 ThreadSafeDevToolsUtils.js:88:5 

Handler function DebuggerProgressListener.prototype.onWindowCreated threw an exception: TypeError: window is undefined; can't access its "windowUtils" property Stack: getWindowID@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:54:3 DebuggerProgressListener.prototype.onWindowCreated<@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:1562:21 exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14 _fireEvent@chrome://global/content/bindings/wizard.xml:418:26 set_currentPage@chrome://global/content/bindings/wizard.xml:94:11 advance@chrome://global/content/bindings/wizard.xml:281:15 @chrome://global/content/bindings/wizard.xml:148:15 observe@chrome://browser/content/migration/migration.js:382:11 notify@resource:///modules/MigrationUtils.jsm:307:9 resourceDone@resource:///modules/MigrationUtils.jsm:342:17 B_migrate/<@jar:file:///Applications/Firefox%20Nightly.app/Contents/Resources/browser/omni.ja!/components/SafariProfileMigrator.js:42:51 promise callback*B_migrate@jar:file:///Applications/Firefox%20Nightly.app/Contents/Resources/browser/omni.ja!/components/SafariProfileMigrator.js:41:10 doMigrate@resource:///modules/MigrationUtils.jsm:351:13 async*MP_migrate@resource:///modules/MigrationUtils.jsm:399:5 async*onMigratingMigrate@chrome://browser/content/migration/migration.js:307:11 async*onMigratingPageShow/<@chrome://browser/content/migration/migration.js:303:22 setTimeout handler*onMigratingPageShow@chrome://browser/content/migration/migration.js:303:5 anonymous@chrome://global/content/bindings/wizard.xml line 423 > Function:3:1 _fireEvent@chrome://global/content/bindings/wizard.xml:424:28 set_currentPage@chrome://global/content/bindings/wizard.xml:94:11 advance@chrome://global/content/bindings/wizard.xml:281:15 @chrome://global/content/bindings/wizard.xml:148:15 EventListener.handleEvent*_initWizardButton@chrome://global/content/bindings/wizard.xml:371:12 wizard_XBL_Constructor@chrome://global/content/bindings/wizard.xml:184:9 Line: 54, column: 3 ThreadSafeDevToolsUtils.js:88:5 
XML Parsing Error: no root element found Location: moz-nullprincipal:{0642cc7f-2d9d-1445-95c4-2ca351d59cde} Line Number 1, Column 1: {0642cc7f-2d9d-1445-95c4-2ca351d59cde}:1:1 
Error: aBuffer cannot be parsed as a DOM document: Error: aDoc is not a property list document PropertyListUtils.jsm:145:13 

Could not read Bookmarks.plist SafariProfileMigrator.js:33 
some bookmarks did not successfully migrate.
Flags: needinfo?(ovidiu.boca)
(In reply to ovidiu boca[:Ovidiu] from comment #3)
> If I want to import from Safari I have only the option "Bookmarks",

Was that also true on 10.13? Maybe there is an existing bug on those others not working but I definitely see code to import History, Reading List, and Search Strings.
Looks like bug 1236916 already covers History not working.
Can you look for and attach the Bookmarks.plist file at ~/Library/Safari/Bookmarks.plist (where ~ is your account home directory)?
Flags: needinfo?(ovidiu.boca)
Mac 10.13

This is the content of Bookmarks.plist


bplist00�
uqv_WebBookmarkUUIDTSyncXChildrenUTitle_WebBookmarkType_WebBookmarkFileVersion_$D045888C-1A2E-4BE1-A4A7-396FA44FBD98�	
CloudKitDeviceIdentifier_CloudKitMigrationState_@904C0EDAD9C712C424E70962740A6FE784AC431C1EB81DC4CD2B74F632DD6B59�r�_WebBookmarkIdentifier_$F0B13F06-FA5D-48D1-80BA-99ADB6EA275F_WebBookmarkTypeProxyWHistory�pq_$BCDF91BB-E000-4AEF-8E80-8C493DB8C6DA�#*18?FMT[bi� ReadingListNonSyncYURLString]URIDictionary_$D3F34166-8488-4548-A85A-FE78AA007C6A�_neverFetchMetadata	https://www.apple.com/_WebBookmarkTypeLeaf�!"UtitleUApple�$%'(_$C9BE29A8-81AD-474A-93CE-317B53785B8D�	https://www.icloud.com/�!)ViCloud�+,./_$C5A3C930-FB76-4F8C-B451-48C1404AD717https://www.yahoo.com/�!0UYahoo�2356_$AF48F0EF-6340-48F4-A858-08C479565F15https://www.bing.com/�!7TBing�9:<=_$76C446EE-A1F8-443B-8655-5B5DD5E1DBA4�	4https://www.google.com/?client=safari&channel=mac_bm�!>VGoogle�@ACD_$9284D618-C2FB-4972-9E82-5DEC39961642�	https://www.wikipedia.org/�!EYWikipedia�GHJK_$0A89ABCA-63BC-4E8E-AEFF-C766B96487CAhttps://www.facebook.com/�!LXFacebook�NOQR_$F424D2BB-1706-494A-ACA2-900F119613C7https://twitter.com/�!SWTwitter�UVXY_$0D896CC8-6B72-41C9-AB76-F795D32B9097https://www.linkedin.com/�!ZXLinkedIn�\]_`_$04CF97B1-D802-4A15-A634-2DBEC46E9911https://www.weather.com/�!a_The Weather Channel�cdfg_$DE101BB7-82D1-4197-B37B-99FB9C48CD32�	https://www.yelp.com/�!hTYelp�jkmn_$76006CF0-028A-4D29-8C88-B89C88E93450https://www.tripadvisor.com/�!o[TripAdvisor\BookmarksBar_WebBookmarkTypeList�stq]BookmarksMenu_$838D70BA-52DA-47C5-A2F6-CD4E1F69B8F8P',5;Mf����	0Wnv������*+DZ]cit����������&MPQilq|�������;>HSz}~����������	034PS\g����������'NQRqt�������w�


And here is a print screen from Mac OS X 10.13 after you selected to import from Safari: https://imgur.com/a/mXAmeBP

But on Mac 10.14 you can select only "Bookmarks".
Flags: needinfo?(ovidiu.boca)
(In reply to ovidiu boca[:Ovidiu] from comment #7)
> Mac 10.13
> 
> This is the content of Bookmarks.plist

Please use attachments as the comment may not preserve the proper encoding. I wasn't clear but I actually wanted that file from 10.14, if it exists.

> And here is a print screen from Mac OS X 10.13 after you selected to import
> from Safari: https://imgur.com/a/mXAmeBP

OK, thanks.

> But on Mac 10.14 you can select only "Bookmarks".

OK, so we need to investigate the Other Data too but the problem may be the same so we can keep one bug for now.
Flags: needinfo?(ovidiu.boca)
Attached file bookmarks.plist.rtf (obsolete) —
Here is the attached file for Bookmarks.plist from Mac OS X 10.14.
Flags: needinfo?(ovidiu.boca)
I'm pretty sure that's not the original file since that's a .rtf file with an RTF header. Can you attach the original?
Flags: needinfo?(ovidiu.boca)
Attached file Bookmarks copy.plist
Hi, sorry for the previous one, I hove this works for you.
Flags: needinfo?(ovidiu.boca)
Attachment #9016670 - Attachment is obsolete: true
Thanks! OK, I believe this is caused by the new privacy protections in Mojave.

Can you test the following:
1) Open System Preferences
2) Open Security & Privacy
3) Select the Privacy tab
4) Click the lock icon to unlock
5) Select "Full Disk Access" on the left bar
6) Click the [+] and add the Firefox Application (.app) file that you're testing with.
7) Run the STR from comment 0. The import should work (better) hopefully.

If that helps then we can add instructions to guide the user to do this. From what I've read online there isn't a way to prompt the user for this permission (unlike the others in that pref pane).
Flags: needinfo?(ovidiu.boca)
Hi Matt,

I've retested this following the instructions from comment 12 and now everything works, the "Bookmarks" can be selected and the import of bookmarks from Safari works as expected, there should be also "Other Data" option because on 10.13 you have that option?
 I'm on Mac OS X 10.14 with FF Nightly 64.0a1(2018-10-14).

About the fact that the settings are not visible I think there should be an easy way for the user to see these settings and to be able to import from Safari, maybe a pop-up when the user selects import from Safari, where all the settings should be displayed. 

Also, another thing that is not ok from my point of view is the fact that after the import is successfully made you don't see anything because you need to activate the Bookmarks Toolbar, I think this should be made automatically based on the fact that you imported data from Safari and you want to see that immediately and also this feature of importing from other browsers is for users that didn't use Firefox and now they want to come back to use it but they are not aware by the fact that they need to activate the "Bookmarks Toolbar", from my point of view as a user I think this is an important issue.
Flags: needinfo?(ovidiu.boca) → needinfo?(MattN+bmo)
(In reply to ovidiu boca[:Ovidiu] from comment #13)
> Also, another thing that is not ok from my point of view is the fact that
> after the import is successfully made you don't see anything because you
> need to activate the Bookmarks Toolbar, I think this should be made
> automatically based on the fact that you imported data from Safari and you
> want to see that immediately and also this feature of importing from other
> browsers is for users that didn't use Firefox and now they want to come back
> to use it but they are not aware by the fact that they need to activate the
> "Bookmarks Toolbar", from my point of view as a user I think this is an
> important issue.

You need to have more than 3 items imported on the bookmark toolbar for it to auto-show (see bug 1415692). Can you confirm that works?
Flags: needinfo?(MattN+bmo) → needinfo?(ovidiu.boca)
I have more Bookmarks on Safari, please see the print screen https://imgur.com/a/0ZI9HWU, please note that the Bookmarks Toolbar didn't appear after I did the import only after I enabled it.
Flags: needinfo?(ovidiu.boca)
You got the "From Safari" folder using step 1 from comment 0? From what I remember you should only get that folder if you use the migrator from within Firefox. Can you confirm what UI you used to start migration?

Since they are in one folder that counts as 2 items total which is not greater than 3 to auto-show the bookmark bar.
Flags: needinfo?(ovidiu.boca)
 (In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #16)
> You got the "From Safari" folder using step 1 from comment 0? From what I
> remember you should only get that folder if you use the migrator from within
> Firefox. Can you confirm what UI you used to start migration?

I start the Firefox with the Profile Manager - new profile, or I delete all the profiles from Library\Application Support\Firefox the main idea is to run the browser for the first time.

> 
> Since they are in one folder that counts as 2 items total which is not
> greater than 3 to auto-show the bookmark bar.

How can I have the 3 items or more in order to see if the Bookmarks Toolbar is displayed?
Flags: needinfo?(ovidiu.boca) → needinfo?(MattN+bmo)
(In reply to ovidiu boca[:Ovidiu] from comment #17)
>  (In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from
> comment #16)
> > You got the "From Safari" folder using step 1 from comment 0? From what I
> > remember you should only get that folder if you use the migrator from within
> > Firefox. Can you confirm what UI you used to start migration?
> 
> I start the Firefox with the Profile Manager - new profile, or I delete all
> the profiles from Library\Application Support\Firefox the main idea is to
> run the browser for the first time.

OK, but since last year we don't automatically show the migration wizard before Firefox starts up. The issue is bug 1416382.

> > Since they are in one folder that counts as 2 items total which is not
> > greater than 3 to auto-show the bookmark bar.
> 
> How can I have the 3 items or more in order to see if the Bookmarks Toolbar
> is displayed?

You would have to test with --migration until bug 1416382 is fixed.

So let's ignore the bookmark toolbar issue as that is bug 1416382. Let's focus on not importing from Safari on 10.14.
Flags: needinfo?(MattN+bmo)
Blocks: mojave
Summary: [Mac 10.14] Data Migration from Safari is not working → [Mac 10.14] Data Migration from Safari is not working due to lack of "Full Disk Access" permission
Happy to consider an uplift during 64, but I'm not convinced I need to track this.
I finally got access to a Mojave install… we can open the Full Disk Access System Preferences for the user using:

> open x-apple.systempreferences:com.apple.preference.security?Privacy_AllFiles
Priority: -- → P2
Duplicate of this bug: 1528271
Duplicate of this bug: 1574335
Duplicate of this bug: 1586378

The MVP would be to open the Full Disk Access pane automatically or with a link from the browser selection page (similar to the one for Chrome about closing it if it’s running).

One other approach that might be worth trying is having a button in the importer "Select Safari Bookmarks.plist file" that opens a file dialog configured to start in ~/Library/Safari and only allows selecting plist files. The user would have to select Bookmarks.plist and that grants Firefox access to it.

Blocks: 1236916

(In reply to Haik Aftandilian [:haik] from comment #25)

One other approach that might be worth trying is having a button in the importer "Select Safari Bookmarks.plist file" that opens a file dialog configured to start in ~/Library/Safari and only allows selecting plist files. The user would have to select Bookmarks.plist and that grants Firefox access to it.

This doesn't seem to work (tested on Mojave), in that if I open ~/Library/Safari with a regular file > open dialog, it has a "entry forbidden" (ie red circle with white stripe in the middle) icon on top of the folder and refuses to list any contents, claiming the folder has a size of 0 bytes. Same for ~/Library/Mail, and Calendars and various other subfolders of ~/Library/. Do you see something else?

Flags: needinfo?(haftandilian)

(I also tried using Firefox > Preferences > Downloads, to pick a folder, then picked the ~/Library/Safari folder, and that didn't help either)

(In reply to :Gijs (he/him) from comment #26)

This doesn't seem to work (tested on Mojave), in that if I open ~/Library/Safari with a regular file > open dialog, it has a "entry forbidden" (ie red circle with white stripe in the middle) icon on top of the folder and refuses to list any contents, claiming the folder has a size of 0 bytes. Same for ~/Library/Mail, and Calendars and various other subfolders of ~/Library/. Do you see something else?

Yes, it works for me on 10.14.6 and 10.15. In Nightly, with File->Open, (I use command-shift-. to show the Library dir in the file dialog), I can navigate to ~/Library/Safari and select Bookmarks.plist and open it. I tried a $ tccutil reset All and that didn't change anything. I do not have Nightly set to have full disk access. In Terminal, I'm able to cd into ~/Library/Safari and get a directory listing, but IIRC, at one point that was prevented so I must have done something to change this. I don't know what the recommended steps are for debugging something like this unfortunately.

You might be able to get some debug info from /Applications/Utilities/Console or using a log command such as $ log stream --debug --predicate 'subsystem == "com.apple.TCC"' although this might be independent from TCC.

Flags: needinfo?(haftandilian)
Duplicate of this bug: 1589976
Duplicate of this bug: 1606068

I still think comment 24 is low-hanging fruit that we should implement.

Joni, maybe we can have the SUMO page explain how the user can import from Safari on 10.14+? See comment 12 for 10.14 instructions, they may be slightly different for 10.15.

Flags: needinfo?(jsavage)

FYI the new Microsoft Edge just shows a dialog and links to a support article about granting Full Disk Access if it doesn't already have it.

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #31)

I still think comment 24 is low-hanging fruit that we should implement.

Joni, maybe we can have the SUMO page explain how the user can import from Safari on 10.14+? See comment 12 for 10.14 instructions, they may be slightly different for 10.15.

Please review this draft and add any comments to it if necessary: https://docs.google.com/document/d/18owEv35aaollJDj-v2whI4hJuWe5T0M0DVDHBkrHcsc/edit?ts=5e2f042f#.

Ni for comment #33.

Flags: needinfo?(MattN+bmo)

I made some comments in the document. I also have a WIP patch with the approach from comment 24.

Flags: needinfo?(jsavage)
Flags: needinfo?(MattN+bmo)
Depends on: 1615134

The docs were published a little while ago at https://support.mozilla.org/kb/importing-safari-data-firefox

We should probably link to them from the product in a new dependency bug if we don't get to this soon.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Blocks: 1665353
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bc4431b6eb57
allow users to import bookmarks from Safari without granting full disk access, r=jaws,Mardak,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
Flags: qe-verify+

Hey @Gijs,

I've been testing the issue on MacOS 10.14 with Nightly 82.0a1 (20200901094542) and Nightly 84.0a1 (20201112094441). With "Full Disk Access" permission set manually, both builds imported data from Safari without problem. However, if the "Full Disk Access" permission was not set, I still couldn't import the Safari data using both builds and I got the situation mentioned in comment 26. Can you please weigh in on this?

Also according to comment 36 there was an option to add a link to the Support Mozilla article, but I couldn't see it in the current Nightly build. Is this expected?

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Alexandra Martin from comment #40)

Hey @Gijs,

I've been testing the issue on MacOS 10.14 with Nightly 82.0a1 (20200901094542) and Nightly 84.0a1 (20201112094441). With "Full Disk Access" permission set manually, both builds imported data from Safari without problem. However, if the "Full Disk Access" permission was not set, I still couldn't import the Safari data using both builds and I got the situation mentioned in comment 26. Can you please weigh in on this?

You should not be setting the full disk access permission to test, and you should be getting a different wizard page when attempting to import Safari bookmarks, like the one in this screenshot. If you then click Continue you should see a file picker.

Are you unable to reproduce this on 10.14 ? If so, what about 10.15 ? On the 10.14 machine, can you try with a new user account to make sure no specific permissions for Firefox or Safari have been set (make sure to create some bookmarks in Safari before attempting to import!).

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(alexandra.martin)

I've tried again with the provided suggestions (different user accounts, not setting the full disk access permission, making sure there are bookmarks in Safari) on two 10.14 devices and one 10.15 device with Nightly 84.0a1 (20201113095941) and Beta 83.0 (20201112153044). I am getting the wizard page on both builds, however in 10.14 after I click "Continue", it doesn't lets me import what I bookmarked in Safari, because the folder is blocked. In 10.15 everything is fine, I could easily get to the Bookmarks.plist file and import it. If you have other suggestions I could try, I would very much appreciate it.

Flags: needinfo?(alexandra.martin) → needinfo?(gijskruitbosch+bugs)

(In reply to Alexandra Martin from comment #42)

Created attachment 9187671 [details]
10.14 Safari bookmarks import.png

I've tried again with the provided suggestions (different user accounts, not setting the full disk access permission, making sure there are bookmarks in Safari) on two 10.14 devices and one 10.15 device with Nightly 84.0a1 (20201113095941) and Beta 83.0 (20201112153044). I am getting the wizard page on both builds, however in 10.14 after I click "Continue", it doesn't lets me import what I bookmarked in Safari, because the folder is blocked. In 10.15 everything is fine, I could easily get to the Bookmarks.plist file and import it. If you have other suggestions I could try, I would very much appreciate it.

Bah, I should have remembered this - I talked about this a year ago with a friend of mine: https://twitter.com/tuxtina/status/1184374590082113536 .

I think we should mark this as verified fixed and have a follow-up for 10.14 (which we might wontfix...) - 10.15 is used a lot more so I imagine that was the more important fix here.

Flags: needinfo?(gijskruitbosch+bugs)

With 83.0 and macOS 10.15, it appears to work after selecting the prompted file.

(In reply to :Gijs (he/him) from comment #43)

(In reply to Alexandra Martin from comment #42)

Created attachment 9187671 [details]
10.14 Safari bookmarks import.png

I've tried again with the provided suggestions (different user accounts, not setting the full disk access permission, making sure there are bookmarks in Safari) on two 10.14 devices and one 10.15 device with Nightly 84.0a1 (20201113095941) and Beta 83.0 (20201112153044). I am getting the wizard page on both builds, however in 10.14 after I click "Continue", it doesn't lets me import what I bookmarked in Safari, because the folder is blocked. In 10.15 everything is fine, I could easily get to the Bookmarks.plist file and import it. If you have other suggestions I could try, I would very much appreciate it.

Bah, I should have remembered this - I talked about this a year ago with a friend of mine: https://twitter.com/tuxtina/status/1184374590082113536 .

I think we should mark this as verified fixed and have a follow-up for 10.14 (which we might wontfix...) - 10.15 is used a lot more so I imagine that was the more important fix here.

Alexandra, would you mind confirming and filing a follow-up for 10.14? Thank you.

Flags: needinfo?(alexandra.martin)

Alexandra, would you mind confirming and filing a follow-up for 10.14? Thank you.

I file this in the behalf of Alexandra, since she moved to another project. Please see bug 1679179 as a follow-up.

I think we should mark this as verified fixed and have a follow-up for 10.14 (which we might wontfix...) - 10.15 is used a lot more so I imagine that was the more important fix here.

I agree, I will close this bug as verified fixed per comment 44. Thanks!

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(alexandra.martin)
Blocks: 1679179
You need to log in before you can comment on or make changes to this bug.