Closed Bug 123834 Opened 23 years ago Closed 22 years ago

text missing from buttons in mail account setup wizard

Categories

(SeaMonkey :: MailNews: Account Configuration, defect)

PowerPC
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: tracy, Assigned: hewitt)

References

Details

(Whiteboard: [adt2] [driver:asa])

Attachments

(1 file)

seen on commercial trunk builds:

mac os9 2002-02-06-03-trunk
mac osx 2002-02-06-03-trunk
so far this morning only the mac builds have completed
I will change platform to all if/when this is confirmed on windows or linux

-with a new profile start the app and go to mail/news.
the account wizard appears. Notice the "Back" and "Go ahead" (I think that's 
what it says; there seems to be changes in the wizard) buttons are missing their 
text.  The buttons do function though.
this is _not_ on windows commercial 2002-02-06-06-trunk

from windows wizard, the text on the buttons should read "Back" and "Next"
Reassinging to Hewitt. I have downloaded windows build, and buttons appear and
function as expetced. This is a platform specific issue with base <wizard/>.
Please do update the bug with results on Linux platform. 
 
Hewitt, you can keep this under AccountManager component if you like. In case
you want change the component, please add keyword 'mailtrack'. Thanks.
Assignee: racham → hewitt
Also selected radio button is not visible but works as selected.
Seeing this with build 2002033008 on Mac OS 9.2.2 (and have been seeing it for a
while).
nominating
Keywords: nsbeta1
Nav triage team: nsbeta1+, adt2
Keywords: nsbeta1nsbeta1+
Whiteboard: [adt2]
Attached patch patchSplinter Review
So, I left the labels out of the mac wizard.properties because Mac wizards have
arrows for back/forward, not text.  However, only the classic wizard has css
for these labels, while the modern css does not, since it is not mac-specific. 
So, I'll just put those labels in for Mac.
Comment on attachment 78992 [details] [diff] [review]
patch

r=andreww
Attachment #78992 - Flags: review+
Who should super review this?
*** Bug 139052 has been marked as a duplicate of this bug. ***
Adding Seth & Blake to the cc list. Can one of you sr= this bug ? 

Today, Mac wizards are simply displaying empty buttons, leaving the action
associated with the button to the user's imagination. thanks.
*** Bug 140266 has been marked as a duplicate of this bug. ***
Can't ship this in 1.0. adding dependency and keywords.
Blocks: 138000
Keywords: mozilla1.0+
it's just waiting for a super review to get into trunk... someone? anyone?
*** Bug 141039 has been marked as a duplicate of this bug. ***
Comment on attachment 78992 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to the 1.0 branch. Let's get this in
quickly.
Attachment #78992 - Flags: approval+
Adding adt1.0.0 keyword.
Keywords: adt1.0.0
adt1.0.0+ (on ADT's behalf) approval fo checkin to the 1.0 branch. Pls check
this in today, then add fixed1.0.0 keyword.
Keywords: adt1.0.0adt1.0.0+
Whiteboard: [adt2] → [adt2] [Needs a=]
Asa already approved this on behalf of drivers (#17). Removing [Needs a=] from
Status Whiteboard. This is ready to be checked in.
Whiteboard: [adt2] [Needs a=] → [adt2]
do we need l10n approval for this one ? I saw dtd file changes in the patch.
Since this is platform specific to the Mac OS, l10n approves for checkin to the
branch. Please check this in today! It's critical it gets checked into the
branch immediately.
Whiteboard: [adt2] → [adt2] [driver:asa]
fixed
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
adding branch resolution keyword. 
Keywords: fixed1.0.0
verified with commercial builds:

win 2002-05-01-08-1.0.0
lin 2002-05-01-08-1.0.0
mac osx 2002-05-01-05-1.0.0

win 2002-05-01-04-trunk
lin 2002-05-01-07-trunk
mac osx 2002-05-01-03-trunk
Status: RESOLVED → VERIFIED
Reopening since there is a difference between using the Modern vs. Classic 
theme. Classic on Mac X is not showing the text.

Branch build 2002-05-01: Mac 10.1.3
- Modern: ok
- Classic: I only see the arrows, no text

Branch build 2002-05-01: Mac 9.1
- Modern: ok
- Classic: ok
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Trunk build 2002-05-01: 10.1.3, same results as in Comment# 25.
- Modern: ok
- Classic: I only see the arrows, no text
Correction, only arrows (no text) appear when using the Classic theme on Mac 9.1
and Mac X. 
*** Bug 141643 has been marked as a duplicate of this bug. ***
Joe explained that this is the desired behavior so marking this Fixed.
Status: REOPENED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → FIXED
Marking Verified since only "arrows" on the Mac using the Classic theme appears 
to be the desired behavior.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: