Closed Bug 1238472 Opened 4 years ago Closed 4 years ago

[emulator-x86-kk][mochitest] failures on test_browserElement_inproc_NoAudioTrack.html

Categories

(Firefox OS Graveyard :: AudioChannel, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(firefox46 fixed)

RESOLVED FIXED
Tracking Status
firefox46 --- fixed

People

(Reporter: hsinyi, Assigned: alwu)

References

Details

Attachments

(1 file)

B2G KK Emulator x86 opt Mochitest [TC] Mochitest tc-M(12)
https://treeherder.mozilla.org/logviewer.html#?job_id=3718575&repo=b2g-inbound

8:29:26     INFO -  31 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html

 18:29:27     INFO -  ############################### browserElementPanning.js loaded

 18:29:28     INFO -  ######################## BrowserElementChildPreload.js loaded

 18:29:28     INFO -  ######################## extensions.js loaded

 18:34:33     INFO -  32 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | Test timed out.

 18:34:33     INFO -      reportError@SimpleTest/TestRunner.js:114:7

 18:34:33     INFO -      TestRunner._checkForHangs@SimpleTest/TestRunner.js:134:7

 18:34:34     INFO -  MEMORY STAT | vsize 191MB | residentFast 53MB | heapAllocated 19MB

 18:34:35     INFO -  33 INFO TEST-OK | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | took 308404ms

 18:34:35     INFO -  34 INFO TEST-PASS | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | allowedAudioChannels exist

 18:34:35     INFO -  35 INFO TEST-PASS | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | 1 audio channel by default

 18:34:35     INFO -  36 INFO TEST-PASS | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | Correct class

 18:34:35     INFO -  37 INFO TEST-PASS | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | onactivestatechanged exists

 18:34:35     INFO -  38 INFO # Command = play

 18:34:35     INFO -  39 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | allowedAudioChannels exist - Result logged after SimpleTest.finish()

 18:34:35     INFO -  40 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | 1 audio channel by default - Result logged after SimpleTest.finish()

 18:34:35     INFO -  41 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | Correct class - Result logged after SimpleTest.finish()

 18:34:35     INFO -  42 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_NoAudioTrack.html | onactivestatechanged exists - Result logged after SimpleTest.finish()

 18:34:37     INFO -  43 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_Opensearch.html

 18:34:37     INFO -  44 INFO # Command = pause

 18:34:38     INFO -  45 ERROR [SimpleTest.finish()] this test already called finish!

 18:34:38     INFO -  MEMORY STAT | vsize 191MB | residentFast 54MB | heapAllocated 19MB
Assignee: nobody → alwu
See Also: → 1237758
Priority: -- → P2
Blocks: 1223298
Duplicate of this bug: 1238470
See Also: 1237758
Attachment #8709885 - Flags: review?(amarchesini)
Hi, Baku,
Could you help me review this patch?

The main problem is that we can't receive the "mozbrowserloadend" event. It seems that this event can't be dispatched if we enable the preload option for the "noaudio.webm". (only on the emulator-x86-kk)

However, I don't why this event can't be dispatched because I don't understand the moz-browser very well. I would open another bug to track this issue and ask kanru's feedback. In this patch, what I do is to avoid this situation happen, so I modify some logic and stop to preload the "noaudio.webm".

Very appreciate!
Comment on attachment 8709885 [details]
MozReview Request: Bug 1238472 - start playing webm after the iframe loaded.

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/31591/diff/1-2/
Comment on attachment 8709885 [details]
MozReview Request: Bug 1238472 - start playing webm after the iframe loaded.

https://reviewboard.mozilla.org/r/31591/#review28509
Attachment #8709885 - Flags: review?(amarchesini) → review+
https://hg.mozilla.org/mozilla-central/rev/9e816bd470de
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
See Also: → 1241960
You need to log in before you can comment on or make changes to this bug.