Closed Bug 1238542 Opened 4 years ago Closed 3 years ago

Intermittent Main app process exited normally | application crashed [@ mozilla::AbstractThread::MainThread()]

Categories

(Core :: Audio/Video: MediaStreamGraph, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---
firefox46 --- disabled
firefox47 --- disabled
firefox48 --- unaffected

People

(Reporter: cbook, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: crash, intermittent-failure)

https://treeherder.mozilla.org/logviewer.html#?job_id=6537556&repo=fx-team

 WARNING -  PROCESS-CRASH | Main app process exited normally | application crashed [@ mozilla::AbstractThread::MainThread()]
 17:39:48     INFO -  Crash dump filename: /tmp/tmpR0Cn6r.mozrunner/minidumps/00174d10-99f1-21f2-5ad1a744-6bc1cde0.dmp
 17:39:48     INFO -  Operating system: Linux
 17:39:48     INFO -                    0.0.0 Linux 3.2.0-76-generic #111-Ubuntu SMP Tue Jan 13 22:16:09 UTC 2015 x86_64
 17:39:48     INFO -  CPU: amd64
 17:39:48     INFO -       family 6 model 62 stepping 4
 17:39:48     INFO -       1 CPU
 17:39:48     INFO -  Crash reason:  SIGSEGV
 17:39:48     INFO -  Crash address: 0x0
 17:39:48     INFO -  Process uptime: not available
 17:39:48     INFO -  Thread 0 (crashed)
 17:39:48     INFO -   0  libxul.so!mozilla::AbstractThread::MainThread() [AbstractThread.cpp:55d6be76fac9 : 116 + 0x11]
 17:39:48     INFO -      rax = 0x0000000000000000   rdx = 0x0000000000000000
 17:39:48     INFO -      rcx = 0x00007f32a7b13f4d   rbx = 0x0000000000000001
 17:39:48     INFO -      rsi = 0x00007f32a7de7a80   rdi = 0x00007f32ac4e8b1f
 17:39:48     INFO -      rbp = 0x00007fff443735a0   rsp = 0x00007fff443735a0
 17:39:48     INFO -       r8 = 0x00007f32af83aa40    r9 = 0x6c702f786f666572
 17:39:48     INFO -      r10 = 0x6e6f632d6e696775   r11 = 0x0000000000000000
 17:39:48     INFO -      r12 = 0x0000000000000005   r13 = 0x0000000000000003
 17:39:48     INFO -      r14 = 0x0000000000000800   r15 = 0x00007f329fbbce50
 17:39:48     INFO -      rip = 0x00007f32a9537152
 17:39:48     INFO -      Found by: given as instruction pointer in context
 17:39:48     INFO -   1  libxul.so!mozilla::MediaStreamGraphImpl::RunInStableState(bool) [MediaStreamGraph.cpp:55d6be76fac9 : 1566 + 0x5]
 17:39:48     INFO -      rbx = 0x0000000000000001   rbp = 0x00007fff44373620
 17:39:48     INFO -      rsp = 0x00007fff443735b0   r12 = 0x0000000000000005
 17:39:48     INFO -      r13 = 0x0000000000000003   r14 = 0x0000000000000800
 17:39:48     INFO -      r15 = 0x00007f329fbbce50   rip = 0x00007f32aa9ba813
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   2  libxul.so!mozilla::::MediaStreamGraphStableStateRunnable::Run [MediaStreamGraph.cpp:55d6be76fac9 : 1371 + 0x15]
 17:39:48     INFO -      rbx = 0x00007f3288d11040   rbp = 0x00007fff44373640
 17:39:48     INFO -      rsp = 0x00007fff44373630   r12 = 0x0000000000000001
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32aa9ba908
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   3  libxul.so!mozilla::CycleCollectedJSRuntime::ProcessStableStateQueue() [CycleCollectedJSRuntime.cpp:55d6be76fac9 : 1106 + 0x3]
 17:39:48     INFO -      rbx = 0x00007f3298008000   rbp = 0x00007fff44373680
 17:39:48     INFO -      rsp = 0x00007fff44373650   r12 = 0x0000000000000001
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a94e4f58
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   4  libxul.so!mozilla::CycleCollectedJSRuntime::~CycleCollectedJSRuntime() [CycleCollectedJSRuntime.cpp:55d6be76fac9 : 467 + 0x8]
 17:39:48     INFO -      rbx = 0x00007f3298008000   rbp = 0x00007fff443736b0
 17:39:48     INFO -      rsp = 0x00007fff44373690   r12 = 0x00007f329fb20140
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a94e8ccb
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   5  libxul.so!XPCJSRuntime::~XPCJSRuntime() [XPCJSRuntime.cpp:55d6be76fac9 : 1653 + 0x5]
 17:39:48     INFO -      rbx = 0x00007f3298008000   rbp = 0x00007fff443736d0
 17:39:48     INFO -      rsp = 0x00007fff443736c0   r12 = 0x00007f329fb20140
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a9b2ad89
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   6  libxul.so!nsXPConnect::~nsXPConnect() [nsXPConnect.cpp:55d6be76fac9 : 99 + 0x6]
 17:39:48     INFO -      rbx = 0x00007f32980ffbb0   rbp = 0x00007fff443736f0
 17:39:48     INFO -      rsp = 0x00007fff443736e0   r12 = 0x00007f329fb20140
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a9b468d1
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   7  libxul.so!nsXPConnect::~nsXPConnect() [nsXPConnect.cpp:55d6be76fac9 : 103 + 0x5]
 17:39:48     INFO -      rbx = 0x00007f32980ffbb0   rbp = 0x00007fff44373710
 17:39:48     INFO -      rsp = 0x00007fff44373700   r12 = 0x00007f329fb20140
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a9b468f7
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   8  libxul.so!nsXPConnect::Release() [nsXPConnect.cpp:55d6be76fac9 : 39 + 0x8]
 17:39:48     INFO -      rbx = 0x00007f32980ffbb0   rbp = 0x00007fff44373740
 17:39:48     INFO -      rsp = 0x00007fff44373720   r12 = 0x00007f329fb20140
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a9b469eb
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -   9  libxul.so!xpcModuleDtor() [XPCModule.cpp:55d6be76fac9 : 22 + 0x5]
 17:39:48     INFO -      rbx = 0x00007f32980715c0   rbp = 0x00007fff44373750
 17:39:48     INFO -      rsp = 0x00007fff44373750   r12 = 0x00007f329fb8db20
 17:39:48     INFO -      r13 = 0x00007f3299eef610   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a9b2916d
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -  10  libxul.so!nsComponentManagerImpl::KnownModule::~KnownModule() [nsComponentManager.h:55d6be76fac9 : 242 + 0x2]
 17:39:48     INFO -      rbx = 0x00007f32980715c0   rbp = 0x00007fff44373770
 17:39:48     INFO -      rsp = 0x00007fff44373760   r12 = 0x00007f329fb8db20
 17:39:48     INFO -      r13 = 0x00007f3299eef610   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a952da18
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -  11  libxul.so!nsAutoPtr<nsComponentManagerImpl::KnownModule>::~nsAutoPtr() [nsAutoPtr.h:55d6be76fac9 : 74 + 0x8]
 17:39:48     INFO -      rbx = 0x00007f32980715c0   rbp = 0x00007fff44373790
 17:39:48     INFO -      rsp = 0x00007fff44373780   r12 = 0x00007f329fb8db20
 17:39:48     INFO -      r13 = 0x00007f3299eef610   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a953281a
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -  12  libxul.so!nsTArray_Impl<nsAutoPtr<nsComponentManagerImpl::KnownModule>, nsTArrayInfallibleAllocator>::RemoveElementsAt(unsigned long, unsigned long) [nsTArray.h:55d6be76fac9 : 529 + 0x10]
 17:39:48     INFO -      rbx = 0x00007f3299eef4e0   rbp = 0x00007fff443737d0
 17:39:48     INFO -      rsp = 0x00007fff443737a0   r12 = 0x00007f329fb8db20
 17:39:48     INFO -      r13 = 0x00007f3299eef610   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a95328db
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -  13  libxul.so!nsComponentManagerImpl::Shutdown() [nsComponentManager.cpp:55d6be76fac9 : 940 + 0xc]
 17:39:48     INFO -      rbx = 0x00007f329fb8d9f0   rbp = 0x00007fff443737f0
 17:39:48     INFO -      rsp = 0x00007fff443737e0   r12 = 0x00007f32a950a9e4
 17:39:48     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000808
 17:39:48     INFO -      r15 = 0x0000000000000001   rip = 0x00007f32a9532a09
 17:39:48     INFO -      Found by: call frame info
 17:39:48     INFO -  14  libxul.so!mozilla::ShutdownXPCOM(nsIServiceManager*) [XPCOMInit.cpp:55d6be76fac9 : 987 + 0x5]
 17:39:48     INFO -      rbx = 0x00007f3288d11370   rbp = 0x00007fff44373840
 17:39:48     INFO -      rsp = 0x00007fff44373800   r12 = 0x00007f32a950a9e4
 17:39:48     INFO -      r13 = 0x000
This shutdown crash occurs about 30% of the time on mochitest-e10s chunk 3 on win7-debug. Example log:

https://treeherder.mozilla.org/logviewer.html#?job_id=15415891&repo=try

This blocks us from enabling mochitest-e10s on win7-debug.
This looks like some kind of media shutdown issue. Randell, do you know who might be able to look at this?

Assertion failure: sMainThread, at c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/xpcom/threads/AbstractThread.cpp:116
#01: mozilla::`anonymous namespace'::MediaStreamGraphStableStateRunnable::Run() [dom/media/MediaStreamGraph.cpp:1373]
#02: mozilla::CycleCollectedJSRuntime::ProcessStableStateQueue() [xpcom/base/CycleCollectedJSRuntime.cpp:1107]
#03: mozilla::CycleCollectedJSRuntime::~CycleCollectedJSRuntime() [xpcom/base/CycleCollectedJSRuntime.cpp:468]
Flags: needinfo?(rjesup)
It looks like the crashes in comment 0 and comment 1 are happening during dom/media/webspeech/recognition/test/ so I guess some webspeech thing isn't being shut down properly?
Component: General → Web Speech
This is MSG trying to do threaded stuff after threads have shut down.
See also bug 1235968, which has a similar cause.  We've filed bug 1239873 to majorly revamp the MSG shutdown code to use AsyncShutdown blockers to guarantee it's shut down on the right phase(s), and to greatly simplify complex shutdown code.
Component: Web Speech → Audio/Video: MediaStreamGraph
Flags: needinfo?(rjesup)
See Also: → 1235968, 1239873
(In reply to Andrew McCreight [:mccr8] from comment #3)
> It looks like the crashes in comment 0 and comment 1 are happening during
> dom/media/webspeech/recognition/test/ so I guess some webspeech thing isn't
> being shut down properly?

Which might also be an issue independently of the MSG shutdown stuff.
I talked with Randell, and I'd like to move this back to Web Speech to confirm if there is a Web Speech issue or if this is just a MSG shutdown issue.  (We have a separate bug to redo the MSG shutdown code -- bug 1239873.)
Component: Audio/Video: MediaStreamGraph → Web Speech
This appears to have gone away on its own.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=47ed320124b0&group_state=expanded
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
See Also: → 1279612
This is nearly permafail on Windows on Beta right now. Maybe it's a variant of bug 1279612. Either way, not acceptable.
Status: RESOLVED → REOPENED
Flags: needinfo?(jwwang)
Resolution: WORKSFORME → ---
This is another manifestation of bug 1279612. Confirmed on Try that backing out bug 1255737 makes things much happier.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=0781a53a896eaf3a1a614694dee6148d216b0c26
See Also: → 1295228
See Also: → 1262031
It looks like MediaStreamGraphImpl is trying to use AbstractThread::sMainThread after shutdown begins.

https://hg.mozilla.org/releases/mozilla-beta/file/ffaec482162fe3f63debf3fcd22c14d57d036f11/xpcom/threads/AbstractThread.cpp#l137
Component: Web Speech → Audio/Video: MediaStreamGraph
Flags: needinfo?(jwwang)
Rank: 29
Priority: -- → P2
Depends on: 1239873
Looks like we finally slayed this dragon for good.
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.