Sync error No keyFetchToken after OTA

RESOLVED FIXED in 2.6 S6 - 1/29

Status

Firefox OS
Sync
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Rizky Ariestiyansyah, Assigned: ferjm)

Tracking

(Blocks: 1 bug, {foxfood})

unspecified
2.6 S6 - 1/29
foxfood

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

Attachments

(6 attachments)

(Reporter)

Description

2 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

1. Go to Settings
2. Select Firefox Sync
3. Press Get started
it will show this account is empty and I try to press sync now then get started again still doesnt work.

In this case my accont already had Firefox Sync in my OSX

Note: Build 20151230201227 dogwood
(Reporter)

Comment 1

2 years ago
Created attachment 8707722 [details]
system-b2g-application.ini
(Reporter)

Comment 2

2 years ago
Created attachment 8707723 [details]
dev-log-system.log
(Reporter)

Comment 3

2 years ago
Created attachment 8707724 [details]
dev-log-main.log
(Reporter)

Comment 4

2 years ago
Created attachment 8707725 [details]
properties.log
(Reporter)

Comment 5

2 years ago
Created attachment 8707726 [details]
screenshot.png
Hi Rizky,
Thank you for reporting this.

Please let me ask you a few questions so we can understand and investigate the problem:
-Which device are you using and what is the version (in Settings->Device info->More info)
-Can you tap on that Get started, add your account and then it goes back to that screen (Please see bug 1237731) or it is like you cannot tap on it to introduce your email/pssw?

I have tried with aries latest ota available (20151230) and seems to be working ok.
Thank you!
Flags: needinfo?(ariestiyansyah.rizky)
(Reporter)

Comment 7

2 years ago
When tap on get started button isnt working.

My phone: Sony z3c foxfooding device
Flags: needinfo?(ariestiyansyah.rizky)
Changing to Sync component and ni ferjm to check if he is aware of similar issues. Thanks!
Component: Gaia::Feedback → Sync
Flags: needinfo?(ferjmoreno)
Just reproduce this. I tapped on Get started and it did not do anything. I had disabled wifi and data, once enabled wifi it worked.

Rizky, could that be your case? Thanks!
Flags: needinfo?(ariestiyansyah.rizky)
(Assignee)

Comment 10

2 years ago
Thanks for the report Rizky. I am sorry to say that Firefox Sync is pretty much broken on the latest Sony z3c OTA. This OTA contains an almost one month old code that does not include many of the recent fixes that are already in master.

I can see this error in the logs that you provided: "Sync error No keyFetchToken". This can probably be fixed by login out of your Firefox Accounts and login back in again. But after that you will likely hit bug 1224203 which was not included in the z3c OTA. I am afraid that you'll need to wait for the next OTA update :\
Flags: needinfo?(ferjmoreno)
Summary: Firefox Sync does not work → Sync error No keyFetchToken after OTA
(Assignee)

Updated

2 years ago
Assignee: nobody → ferjmoreno
Blocks: 824026
Priority: -- → P1
Target Milestone: --- → 2.6 S6 - 1/29

Comment 11

2 years ago
Created attachment 8711138 [details] [review]
[gaia] ferjm:bug1239546.nokeyfetchtoken.patch > mozilla-b2g:master
(Assignee)

Comment 12

2 years ago
Comment on attachment 8711138 [details] [review]
[gaia] ferjm:bug1239546.nokeyfetchtoken.patch > mozilla-b2g:master

It is possible that devices getting an OTA where the user is already logged into FxA and where the fix from bug 1211606 is not present or was never executed (i.e. the user didn't logout/login from FxA) hit the "No key fetch token" error. In this case, the only thing that we can do is to log the user out of her FxA and ask her to login again.

As usual, Michiel, could you review the Sync part, please? Yura, could look at the Settings one, please? Thanks!
Attachment #8711138 - Flags: review?(yzenevich)
Attachment #8711138 - Flags: review?(mbdejong)
Attachment #8711138 - Flags: review?(mbdejong) → review+
Comment on attachment 8711138 [details] [review]
[gaia] ferjm:bug1239546.nokeyfetchtoken.patch > mozilla-b2g:master

Looks good with 1 problem addressed. Thanks
Attachment #8711138 - Flags: review?(yzenevich) → review+
(Reporter)

Comment 14

2 years ago
It solve my problem by login out and log in again. awesome
Flags: needinfo?(ariestiyansyah.rizky)
(Assignee)

Comment 15

2 years ago
https://github.com/mozilla-b2g/gaia/commit/627005324f60fba0b2da5681e355628a0f2bed69
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
To allow TVs to OTA from 2.1 to 2.5 later this year, this will need to be fixed in tv_apps/smart-system, and then be uplifted to 2.5, right?
Flags: needinfo?(ferjmoreno)
(Assignee)

Updated

2 years ago
blocking-b2g: --- → 2.5?
Flags: needinfo?(ferjmoreno)
(Assignee)

Comment 17

2 years ago
Maybe not. Is the 2.1 TV shipping with FxA integration?
blocking-b2g: 2.5? → ---
Flags: needinfo?(yliao)
Flags: needinfo?(jocheng)

Comment 18

2 years ago
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #17)
> Maybe not. Is the 2.1 TV shipping with FxA integration?

Hi Fernando,
We will not support FxA integration in 2.1. OTA should not be an issue for TV.
Flags: needinfo?(jocheng)

Updated

2 years ago
Flags: needinfo?(yliao)
You need to log in before you can comment on or make changes to this bug.