Design issues with new about:networking design

RESOLVED FIXED in Firefox 47

Status

()

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: soeren.hentzschel, Assigned: ntim)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 47
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 affected, firefox47 fixed)

Details

(Whiteboard: good first bug)

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
Created attachment 8711214 [details]
screenshot1.png

Images can say more than a thousand words.
(Reporter)

Comment 1

3 years ago
Created attachment 8711217 [details]
screenshot2.png
(Reporter)

Comment 2

3 years ago
Also the rows should have some top/bottom padding. Please have a look at the in content preferences, for example the list of installed search engines or the application pane. The height of the rows should be the same.
Whiteboard: good first bug
(In reply to Sören Hentzschel from comment #0)
> Created attachment 8711214 [details]
> Images can say more than a thousand words.

The line is intentional. It's supposed to separate the stats section (above), and the diagnostics section (below), which hasn't landed yet (bug 907050)

Comment 4

3 years ago
Created attachment 8711322 [details]
VirtualBox_Mac OS X (64 bit)_23_01_2016_19_36_20.png

On Mac OS X 10.6.8 Snow Leopard, no left margin and the warning image.
Created attachment 8714386 [details] [diff] [review]
about-networking-improved
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Attachment #8714386 - Flags: review?(jaws)

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/97fafd23a077
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
(Reporter)

Comment 8

3 years ago
The alignment issue you can see in the second screenshot was not addressed with this patch. Shall I file a new ticket or was it intentional not to change the warning page?
(In reply to Sören Hentzschel from comment #8)
> The alignment issue you can see in the second screenshot was not addressed
> with this patch. Shall I file a new ticket or was it intentional not to
> change the warning page?

The spacing is intentional, I've reduced it in this bug so it looks less out of place.
(Reporter)

Comment 10

3 years ago
But it's not consistent with about:config. Is there a reason for this style difference?
(In reply to Sören Hentzschel from comment #10)
> But it's not consistent with about:config. Is there a reason for this style
> difference?

about:config's warning screen has a description, about:networking doesn't. Consider the spacing as a replacement for the description :)
Created attachment 8716763 [details] [diff] [review]
followup: clean up aboutNetworking CSS
Attachment #8716763 - Flags: review?(jaws)
Comment on attachment 8716763 [details] [diff] [review]
followup: clean up aboutNetworking CSS

Review of attachment 8716763 [details] [diff] [review]:
-----------------------------------------------------------------

Please file a new bug for the follow-up, as the patches in this bug have already landed and it's been more than 24 hours since it was merged to mozilla-central. I'd rather not have one bug that has patches that span multiple Nightly builds, as it can make looking for regressions confusing.

r+ once you file a new bug for this and associate the patch with the new bug number. You can reference this comment in the new bug and carry-forward the r+.
Attachment #8716763 - Flags: review?(jaws) → review+
(Reporter)

Comment 14

3 years ago
(In reply to Tim Nguyen [:ntim] (mostly busy until Feb. 12th) from comment #11)
> (In reply to Sören Hentzschel from comment #10)
> > But it's not consistent with about:config. Is there a reason for this style
> > difference?
> 
> about:config's warning screen has a description, about:networking doesn't.
> Consider the spacing as a replacement for the description :)

Spacing is no replacement for a description. Even it is intentional, it looks like a style bug.
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #13)
> Comment on attachment 8716763 [details] [diff] [review]
> followup: clean up aboutNetworking CSS
> 
> Review of attachment 8716763 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Please file a new bug for the follow-up, as the patches in this bug have
> already landed and it's been more than 24 hours since it was merged to
> mozilla-central. I'd rather not have one bug that has patches that span
> multiple Nightly builds, as it can make looking for regressions confusing.
> 
> r+ once you file a new bug for this and associate the patch with the new bug
> number. You can reference this comment in the new bug and carry-forward the
> r+.

Thanks for the review ! Moved this to bug 1246498.
Created attachment 8716765 [details]
about-networking-no-spacing.png

Sören, removing the spacing doesn't look great either (too much negative spacing around the warning). Perhaps, we should consider adding a description to about:networking's warning instead ?
Yeah, a description would be best. Valentin, can you file a bug to add a description and include what you think it should say?
Flags: needinfo?(valentin.gosu)
I have reproduced this bug according to (2016-1-22)

It's fixed on Latest Developer Edition -- Build ID (20160408004012), User Agent: Mozilla/5.0 (Windows NT 6.3; rv:47.0) Gecko/20100101 Firefox/47.0

Tested OS-- Windows8.1 32bit
QA Whiteboard: [bugday-20160406]
I filed bug 1324792 for the description text.
Flags: needinfo?(valentin.gosu)
You need to log in before you can comment on or make changes to this bug.