Enable selection events outside of nightly

RESOLVED DUPLICATE of bug 1231923

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 1231923
a year ago
5 months ago

People

(Reporter: cyril.auburtin, Assigned: mystor)

Tracking

({testcase})

43 Branch
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 wontfix, firefox45 wontfix, firefox46 wontfix, firefox47 wontfix, firefox48 wontfix, firefox49 wontfix, firefox50 affected, firefox51 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.13 Safari/537.36

Steps to reproduce:

demo: http://jsfiddle.net/3wLt19ca/2/


Actual results:

wen selecting text, nothing happen in console, no selectionchange events


Expected results:

it should logs those events
Component: Untriaged → DOM: Events
Product: Firefox → Core
(Reporter)

Comment 1

a year ago
works on nightly

Comment 2

a year ago
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9771bd5e56edd07e21cf008dcadc20d7ed970ce3&tochange=9ed17db42e3e46f1c712e4dffd62d54e915e0fac

Bug 1196479 - Fire selectstart and selectionchange events on the input node when the selection in that editor changes. r=ehsan


See also bug 1248148, it has an opposite expectations.
Blocks: 1196479
status-firefox44: --- → affected
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → ?
Keywords: testcase
See Also: → bug 1248148
Version: 47 Branch → 45 Branch

Updated

a year ago
status-firefox44: affected → wontfix
Version: 45 Branch → 43 Branch
(Reporter)

Comment 3

10 months ago
document.addEventListener('selectionchange', e=>console.log('sel change')) is still not working in stable 47 and beta 48

Comment 4

10 months ago
Have we not enabled the events yet?
Flags: needinfo?(michael)
(Assignee)

Comment 5

10 months ago
(In reply to Olli Pettay [:smaug] (high review load, please consider other reviewers) from comment #4)
> Have we not enabled the events yet?

I don't believe we have enabled them yet. To do that we just need to set the dom.select_events.enabled pref.
Flags: needinfo?(michael)
(Reporter)

Comment 6

10 months ago
Thanks for enabling it, could you tell me for which version it'll land for sure? 
I've a polyfill http://jsfiddle.net/crl/rk6f74tw/32/ but I'd like to use only when necessary
(Reporter)

Comment 7

10 months ago
50 maybe?
(Assignee)

Updated

10 months ago
Assignee: nobody → michael
Summary: selectionchange event is not triggered → Enable selection events outside of nightly
(Assignee)

Comment 8

10 months ago
Created attachment 8764388 [details] [diff] [review]
Enable selection events outside of nightly

This patch enables selection events outside of nightly
(Assignee)

Comment 9

10 months ago
Comment on attachment 8764388 [details] [diff] [review]
Enable selection events outside of nightly

Review of attachment 8764388 [details] [diff] [review]:
-----------------------------------------------------------------

Smaug, do you think we're ready to enable these outside of nightly?
Attachment #8764388 - Flags: review?(bugs)

Comment 10

10 months ago
Comment on attachment 8764388 [details] [diff] [review]
Enable selection events outside of nightly

I guess so. At least we'd get more feedback and if there are regressions on aurora/beta, we can disable easily.
Attachment #8764388 - Flags: review?(bugs) → review+

Comment 11

9 months ago
Pushed by michael@thelayzells.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/08845358703f
Enable selection events outside of nightly, r=smaug

Comment 12

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/08845358703f
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Depends on: 1280534
(Assignee)

Updated

8 months ago
Depends on: 1298970
(Assignee)

Comment 13

8 months ago
Re-opening because of backout coming in bug 1280534 - Should be re-landable once bug 1298970 is fixed.
(Assignee)

Updated

8 months ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Merge of backout:
https://hg.mozilla.org/mozilla-central/rev/21fb1f17d958
status-firefox45: affected → wontfix
status-firefox46: affected → wontfix
status-firefox47: ? → wontfix
status-firefox48: --- → wontfix
status-firefox49: --- → wontfix
status-firefox50: fixed → affected
status-firefox51: --- → affected
Target Milestone: mozilla50 → ---
And from Aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/6b222a7b59be
Keywords: dev-doc-needed
(Assignee)

Updated

7 months ago
Status: REOPENED → RESOLVED
Last Resolved: 9 months ago7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231923
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.