Intermittent browser_newtab_undo.js | grid status = 5p,1,2,4,6,7,8 - Got 5p,0,1,2,4,6,7, expected 5p,1,2,4,6,7,8

RESOLVED FIXED in Firefox 60

Status

()

P3
normal
RESOLVED FIXED
3 years ago
5 months ago

People

(Reporter: cbook, Assigned: gbrown)

Tracking

({intermittent-failure, leave-open})

unspecified
Firefox 60
intermittent-failure, leave-open
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 fixed)

Details

(Whiteboard: [test disabled on Linux][stockwell disabled], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=20574019&repo=mozilla-inbound

 07:00:35     INFO -  93 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/newtab/browser_newtab_undo.js | grid status = 5p,1,2,4,6,7,8 - Got 5p,0,1,2,4,6,7, expected 5p,1,2,4,6,7,8

 07:00:35     INFO -  Stack trace:

 07:00:35     INFO -      chrome://mochikit/content/browser-test.js:test_is:979

 07:00:35     INFO -      chrome://mochitests/content/browser/browser/base/content/test/newtab/head.js:checkGrid:359

 07:00:35     INFO -      chrome://mochitests/content/browser/browser/base/content/test/newtab/browser_newtab_undo.js:null:31

 07:00:35     INFO -      Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23

 07:00:35     INFO -      this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7

 07:00:35     INFO -      Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747:11

 07:00:35     INFO -      this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:779:7

 07:00:35     INFO -      this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:714:7

 07:00:35     INFO -      TaskImpl_run@resource://gre/modules/Task.jsm:324:13

 07:00:35     INFO -      promise callback*TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:395:7

 07:00:35     INFO -      TaskImpl_run@resource://gre/modules/Task.jsm:327:13

 07:00:35     INFO -      promise callback*TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:395:7

 07:00:35     INFO -      TaskImpl_run@resource://gre/modules/Task.jsm:327:13

 07:00:35     INFO -      TaskImpl@resource://gre/modules/Task.jsm:280:3

 07:00:35     INFO -      createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:254:14

 07:00:35     INFO -      Task_spawn@resource://gre/modules/Task.jsm:168:12

 07:00:35     INFO -      setup@chrome://mochitests/content/browser/browser/base/content/test/newtab/head.js:134:22

 07:00:35     INFO -      TaskImpl_run@resource://gre/modules/Task.jsm:319:40

 07:00:35     INFO -      TaskImpl@resource://gre/modules/Task.jsm:280:3

 07:00:35     INFO -      createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:254:14

 07:00:35     INFO -      Task_spawn@resource://gre/modules/Task.jsm:168:12

 07:00:35     INFO -      TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:388:16

 07:00:35     INFO -      TaskImpl_run@resource://gre/modules/Task.jsm:327:13

 07:00:35     INFO -      TaskImpl@resource://gre/modules/Task.jsm:280:3

 07:00:35     INFO -      createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:254:14

 07:00:35     INFO -      Task_spawn@resource://gre/modules/Task.jsm:168:12

 07:00:35     INFO -      Tester_execTest@chrome://mochikit/content/browser-test.js:803:9

 07:00:35     INFO -      Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:723:7

 07:00:35     INFO -      SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:741:59

 07:00:35     INFO -  Not taking screenshot here: see the one that was previously logged
Comment hidden (Intermittent Failures Robot)

Updated

3 years ago
Component: Tabbed Browser → New Tab Page
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Blocks: 1240014
Flags: needinfo?(enndeakin)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Comment 8

3 years ago
Very likely the same issue as 1243103 and will be fixed by that bug.
Depends on: 1243103
Flags: needinfo?(enndeakin)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Keywords: leave-open
Whiteboard: [test disabled on Linux]
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Comment 22

3 years ago
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 25

2 years ago
Failing on Windows 7 Debug, e10s only, re-starting with, possibly, https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=a8d2fc52fdeec706da43fd2ae824a03a462fce82.

If bug 1243103 does not re-occur for a few days, we should consider running this test in a subsuite also.
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 27

2 years ago
(In reply to Geoff Brown [:gbrown] from comment #25)
> Failing on Windows 7 Debug, e10s only, re-starting with, possibly,
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=a8d2fc52fdeec706da43fd2ae824a03a462fce82.

Or maybe bug 1303113, which affected a lot of tests on e10s and landed a few revisions earlier.
(Assignee)

Comment 28

2 years ago
Created attachment 8830395 [details] [diff] [review]
move test to subsuite

I have no idea of root cause here; I'm just noting that the subsuite change seemed effective for bug 1243103 and hoping it will do good things here.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=71170510ff61de678272fef4e511195b8ee14fe8
Attachment #8830395 - Flags: review?(jmaher)
Comment on attachment 8830395 [details] [diff] [review]
move test to subsuite

Review of attachment 8830395 [details] [diff] [review]:
-----------------------------------------------------------------

thanks!
Attachment #8830395 - Flags: review?(jmaher) → review+

Comment 30

2 years ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/911a2b9a2a26
Move browser_newtab_undo.js to clipboard subsuite; r=jmaher
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Whiteboard: [test disabled on Linux] → [test disabled on Linux][stockwell disabled]

Comment 35

a year ago
Test was removed in bug 1433133 https://hg.mozilla.org/mozilla-central/rev/fc80dd3e4fae
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox60: --- → fixed
Depends on: 1433133
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Assignee: nobody → gbrown
You need to log in before you can comment on or make changes to this bug.